]> git.pld-linux.org Git - packages/freya.git/blob - freya.spec
17e9f7404a8c52fca0055e4bc200d3e4ff622d31
[packages/freya.git] / freya.spec
1 #
2 # Conditional build:
3 %bcond_with     avahi           # build with Avahi (Built-in Serverlist)
4 %bcond_without  glyr    # build with libglyr (Now Playing Browser)
5 %bcond_with     libnotify       # build with libnotify (For notifcations)
6
7 # TODO
8 # - fails to understand libnotify is there
9 #   -- checking for modules 'OPTIONAL;libnotify'
10 #   --   package 'OPTIONAL' not found
11 #   Disabling libnotify support, since deps were not found.
12 # - does not support out of tree build:
13 #   freya-1.0.2/src/Init/cmdoptions.cc:10:26: fatal error: ../../config.h: No such file or directory
14 # - avahi build fails:
15 #   freya-1.0.2/src/Browser/Avahi/ServerList.hh:88:5: error: 'Avahi' does not name a type
16 #   freya-1.0.2/src/Browser/Avahi/ServerList.cc: In constructor 'Browser::ServerList::ServerList(Glib::RefPtr<Gtk::Builder>&, GManager::BrowserList&)':
17 #   freya-1.0.2/src/Browser/Avahi/ServerList.cc:51:5: error: 'avahi_handle' was not declared in this scope
18 # - mpdclinet link fails:
19 #   freya-1.0.2/src/MPD/Client.cc: In member function 'virtual void MPD::Client::fill_playlists(MPD::AbstractItemlist&)':
20 #   freya-1.0.2/src/MPD/Client.cc:278:40: error: 'mpd_send_list_playlists' was not declared in this scope
21 Summary:        A simple and slim mpd client
22 Name:           freya
23 Version:        1.0.2
24 Release:        0.1
25 License:        GPL v3+
26 Group:          Applications/Multimedia
27 URL:            https://github.com/studentkittens/Freya
28 # VCS: git:https://github.com/studentkittens/Freya.git
29 Source0:        https://github.com/studentkittens/Freya/tarball/master/%{name}.tgz
30 # Source0-md5:  6e6686e2ef4845c17e32183d33405cc4
31 %{?with_avahi:BuildRequires:    avahi-devel}
32 %{?with_avahi:BuildRequires:    avahi-glib-devel}
33 BuildRequires:  cmake
34 BuildRequires:  glibmm-devel
35 BuildRequires:  glyr-devel
36 BuildRequires:  gtkmm3-devel
37 BuildRequires:  libmpdclient-devel
38 BuildRequires:  libnotify-devel
39 BuildRequires:  libxml2-devel
40 BuildRequires:  pkgconfig
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A fun and slim Client for the MPD Server.
45
46 %prep
47 %setup -qc
48 mv *-Freya-*/* .
49
50 %build
51 %cmake \
52         -DUSE_GLYR=%{!?with_glyr:NO}%{?with_glyr:YES} \
53         -DUSE_LIBNOTIFY=%{!?with_libnotify:NO}%{?with_libnotify:YES} \
54         -DUSE_AVAHI=%{!?with_avahi:NO}%{?with_avahi:YES} \
55         .
56 %{__make} -j1
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %find_lang %{name}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files -f %{name}.lang
69 %defattr(644,root,root,755)
70 %doc README.textile
This page took 0.052294 seconds and 2 git commands to generate.