]> git.pld-linux.org Git - packages/freewrl.git/blobdiff - freewrl-optimize.patch
- updated for 1.19.8
[packages/freewrl.git] / freewrl-optimize.patch
index bf40f1ff8b1b1d119cd00b17998bd4588e3022b7..bd0d27c9d039c5841cf197918450c7ae866323a2 100644 (file)
@@ -1,56 +1,53 @@
-diff -uNr freewrl-1.17.4.orig/CFrontEnd/Makefile freewrl-1.17.4/CFrontEnd/Makefile
---- freewrl-1.17.4.orig/CFrontEnd/Makefile     2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/CFrontEnd/Makefile  2006-06-07 10:35:47.000000000 +0200
-@@ -11,15 +11,15 @@
-       cp freewrl $(BINDIR)
- fwopts:
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) fwopts.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) fwopts.c
- fwWindow:
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) fwWindow.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) fwWindow.c
- freewrl: fwopts fwWindow
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) freewrl.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) freewrl.c
--      $(CC) -L../blib/arch/auto/VRML/VRMLFunc -o freewrl \
-+      $(CC) $(OPTIMIZE) -L../blib/arch/auto/VRML/VRMLFunc -o freewrl \
-       freewrl.o fwopts.o fwWindow.o \
-       `perl -MExtUtils::Embed -e ccopts -e ldopts` \
-       $(LIBS) \
-diff -uNr freewrl-1.17.4.orig/FreeWRL_Message/Makefile freewrl-1.17.4/FreeWRL_Message/Makefile
---- freewrl-1.17.4.orig/FreeWRL_Message/Makefile       2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/FreeWRL_Message/Makefile    2006-06-07 10:36:41.000000000 +0200
-@@ -3,7 +3,7 @@
- COMPILERFLAGS = -Wall
- CC = gcc
--CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
-+CFLAGS = $(COMPILERFLAGS) $(INCLUDE) $(OPTIMIZE)  
- # use this for better borders on window LIBRARIES = -lXaw3d
- LIBRARIES = -lXaw
- SVROBJ = FreeWRL_Message.o
-diff -uNr freewrl-1.17.4.orig/Plugin/Makefile freewrl-1.17.4/Plugin/Makefile
---- freewrl-1.17.4.orig/Plugin/Makefile        2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/Plugin/Makefile     2006-06-07 10:37:32.000000000 +0200
-@@ -45,13 +45,13 @@
-       cp $(SHAREDTARGET) $(PLUGDIR)
- $(SHAREDTARGET): $(OBJ)
--      $(CC) -shared -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
-+      $(CC) -shared -o $(SHAREDTARGET) $(OBJ) $(OPTIMIZE) $(LDFLAGS)
- npfreewrl.o: netscape/source/npfreewrl.c
--      $(CC) -c $(CFLAGS) netscape/source/npfreewrl.c
-+      $(CC) -c $(CFLAGS) $(OPTIMIZE) netscape/source/npfreewrl.c
- npunix.o: netscape/source/common/npunix.c
--      $(CC) -c $(CFLAGS) netscape/source/common/npunix.c
-+      $(CC) -c $(CFLAGS) $(OPTIMIZE) netscape/source/common/npunix.c
- clean:
-       $(RM) $(OBJ) $(SHAREDTARGET)
-
+--- freewrl-1.19.8/Makefile.PL.orig    2008-01-12 19:26:25.187644000 +0100
++++ freewrl-1.19.8/Makefile.PL 2008-01-12 19:49:11.737519783 +0100
+@@ -253,14 +253,7 @@
+       print MK "JAVAC = javac\n";
+       print MK "INC = $MYINC\n";
+       print MK "DEFINE = $noStackProtector $MYDEFINE\n";
+-      #print MK "FWFLAGS = -c -Wall -O2 -g -pipe -m32 -march=i386 -mtune=pentium4\n";
+-
+-      # different compiler flags for different architectures
+-      if ($ARCH eq "x86_64") {
+-              print MK "FWFLAGS = -c -O2 -g -pipe -m32 -march=i386 -mtune=pentium4\n";
+-      } else {
+-              print MK "FWFLAGS = -c -O2 -g -pipe -fno-strict-aliasing -fPIC\n";
+-      }
++      print MK "FWFLAGS = -c -Wall \$(OPTIMIZE) -pipe -fno-strict-aliasing -fPIC\n";
+       print MK "MYLIBS = $MYLIBS\n";
+       print MK "MYFELIBS = $MYFELIBS\n";
+       print MK "MYSELIBS = $MYSELIBS\n";
+@@ -386,10 +379,13 @@
+       #LIBFREEWRL
+       print MK "\$(LIBFWSRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "libFreeWRL:      \$(LIBFWOBJS)\n";
+       if ($OS eq "Darwin") { 
++      print MK "libFreeWRL:      libFreeWRLFunc.dylib\n\n";
++      print MK "libFreeWRLFunc.dylib:      \$(LIBFWOBJS)\n";
+       print MK "\t\$(CC) -dynamiclib \$(MYFELIBS) \$(MYLDFLAGS) -o libFreeWRLFunc.dylib  \$(MYLIBS) \$(LIBFWOBJS)\n\n";
+       } else {
++      print MK "libFreeWRL:      libFreeWRLFunc.so\n\n";
++      print MK "libFreeWRLFunc.so:      \$(LIBFWOBJS)\n";
+       print MK "\t\$(CC) -shared -o libFreeWRLFunc.so \$(LIBFWOBJS)\n\n";
+       }
+ }
+@@ -402,7 +398,8 @@
+       print MK "\n# make the Unix front end\n";
+       print MK "\$(FESRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "CFrontEnd:      \$(FEOBJS)\n";
++      print MK "CFrontEnd:      CFrontEnd/freewrl\n\n";
++      print MK "CFrontEnd/freewrl:      \$(FEOBJS)\n";
+       print MK "\t\$(CC) \$(FEOBJS) \$(MYFELIBS) -o CFrontEnd/freewrl\n\n";
+       }
+ }
+@@ -432,7 +429,8 @@
+       print MK "\n# make the Unix Console Message \n";
+       print MK "\$(FWMSRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "FreeWRL_Message:      \$(FWMOBJS)\n";
++      print MK "FreeWRL_Message:      FreeWRL_Msg/FreeWRL_Message\n\n";
++      print MK "FreeWRL_Msg/FreeWRL_Message:      \$(FWMOBJS)\n";
+       print MK "\t\$(CC) FreeWRL_Msg/FreeWRL_Message.o  -o FreeWRL_Msg/FreeWRL_Message \$(MYLIBS) \$(MYMESLIBS) \n\n";
+       }
+ }
This page took 0.080106 seconds and 4 git commands to generate.