]> git.pld-linux.org Git - packages/freewrl.git/commitdiff
- updated for 1.19.8
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 12 Jan 2008 19:25:23 +0000 (19:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    freewrl-optimize.patch -> 1.2
    freewrl-system-js.patch -> 1.6

freewrl-optimize.patch
freewrl-system-js.patch

index bf40f1ff8b1b1d119cd00b17998bd4588e3022b7..bd0d27c9d039c5841cf197918450c7ae866323a2 100644 (file)
@@ -1,56 +1,53 @@
-diff -uNr freewrl-1.17.4.orig/CFrontEnd/Makefile freewrl-1.17.4/CFrontEnd/Makefile
---- freewrl-1.17.4.orig/CFrontEnd/Makefile     2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/CFrontEnd/Makefile  2006-06-07 10:35:47.000000000 +0200
-@@ -11,15 +11,15 @@
-       cp freewrl $(BINDIR)
- fwopts:
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) fwopts.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) fwopts.c
- fwWindow:
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) fwWindow.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) fwWindow.c
- freewrl: fwopts fwWindow
--      $(CC) $(INC) $(FWFLAGS) $(DEFINE) freewrl.c
-+      $(CC) $(INC) $(FWFLAGS) $(DEFINE) $(OPTIMIZE) freewrl.c
--      $(CC) -L../blib/arch/auto/VRML/VRMLFunc -o freewrl \
-+      $(CC) $(OPTIMIZE) -L../blib/arch/auto/VRML/VRMLFunc -o freewrl \
-       freewrl.o fwopts.o fwWindow.o \
-       `perl -MExtUtils::Embed -e ccopts -e ldopts` \
-       $(LIBS) \
-diff -uNr freewrl-1.17.4.orig/FreeWRL_Message/Makefile freewrl-1.17.4/FreeWRL_Message/Makefile
---- freewrl-1.17.4.orig/FreeWRL_Message/Makefile       2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/FreeWRL_Message/Makefile    2006-06-07 10:36:41.000000000 +0200
-@@ -3,7 +3,7 @@
- COMPILERFLAGS = -Wall
- CC = gcc
--CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
-+CFLAGS = $(COMPILERFLAGS) $(INCLUDE) $(OPTIMIZE)  
- # use this for better borders on window LIBRARIES = -lXaw3d
- LIBRARIES = -lXaw
- SVROBJ = FreeWRL_Message.o
-diff -uNr freewrl-1.17.4.orig/Plugin/Makefile freewrl-1.17.4/Plugin/Makefile
---- freewrl-1.17.4.orig/Plugin/Makefile        2006-05-10 16:50:23.000000000 +0200
-+++ freewrl-1.17.4/Plugin/Makefile     2006-06-07 10:37:32.000000000 +0200
-@@ -45,13 +45,13 @@
-       cp $(SHAREDTARGET) $(PLUGDIR)
- $(SHAREDTARGET): $(OBJ)
--      $(CC) -shared -o $(SHAREDTARGET) $(OBJ) $(LDFLAGS)
-+      $(CC) -shared -o $(SHAREDTARGET) $(OBJ) $(OPTIMIZE) $(LDFLAGS)
- npfreewrl.o: netscape/source/npfreewrl.c
--      $(CC) -c $(CFLAGS) netscape/source/npfreewrl.c
-+      $(CC) -c $(CFLAGS) $(OPTIMIZE) netscape/source/npfreewrl.c
- npunix.o: netscape/source/common/npunix.c
--      $(CC) -c $(CFLAGS) netscape/source/common/npunix.c
-+      $(CC) -c $(CFLAGS) $(OPTIMIZE) netscape/source/common/npunix.c
- clean:
-       $(RM) $(OBJ) $(SHAREDTARGET)
-
+--- freewrl-1.19.8/Makefile.PL.orig    2008-01-12 19:26:25.187644000 +0100
++++ freewrl-1.19.8/Makefile.PL 2008-01-12 19:49:11.737519783 +0100
+@@ -253,14 +253,7 @@
+       print MK "JAVAC = javac\n";
+       print MK "INC = $MYINC\n";
+       print MK "DEFINE = $noStackProtector $MYDEFINE\n";
+-      #print MK "FWFLAGS = -c -Wall -O2 -g -pipe -m32 -march=i386 -mtune=pentium4\n";
+-
+-      # different compiler flags for different architectures
+-      if ($ARCH eq "x86_64") {
+-              print MK "FWFLAGS = -c -O2 -g -pipe -m32 -march=i386 -mtune=pentium4\n";
+-      } else {
+-              print MK "FWFLAGS = -c -O2 -g -pipe -fno-strict-aliasing -fPIC\n";
+-      }
++      print MK "FWFLAGS = -c -Wall \$(OPTIMIZE) -pipe -fno-strict-aliasing -fPIC\n";
+       print MK "MYLIBS = $MYLIBS\n";
+       print MK "MYFELIBS = $MYFELIBS\n";
+       print MK "MYSELIBS = $MYSELIBS\n";
+@@ -386,10 +379,13 @@
+       #LIBFREEWRL
+       print MK "\$(LIBFWSRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "libFreeWRL:      \$(LIBFWOBJS)\n";
+       if ($OS eq "Darwin") { 
++      print MK "libFreeWRL:      libFreeWRLFunc.dylib\n\n";
++      print MK "libFreeWRLFunc.dylib:      \$(LIBFWOBJS)\n";
+       print MK "\t\$(CC) -dynamiclib \$(MYFELIBS) \$(MYLDFLAGS) -o libFreeWRLFunc.dylib  \$(MYLIBS) \$(LIBFWOBJS)\n\n";
+       } else {
++      print MK "libFreeWRL:      libFreeWRLFunc.so\n\n";
++      print MK "libFreeWRLFunc.so:      \$(LIBFWOBJS)\n";
+       print MK "\t\$(CC) -shared -o libFreeWRLFunc.so \$(LIBFWOBJS)\n\n";
+       }
+ }
+@@ -402,7 +398,8 @@
+       print MK "\n# make the Unix front end\n";
+       print MK "\$(FESRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "CFrontEnd:      \$(FEOBJS)\n";
++      print MK "CFrontEnd:      CFrontEnd/freewrl\n\n";
++      print MK "CFrontEnd/freewrl:      \$(FEOBJS)\n";
+       print MK "\t\$(CC) \$(FEOBJS) \$(MYFELIBS) -o CFrontEnd/freewrl\n\n";
+       }
+ }
+@@ -432,7 +429,8 @@
+       print MK "\n# make the Unix Console Message \n";
+       print MK "\$(FWMSRCS):\n";
+       print MK "\t\$(CC) -c \$*.c\n\n";
+-      print MK "FreeWRL_Message:      \$(FWMOBJS)\n";
++      print MK "FreeWRL_Message:      FreeWRL_Msg/FreeWRL_Message\n\n";
++      print MK "FreeWRL_Msg/FreeWRL_Message:      \$(FWMOBJS)\n";
+       print MK "\t\$(CC) FreeWRL_Msg/FreeWRL_Message.o  -o FreeWRL_Msg/FreeWRL_Message \$(MYLIBS) \$(MYMESLIBS) \n\n";
+       }
+ }
index dcdb6fc849f6975e63c1675679fd59aa7b27fb47..d23f217b9a24c97e618f56e7b2e33f9860d1d1f9 100644 (file)
---- FreeWRL-1.13/Makefile.PL.orig      2005-04-25 15:47:19.000000000 +0200
-+++ FreeWRL-1.13/Makefile.PL   2005-04-28 22:16:18.330867064 +0200
-@@ -412,8 +384,6 @@
-                       push(@postamble, join(
-                               "\n",
-                               qq{# make the libFreeWRLFunc shared library active\n},
--                              qq{\tcp blib/arch/auto/VRML/VRMLFunc/VRMLFunc.so \$(DESTDIR)$LIB_DIR/libFreeWRLFunc.so\n},
--                              qq{\t/sbin/ldconfig\n}
-                       ));
+--- freewrl-1.19.8/Makefile.PL.orig    2008-01-12 18:27:02.568622000 +0100
++++ freewrl-1.19.8/Makefile.PL 2008-01-12 19:24:10.279956593 +0100
+@@ -108,8 +108,6 @@
+ ## Handle platform-specific compile options for the Javascript engine
+ ## and others specific to FreeWRL.
+-my $jsdir = "js1.5/src";
+-my $jsobjdir;
+ my $noStackProtector = "";
+ my @inc;
+@@ -119,21 +117,6 @@
+ my @jslibs;
+-if ($OS eq  "IRIX64") {
+-      $jsobjdir = "$jsdir/IRIX6.5";
+-} elsif ($OS eq "Darwin") {
+-      $jsobjdir = "$jsdir/Darwin";
+-} elsif ($OS eq "SunOS") {
+-      $jsobjdir = "$jsdir/SunOS5.8";
+-} else { ## linux used by default
+-      $jsobjdir = "$jsdir/Linux_All";
+-}
+-
+-#location of the spidermonkey js engine.
+-$jsobjdir .= "_OPT.OBJ";
+-my $libFreeWRLjspath = "./JS/".$jsobjdir."/libFreeWRLjs.so";
+-
+-#print "the javascript engine should be located at: $libFreeWRLjspath\n";
+@@ -155,11 +138,8 @@
+       print "this system does not use the -fno-stack-protector flag\n";
+ }
+-push @inc, $VRML_CONFIG{FREEWRL_INC}, "-IJS/$jsobjdir", "-IJS/$jsdir", "-ICFuncs -ICFrontEnd ";
+-push @libs, $VRML_CONFIG{FREEWRL_LIBS}, "-LJS/$jsobjdir", "-lFreeWRLjs";
+-if ($OS eq "Darwin") {
+-push @ldflags, $VRML_CONFIG{LDFLAGS}, "-LJS/$jsobjdir";
+-}
++push @inc, $VRML_CONFIG{FREEWRL_INC}, "-I/usr/include/js", "-ICFuncs -ICFrontEnd ";
++push @libs, $VRML_CONFIG{FREEWRL_LIBS}, "-ljs";
+ # push build directory, for running standalone
+@@ -314,10 +294,7 @@
+       }
+       if ($OS eq "Linux") {
+               print MK "\tinstall -D libFreeWRLFunc.so \$(DESTDIR)\$(LIB_DIR)/libFreeWRLFunc.so\n";
+-              print MK "\tinstall -D $libFreeWRLjspath \$(DESTDIR)\$(LIB_DIR)/libFreeWRLjs.so\n";
+-
+               if ($CHCON ne "") {
+-                      print MK "\t-$CHCON -t texrel_shlib_t  \$(DESTDIR)\$(LIB_DIR)/libFreeWRLjs.so\n";
+                       print MK "\t-$CHCON -t texrel_shlib_t  \$(DESTDIR)\$(LIB_DIR)/libFreeWRLFunc.so\n";
                }
-               if ($OS eq "Darwin") {
-@@ -462,11 +432,6 @@
-               ###################################################
-               # lets do the clean:: targets at this step.
-               ###################################################
--              push(@postamble, join(
--                        "\n",
--                        qq{clean ::},
--                        qq{\tcd JS/$jsdir && \$(MAKE) -f Makefile.ref BUILD_OPT=$BUILD_OPT clean\n},
--                       ));
-               if ($OS ne "Darwin") {
-                       push(@postamble, join(
-                         "\n",
-@@ -479,11 +444,6 @@
-               ###################################################
-               # lets do the distclean:: targets at this step.
-               ###################################################
--              push(@postamble, join(
--                        "\n",
--                        qq{distclean :: realclean},
--                        qq{\tcd JS/$jsdir && \$(MAKE) -f Makefile.ref BUILD_OPT=$BUILD_OPT clobber},
--                       ));
-               if ($OS ne "Darwin") {
-                       push(@postamble, join(
-                         "\n",
-@@ -504,8 +464,6 @@
-               if ($OS eq "Linux") {
-                       push(@postamble, join(
-                               "\n",
--                              #qq{\tcp blib/arch/auto/VRML/VRMLFunc/VRMLFunc.so $LIB_DIR/libFreeWRLFunc.so\n},
--                              #qq{\t/sbin/ldconfig\n}
-                               qq{\t\tcp -f blib/arch/auto/VRML/VRMLFunc/VRMLFunc.so blib/arch/auto/VRML/VRMLFunc/libFreeWRLFunc.so\n},
-                       ));
+               if ($HAVE_UBUNTU eq "NO") {
+@@ -461,11 +438,9 @@
+ }
+ sub write_linux_makefile_javascript() {
+-      #############################################################################
+-      ## make the Javascript libraries if needed
+     
+       print MK "Javascript:\n";
+-      print MK "\tcd JS/$jsdir; make -f Makefile.ref BUILD_OPT=1 STACKPROT=$noStackProtector; cd $pwd\n";
++      print MK "\n";
+ }
+@@ -556,7 +531,6 @@
+               print MK "\techo \"%files\" >> $specfile\n";
+               print MK "\techo \"%defattr(-,root,root)\" >> $specfile\n";
+               print MK "\techo \"\$(DESTDIR)\$(LIB_DIR)/libFreeWRLFunc.so\" >> $specfile\n";
+-              print MK "\techo \"\$(DESTDIR)\$(LIB_DIR)/libFreeWRLjs.so\" >> $specfile\n";
+               print MK "\techo \"\$(DESTDIR)\$(FRONTEND_DIR)/FreeWRL_Message\" >> $specfile\n";
+               print MK "\techo \"\$(DESTDIR)\$(FRONTEND_DIR)/freewrl\" >> $specfile\n";
+               print MK "\techo \"\$(DESTDIR)\$(FRONTEND_DIR)/FreeWRL_SoundServer\" >> $specfile\n";
+@@ -597,19 +571,11 @@
+       print MK "      rm -f java/classes/sai/eai/*class\n";
+       print MK "      rm -f java/classes/org/web3d/x3d/sai/*class\n";
+       print MK "      rm -f java/classes/vrml.jar\n";
+-      print MK "      rm -rf JS/$jsobjdir\n";
+       if ($OS eq "Darwin") {
+               print MK "      rm -f /usr/local/lib/libFreeWRLFunc.dylib\n";
+-              print MK "      rm -f /usr/local/lib/libFreeWRLjs.dylib\n";
+       }
+-      # remove other JS directories
+-      $jsobjdir =~s/src/src\/editline/;
+-      print MK "      rm -rf JS/$jsobjdir\n";
+-      $jsobjdir =~ s/editline/fdlibm/;
+-      print MK "      rm -rf JS/$jsobjdir\n";
+-
+       print MK "\n#remove installed images\n";
+       print MK "distclean:    clean\n";
+       print MK "\trm -f \$(DESTDIR)\$(FRONTEND_DIR)/freewrl\n";
+@@ -617,7 +583,6 @@
+       
+       if ($OS eq "Linux") {
+               print MK "\trm -f \$(DESTDIR)\$(LIB_DIR)/libFreeWRLFunc.so\n";
+-              print MK "\trm -f \$(DESTDIR)\$(LIB_DIR)/libFreeWRLjs.so\n";
+               if ($HAVE_UBUNTU eq "NO") {
+ #                     print MK "\t/sbin/ldconfig\n";
                }
This page took 0.093425 seconds and 4 git commands to generate.