]> git.pld-linux.org Git - packages/freewrl.git/blob - freewrl.spec
- fixed mozilla libdir, other cleanups
[packages/freewrl.git] / freewrl.spec
1 # TODO:
2 # - install fonts system-wide (subpackage?)
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        FreeWRL - VRML browser
5 Summary(pl):    FreeWRL - przegl±darka VRML
6 Name:           freewrl
7 Version:        1.03
8 Release:        2
9 License:        LGPL
10 Group:          X11/Applications/Graphics
11 Source0:        http://dl.sourceforge.net/freewrl/FreeWRL-%{version}.tar.gz
12 # Source0-md5:  cb4435f5f64cebd6b0cc5cf831fb186f
13 Patch0:         %{name}-config.patch
14 Patch1:         %{name}-DESTDIR.patch
15 Patch2:         %{name}-mozilla.patch
16 Patch3:         %{name}-gcc3.patch
17 Patch4:         %{name}-system-js.patch
18 URL:            http://freewrl.sourceforge.net/
19 BuildRequires:  ImageMagick
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  freetype-devel
23 BuildRequires:  gtk+2-devel
24 BuildRequires:  jar
25 BuildRequires:  jdk
26 BuildRequires:  js-devel
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  mozilla-devel
30 BuildRequires:  mozilla-embedded(gtk2)
31 BuildRequires:  perl-devel >= 1:5.8.0
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  saxon
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         mozilladir      /usr/%{_lib}/mozilla
38 %define         netscapedir     /usr/%{_lib}/netscape
39
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
41 # false positives found by perlreq from rpm 4.1
42 %define         _noautoreq      'perl(VRML::Events)' 'perl(VRML::VRMLCU)' 'perl(VRML::VRMLFields)' 'perl(VRML::VRMLNodes)' 'perl(VRMLFields)' 'perl(VRMLNodes)' 'perl(VRMLRend)'
43
44 %description
45 FreeWRL - VRML browser.
46
47 %description -l pl
48 FreeWRL - przegl±darka VRML.
49
50 %package -n mozilla-plugin-freewrl
51 Summary:        VRML plugin for Mozilla WWW browser
52 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Mozilla
53 Group:          Libraries
54 Requires:       %{name} = %{version}
55 Requires:       mozilla-embedded(gtk2)
56
57 %description -n mozilla-plugin-freewrl
58 VRML plugin for Mozilla WWW browser.
59
60 %description -n mozilla-plugin-freewrl -l pl
61 Wtyczka VRML dla przegl±darki WWW Mozilla.
62
63 %package -n netscape-plugin-freewrl
64 Summary:        VRML plugin for Netscape WWW browser
65 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Netscape
66 Group:          Libraries
67 Requires:       %{name} = %{version}
68
69 %description -n netscape-plugin-freewrl
70 VRML plugin for Netscape WWW browser.
71
72 %description -n netscape-plugin-freewrl -l pl
73 Wtyczka VRML dla przegl±darki WWW Netscape.
74
75 %prep
76 %setup -q -n FreeWRL-%{version}
77 %patch0 -p1
78 %patch1 -p1
79 # for mozilla plugin - removed intentionaly?
80 #%patch2 -p1
81 #%patch3 -p1
82 %patch4 -p1
83
84 %build
85 %{__perl} Makefile.PL \
86         INSTALLDIRS=vendor
87 %{__make} \
88         OPTIMIZE="%{rpmcflags}" \
89         OPTIMIZER="%{rpmcflags}"
90 #       MOZILLA_INC="/usr/include/mozilla" \
91 #       GTK_CONFIG="pkg-config gtk+-2.0"
92
93 %{__make} -C Plugin/netscape \
94         OPTIMIZER="%{rpmcflags}"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{mozilladir}/{plugins,java/classes},%{netscapedir}/plugins}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         SITEARCHEXP=$RPM_BUILD_ROOT%{perl_vendorarch}
103
104 #install Plugin/mozilla/_lib/npFreeWRL.so $RPM_BUILD_ROOT%{mozilladir}/plugins
105
106 install Plugin/netscape/_lib/npfreewrl.so $RPM_BUILD_ROOT%{mozilladir}/plugins
107 install Plugin/netscape/_lib/npfreewrl.so $RPM_BUILD_ROOT%{netscapedir}/plugins
108
109 # no such directory, don't know how to make mozilla+java load this jar
110 # without placing it in /usr/lib/java/jre/lib/ext :/
111 #install java/classes/vrml.jar $RPM_BUILD_ROOT%{mozilladir}/java/classes
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README.html
119 %attr(755,root,root) %{_bindir}/*
120 %{perl_vendorarch}/VRML
121 %dir %{perl_vendorarch}/auto/VRML
122 %dir %{perl_vendorarch}/auto/VRML/*
123 %{perl_vendorarch}/auto/VRML/*/*.bs
124 %attr(755,root,root) %{perl_vendorarch}/auto/VRML/*/*.so
125 %{_mandir}/man1/*.1*
126 %{_mandir}/man3/*.3*
127
128 %files -n mozilla-plugin-freewrl
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{mozilladir}/plugins/*.so
131
132 %files -n netscape-plugin-freewrl
133 %defattr(644,root,root,755)
134 %{netscapedir}/java/classes/*.jar
135 %attr(755,root,root) %{netscapedir}/plugins/*.so
This page took 0.036113 seconds and 4 git commands to generate.