]> git.pld-linux.org Git - packages/freewrl.git/blob - freewrl.spec
- updated to 1.13, updated system-js patch
[packages/freewrl.git] / freewrl.spec
1 # TODO:
2 # - install fonts system-wide (subpackage?)
3 # - why not having the plugin in single dir, /usr/lib/nsplugins, and
4 #   all the browsers symlink there?
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        FreeWRL - VRML browser
7 Summary(pl):    FreeWRL - przegl±darka VRML
8 Name:           freewrl
9 Version:        1.13
10 Release:        1
11 License:        LGPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://dl.sourceforge.net/freewrl/FreeWRL-%{version}.tar.gz
14 # Source0-md5:  edba3a6f13d7b96c29cf49b9fa7b8a2f
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-system-js.patch
17 Patch2:         %{name}-make.patch
18 URL:            http://freewrl.sourceforge.net/
19 BuildRequires:  ImageMagick
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  freetype-devel >= 2.0
23 BuildRequires:  jar
24 BuildRequires:  jdk
25 BuildRequires:  js-devel
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  mozilla-devel
29 BuildRequires:  mozilla-embedded(gtk2)
30 BuildRequires:  perl-devel >= 1:5.8.0
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  rpmbuild(macros) >= 1.213
33 BuildRequires:  saxon
34 %ifarch %{x8664} ia64 ppc64 s390x sparc64
35 Provides:       libFreeWRLFunc.so()(64-bit)
36 %else
37 Provides:       libFreeWRLFunc.so
38 %endif
39 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         mozilladir      /usr/%{_lib}/mozilla
43 %define         netscapedir     /usr/%{_lib}/netscape
44
45 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
46 # false positives found by perlreq from rpm 4.1
47 %define         _noautoreq      'perl(VRML::Events)' 'perl(VRML::VRMLCU)' 'perl(VRML::VRMLFields)' 'perl(VRML::VRMLNodes)' 'perl(VRMLFields)' 'perl(VRMLNodes)' 'perl(VRMLRend)'
48
49 %description
50 FreeWRL - VRML browser.
51
52 %description -l pl
53 FreeWRL - przegl±darka VRML.
54
55 %package -n mozilla-plugin-%{name}
56 Summary:        VRML plugin for Mozilla WWW browser
57 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Mozilla
58 Group:          Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       mozilla-embedded(gtk2)
61
62 %description -n mozilla-plugin-%{name}
63 VRML plugin for Mozilla WWW browser.
64
65 %description -n mozilla-plugin-%{name} -l pl
66 Wtyczka VRML dla przegl±darki WWW Mozilla.
67
68 %package -n netscape-plugin-%{name}
69 Summary:        VRML plugin for Netscape WWW browser
70 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Netscape
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n netscape-plugin-%{name}
75 VRML plugin for Netscape WWW browser.
76
77 %description -n netscape-plugin-%{name} -l pl
78 Wtyczka VRML dla przegl±darki WWW Netscape.
79
80 %package -n mozilla-firefox-plugin-%{name}
81 Summary:        VRML plugin for Mozilla Firefox browser
82 Summary(pl):    Wtyczka VRML dla przegl±darki Mozilla Firefox
83 Group:          Libraries
84 PreReq:         mozilla-firefox
85 Requires:       %{name} = %{version}-%{release}
86
87 %description -n mozilla-firefox-plugin-%{name}
88 VRML plugin for Mozilla Firefox browser.
89
90 %description -n mozilla-firefox-plugin-%{name} -l pl
91 Wtyczka VRML dla przegl±darki Mozilla Firefox.
92
93 %package -n konqueror-plugin-%{name}
94 Summary:        VRML plugin for Konqueror browser
95 Summary(pl):    Wtyczka VRML dla przegl±darki Konqueror
96 Group:          Libraries
97 PreReq:         konqueror >= 3.0.8-2.3
98 Requires:       %{name} = %{version}-%{release}
99
100 %description -n konqueror-plugin-%{name}
101 VRML plugin for Konqueror browser.
102
103 %description -n konqueror-plugin-%{name} -l pl
104 Wtyczka VRML dla przegl±darki Konqueror.
105
106 %prep
107 %setup -q -n FreeWRL-%{version}
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 # this file causes unnecessary/unwanted rebuilds of JS module
113 rm -f JS/Makefile.aqua.PL
114 # kill precompiled object
115 rm CFuncs/GenPolyRep.o
116
117 %build
118 %{__perl} Makefile.PL \
119         INSTALLDIRS=vendor
120 %{__make} \
121         CC="%{__cc}" \
122         OPTIMIZE="%{rpmcflags}" \
123         OPTIMIZER="%{rpmcflags}" \
124         DESTINSTALLPRIVLIB=%{perl_vendorlib}
125
126 %{__make} -C Plugin \
127         CC="%{__cc}" \
128         OPTIMIZER="%{rpmcflags}"
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{mozilladir}/plugins,%{netscapedir}/plugins} \
133         $RPM_BUILD_ROOT%{_libdir}/{mozilla-firefox/plugins,kde3/plugins/konqueror} \
134         $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         SITEARCHEXP=$RPM_BUILD_ROOT%{perl_vendorarch} \
139         DESTINSTALLPRIVLIB=$RPM_BUILD_ROOT%{perl_vendorlib}
140
141 # mozilla plugin is installed by make install
142 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{netscapedir}/plugins
143 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
144 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/konqueror
145
146 # specified in java/classes/Makefile.PL, but finally not installed
147 install java/classes/vrml.jar $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
148 install java/classes/java.policy $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
149
150 # remove copy, make a symlink
151 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/VRML/VRMLFunc/libFreeWRLFunc.so
152 ln -sf %{perl_vendorarch}/auto/VRML/VRMLFunc/VRMLFunc.so $RPM_BUILD_ROOT%{_libdir}/libFreeWRLFunc.so
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %doc README.html
160 %attr(755,root,root) %{_bindir}/*
161 %attr(755,root,root) %{_libdir}/libFreeWRLFunc.so
162 %dir %{perl_vendorlib}/VRML
163 %attr(755,root,root) %{perl_vendorlib}/VRML/fw2init.pl
164 %{perl_vendorlib}/VRML/java.policy
165 %{perl_vendorlib}/VRML/vrml.jar
166 %dir %{perl_vendorlib}/VRML/fonts
167 # Bitstream Amerigo, BauerBodni, Futura fonts
168 %{perl_vendorlib}/VRML/fonts/*.ttf
169 %{perl_vendorarch}/VRML
170 %dir %{perl_vendorarch}/auto/VRML
171 %dir %{perl_vendorarch}/auto/VRML/*
172 %{perl_vendorarch}/auto/VRML/*/*.bs
173 %attr(755,root,root) %{perl_vendorarch}/auto/VRML/*/*.so
174 %{_mandir}/man1/*.1*
175 %{_mandir}/man3/*.3*
176
177 %files -n mozilla-plugin-%{name}
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{mozilladir}/plugins/*.so
180
181 %files -n netscape-plugin-%{name}
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{netscapedir}/plugins/*.so
184
185 %files -n mozilla-firefox-plugin-%{name}
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
188
189 %files -n konqueror-plugin-%{name}
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/kde3/plugins/konqueror/*.so
This page took 0.067858 seconds and 4 git commands to generate.