]> git.pld-linux.org Git - packages/freewrl.git/blob - freewrl.spec
- add BR
[packages/freewrl.git] / freewrl.spec
1 # TODO:
2 # - install fonts system-wide (subpackage?)
3 # - why not having the plugin in single dir, /usr/lib/nsplugins, and
4 #   all the browsers symlink there?
5 # - check and correct/remove patch1 and patch2
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        FreeWRL - VRML browser
8 Summary(pl):    FreeWRL - przegl±darka VRML
9 Name:           freewrl
10 Version:        1.17.4
11 Release:        0.1
12 License:        LGPL
13 Group:          X11/Applications/Graphics
14 Source0:        http://dl.sourceforge.net/freewrl/%{name}-%{version}.tar.gz
15 # Source0-md5:  0c4e7d91b51c593d37ca190d112c869e
16 Patch0:         %{name}-config.patch
17 Patch1:         %{name}-system-js.patch
18 Patch2:         %{name}-make.patch
19 URL:            http://freewrl.sourceforge.net/
20 BuildRequires:  ImageMagick
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  X11-devel
23 BuildRequires:  freetype-devel >= 2.0
24 BuildRequires:  jar
25 BuildRequires:  jdk
26 BuildRequires:  js-devel
27 BuildRequires:  lesstif-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  mozilla-devel
31 BuildRequires:  mozilla-embedded(gtk2)
32 BuildRequires:  perl-devel >= 1:5.8.0
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  rpmbuild(macros) >= 1.213
35 BuildRequires:  saxon
36 %ifarch %{x8664} ia64 ppc64 s390x sparc64
37 Provides:       libFreeWRLFunc.so()(64-bit)
38 %else
39 Provides:       libFreeWRLFunc.so
40 %endif
41 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         mozilladir      /usr/%{_lib}/mozilla
45 %define         netscapedir     /usr/%{_lib}/netscape
46
47 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
48 # false positives found by perlreq from rpm 4.1
49 %define         _noautoreq      'perl(VRML::Events)' 'perl(VRML::VRMLCU)' 'perl(VRML::VRMLFields)' 'perl(VRML::VRMLNodes)' 'perl(VRMLFields)' 'perl(VRMLNodes)' 'perl(VRMLRend)'
50
51 %description
52 FreeWRL - VRML browser.
53
54 %description -l pl
55 FreeWRL - przegl±darka VRML.
56
57 %package -n mozilla-plugin-%{name}
58 Summary:        VRML plugin for Mozilla WWW browser
59 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Mozilla
60 Group:          Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       mozilla-embedded(gtk2)
63
64 %description -n mozilla-plugin-%{name}
65 VRML plugin for Mozilla WWW browser.
66
67 %description -n mozilla-plugin-%{name} -l pl
68 Wtyczka VRML dla przegl±darki WWW Mozilla.
69
70 %package -n netscape-plugin-%{name}
71 Summary:        VRML plugin for Netscape WWW browser
72 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Netscape
73 Group:          Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description -n netscape-plugin-%{name}
77 VRML plugin for Netscape WWW browser.
78
79 %description -n netscape-plugin-%{name} -l pl
80 Wtyczka VRML dla przegl±darki WWW Netscape.
81
82 %package -n mozilla-firefox-plugin-%{name}
83 Summary:        VRML plugin for Mozilla Firefox browser
84 Summary(pl):    Wtyczka VRML dla przegl±darki Mozilla Firefox
85 Group:          Libraries
86 PreReq:         mozilla-firefox
87 Requires:       %{name} = %{version}-%{release}
88
89 %description -n mozilla-firefox-plugin-%{name}
90 VRML plugin for Mozilla Firefox browser.
91
92 %description -n mozilla-firefox-plugin-%{name} -l pl
93 Wtyczka VRML dla przegl±darki Mozilla Firefox.
94
95 %package -n konqueror-plugin-%{name}
96 Summary:        VRML plugin for Konqueror browser
97 Summary(pl):    Wtyczka VRML dla przegl±darki Konqueror
98 Group:          Libraries
99 PreReq:         konqueror >= 3.0.8-2.3
100 Requires:       %{name} = %{version}-%{release}
101
102 %description -n konqueror-plugin-%{name}
103 VRML plugin for Konqueror browser.
104
105 %description -n konqueror-plugin-%{name} -l pl
106 Wtyczka VRML dla przegl±darki Konqueror.
107
108 %prep
109 %setup -q -n %{name}-%{version}
110 %patch0 -p1
111 #%patch1 -p1
112 #%patch2 -p1
113
114 # this file causes unnecessary/unwanted rebuilds of JS module
115 rm -f JS/Makefile.aqua.PL
116
117 %build
118 %{__perl} Makefile.PL \
119         INSTALLDIRS=vendor
120 %{__make} \
121         CC="%{__cc}" \
122         OPTIMIZE="%{rpmcflags}" \
123         OPTIMIZER="%{rpmcflags}" \
124         DESTINSTALLPRIVLIB=%{perl_vendorlib}
125
126 %{__make} -C Plugin \
127         CC="%{__cc}" \
128         OPTIMIZER="%{rpmcflags}"
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{mozilladir}/plugins,%{netscapedir}/plugins} \
133         $RPM_BUILD_ROOT%{_libdir}/{mozilla-firefox/plugins,kde3/plugins/konqueror} \
134         $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT \
138         SITEARCHEXP=$RPM_BUILD_ROOT%{perl_vendorarch} \
139         DESTINSTALLPRIVLIB=$RPM_BUILD_ROOT%{perl_vendorlib}
140
141 # mozilla plugin is installed by make install
142 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{netscapedir}/plugins
143 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
144 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/konqueror
145
146 # specified in java/classes/Makefile.PL, but finally not installed
147 install java/classes/vrml.jar $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
148 install java/classes/java.policy $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
149
150 # remove copy, make a symlink
151 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/VRML/VRMLFunc/libFreeWRLFunc.so
152 ln -sf %{perl_vendorarch}/auto/VRML/VRMLFunc/VRMLFunc.so $RPM_BUILD_ROOT%{_libdir}/libFreeWRLFunc.so
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %doc README.html
160 %attr(755,root,root) %{_bindir}/*
161 %attr(755,root,root) %{_libdir}/libFreeWRLFunc.so
162 %dir %{perl_vendorlib}/VRML
163 %attr(755,root,root) %{perl_vendorlib}/VRML/fw2init.pl
164 %{perl_vendorlib}/VRML/java.policy
165 %{perl_vendorlib}/VRML/vrml.jar
166 %dir %{perl_vendorlib}/VRML/fonts
167 # Bitstream Amerigo, BauerBodni, Futura fonts
168 %{perl_vendorlib}/VRML/fonts/*.ttf
169 %{perl_vendorarch}/VRML
170 %dir %{perl_vendorarch}/auto/VRML
171 %dir %{perl_vendorarch}/auto/VRML/*
172 %{perl_vendorarch}/auto/VRML/*/*.bs
173 %attr(755,root,root) %{perl_vendorarch}/auto/VRML/*/*.so
174 %{_mandir}/man1/*.1*
175 %{_mandir}/man3/*.3*
176
177 %files -n mozilla-plugin-%{name}
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{mozilladir}/plugins/*.so
180
181 %files -n netscape-plugin-%{name}
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{netscapedir}/plugins/*.so
184
185 %files -n mozilla-firefox-plugin-%{name}
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
188
189 %files -n konqueror-plugin-%{name}
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/kde3/plugins/konqueror/*.so
This page took 0.050066 seconds and 4 git commands to generate.