]> git.pld-linux.org Git - packages/freewrl.git/blob - freewrl.spec
- updated to 1.12
[packages/freewrl.git] / freewrl.spec
1 # TODO:
2 # - install fonts system-wide (subpackage?)
3 # - why not having the plugin in single dir, /usr/lib/nsplugins, and
4 #   all the browsers symlink there?
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        FreeWRL - VRML browser
7 Summary(pl):    FreeWRL - przegl±darka VRML
8 Name:           freewrl
9 Version:        1.12
10 Release:        1
11 License:        LGPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://dl.sourceforge.net/freewrl/FreeWRL-%{version}.tar.gz
14 # Source0-md5:  cc717ca6587be7096e06338cd841350f
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-system-js.patch
17 Patch2:         %{name}-make.patch
18 URL:            http://freewrl.sourceforge.net/
19 BuildRequires:  ImageMagick
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  XFree86-devel
22 BuildRequires:  freetype-devel >= 2.0
23 BuildRequires:  jar
24 BuildRequires:  jdk
25 BuildRequires:  js-devel
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  mozilla-devel
29 BuildRequires:  mozilla-embedded(gtk2)
30 BuildRequires:  perl-devel >= 1:5.8.0
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  saxon
33 %ifarch amd64 ia64 ppc64 s390x sparc64
34 Provides:       libFreeWRLFunc.so()(64-bit)
35 %else
36 Provides:       libFreeWRLFunc.so
37 %endif
38 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         mozilladir      /usr/%{_lib}/mozilla
42 %define         netscapedir     /usr/%{_lib}/netscape
43
44 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
45 # false positives found by perlreq from rpm 4.1
46 %define         _noautoreq      'perl(VRML::Events)' 'perl(VRML::VRMLCU)' 'perl(VRML::VRMLFields)' 'perl(VRML::VRMLNodes)' 'perl(VRMLFields)' 'perl(VRMLNodes)' 'perl(VRMLRend)'
47
48 %description
49 FreeWRL - VRML browser.
50
51 %description -l pl
52 FreeWRL - przegl±darka VRML.
53
54 %package -n mozilla-plugin-%{name}
55 Summary:        VRML plugin for Mozilla WWW browser
56 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Mozilla
57 Group:          Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       mozilla-embedded(gtk2)
60
61 %description -n mozilla-plugin-%{name}
62 VRML plugin for Mozilla WWW browser.
63
64 %description -n mozilla-plugin-%{name} -l pl
65 Wtyczka VRML dla przegl±darki WWW Mozilla.
66
67 %package -n netscape-plugin-%{name}
68 Summary:        VRML plugin for Netscape WWW browser
69 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Netscape
70 Group:          Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description -n netscape-plugin-%{name}
74 VRML plugin for Netscape WWW browser.
75
76 %description -n netscape-plugin-%{name} -l pl
77 Wtyczka VRML dla przegl±darki WWW Netscape.
78
79 %package -n mozilla-firefox-plugin-%{name}
80 Summary:        VRML plugin for Mozilla Firefox browser
81 Summary(pl):    Wtyczka VRML dla przegl±darki Mozilla Firefox
82 Group:          Libraries
83 PreReq:         mozilla-firefox
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n mozilla-firefox-plugin-%{name}
87 VRML plugin for Mozilla Firefox browser.
88
89 %description -n mozilla-firefox-plugin-%{name} -l pl
90 Wtyczka VRML dla przegl±darki Mozilla Firefox.
91
92 %package -n konqueror-plugin-%{name}
93 Summary:        VRML plugin for Konqueror browser
94 Summary(pl):    Wtyczka VRML dla przegl±darki Konqueror
95 Group:          Libraries
96 PreReq:         konqueror >= 3.0.8-2.3
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n konqueror-plugin-%{name}
100 VRML plugin for Konqueror browser.
101
102 %description -n konqueror-plugin-%{name} -l pl
103 Wtyczka VRML dla przegl±darki Konqueror.
104
105 %prep
106 %setup -q -n FreeWRL-%{version}
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110
111 # this file causes unnecessary/unwanted rebuilds of JS module
112 rm -f JS/Makefile.aqua.PL
113
114 %build
115 %{__perl} Makefile.PL \
116         INSTALLDIRS=vendor
117 %{__make} \
118         CC="%{__cc}" \
119         OPTIMIZE="%{rpmcflags}" \
120         OPTIMIZER="%{rpmcflags}" \
121         DESTINSTALLPRIVLIB=%{perl_vendorlib}
122
123 %{__make} -C Plugin \
124         CC="%{__cc}" \
125         OPTIMIZER="%{rpmcflags}"
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{mozilladir}/plugins,%{netscapedir}/plugins} \
130         $RPM_BUILD_ROOT%{_libdir}/{mozilla-firefox/plugins,kde3/plugins/konqueror} \
131         $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         SITEARCHEXP=$RPM_BUILD_ROOT%{perl_vendorarch} \
136         DESTINSTALLPRIVLIB=$RPM_BUILD_ROOT%{perl_vendorlib}
137
138 # mozilla plugin is installed by make install
139 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{netscapedir}/plugins
140 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
141 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/konqueror
142
143 # specified in java/classes/Makefile.PL, but finally not installed
144 install java/classes/vrml.jar $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
145 install java/classes/java.policy $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
146
147 # remove copy, make a symlink
148 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/VRML/VRMLFunc/libFreeWRLFunc.so
149 ln -sf %{perl_vendorarch}/auto/VRML/VRMLFunc/VRMLFunc.so $RPM_BUILD_ROOT%{_libdir}/libFreeWRLFunc.so
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %doc README.html
157 %attr(755,root,root) %{_bindir}/*
158 %attr(755,root,root) %{_libdir}/libFreeWRLFunc.so
159 %dir %{perl_vendorlib}/VRML
160 %attr(755,root,root) %{perl_vendorlib}/VRML/fw2init.pl
161 %{perl_vendorlib}/VRML/java.policy
162 %{perl_vendorlib}/VRML/vrml.jar
163 %dir %{perl_vendorlib}/VRML/fonts
164 # Bitstream Amerigo, BauerBodni, Futura fonts
165 %{perl_vendorlib}/VRML/fonts/*.ttf
166 %{perl_vendorarch}/VRML
167 %dir %{perl_vendorarch}/auto/VRML
168 %dir %{perl_vendorarch}/auto/VRML/*
169 %{perl_vendorarch}/auto/VRML/*/*.bs
170 %attr(755,root,root) %{perl_vendorarch}/auto/VRML/*/*.so
171 %{_mandir}/man1/*.1*
172 %{_mandir}/man3/*.3*
173
174 %files -n mozilla-plugin-%{name}
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{mozilladir}/plugins/*.so
177
178 %files -n netscape-plugin-%{name}
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{netscapedir}/plugins/*.so
181
182 %files -n mozilla-firefox-plugin-%{name}
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
185
186 %files -n konqueror-plugin-%{name}
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/kde3/plugins/konqueror/*.so
This page took 0.088779 seconds and 4 git commands to generate.