]> git.pld-linux.org Git - packages/freewrl.git/blob - freewrl.spec
- up to 1.17.4
[packages/freewrl.git] / freewrl.spec
1 # TODO:
2 # - install fonts system-wide (subpackage?)
3 # - why not having the plugin in single dir, /usr/lib/nsplugins, and
4 #   all the browsers symlink there?
5 # - check and correct/remove patch1 and patch2
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        FreeWRL - VRML browser
8 Summary(pl):    FreeWRL - przegl±darka VRML
9 Name:           freewrl
10 Version:        1.17.4
11 Release:        0.1
12 License:        LGPL
13 Group:          X11/Applications/Graphics
14 Source0:        http://dl.sourceforge.net/freewrl/%{name}-%{version}.tar.gz
15 # Source0-md5:  0c4e7d91b51c593d37ca190d112c869e
16 Patch0:         %{name}-config.patch
17 Patch1:         %{name}-system-js.patch
18 Patch2:         %{name}-make.patch
19 URL:            http://freewrl.sourceforge.net/
20 BuildRequires:  ImageMagick
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  X11-devel
23 BuildRequires:  freetype-devel >= 2.0
24 BuildRequires:  jar
25 BuildRequires:  jdk
26 BuildRequires:  js-devel
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel
29 BuildRequires:  mozilla-devel
30 BuildRequires:  mozilla-embedded(gtk2)
31 BuildRequires:  perl-devel >= 1:5.8.0
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  rpmbuild(macros) >= 1.213
34 BuildRequires:  saxon
35 %ifarch %{x8664} ia64 ppc64 s390x sparc64
36 Provides:       libFreeWRLFunc.so()(64-bit)
37 %else
38 Provides:       libFreeWRLFunc.so
39 %endif
40 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         mozilladir      /usr/%{_lib}/mozilla
44 %define         netscapedir     /usr/%{_lib}/netscape
45
46 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
47 # false positives found by perlreq from rpm 4.1
48 %define         _noautoreq      'perl(VRML::Events)' 'perl(VRML::VRMLCU)' 'perl(VRML::VRMLFields)' 'perl(VRML::VRMLNodes)' 'perl(VRMLFields)' 'perl(VRMLNodes)' 'perl(VRMLRend)'
49
50 %description
51 FreeWRL - VRML browser.
52
53 %description -l pl
54 FreeWRL - przegl±darka VRML.
55
56 %package -n mozilla-plugin-%{name}
57 Summary:        VRML plugin for Mozilla WWW browser
58 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Mozilla
59 Group:          Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       mozilla-embedded(gtk2)
62
63 %description -n mozilla-plugin-%{name}
64 VRML plugin for Mozilla WWW browser.
65
66 %description -n mozilla-plugin-%{name} -l pl
67 Wtyczka VRML dla przegl±darki WWW Mozilla.
68
69 %package -n netscape-plugin-%{name}
70 Summary:        VRML plugin for Netscape WWW browser
71 Summary(pl):    Wtyczka VRML dla przegl±darki WWW Netscape
72 Group:          Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description -n netscape-plugin-%{name}
76 VRML plugin for Netscape WWW browser.
77
78 %description -n netscape-plugin-%{name} -l pl
79 Wtyczka VRML dla przegl±darki WWW Netscape.
80
81 %package -n mozilla-firefox-plugin-%{name}
82 Summary:        VRML plugin for Mozilla Firefox browser
83 Summary(pl):    Wtyczka VRML dla przegl±darki Mozilla Firefox
84 Group:          Libraries
85 PreReq:         mozilla-firefox
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n mozilla-firefox-plugin-%{name}
89 VRML plugin for Mozilla Firefox browser.
90
91 %description -n mozilla-firefox-plugin-%{name} -l pl
92 Wtyczka VRML dla przegl±darki Mozilla Firefox.
93
94 %package -n konqueror-plugin-%{name}
95 Summary:        VRML plugin for Konqueror browser
96 Summary(pl):    Wtyczka VRML dla przegl±darki Konqueror
97 Group:          Libraries
98 PreReq:         konqueror >= 3.0.8-2.3
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n konqueror-plugin-%{name}
102 VRML plugin for Konqueror browser.
103
104 %description -n konqueror-plugin-%{name} -l pl
105 Wtyczka VRML dla przegl±darki Konqueror.
106
107 %prep
108 %setup -q -n %{name}-%{version}
109 %patch0 -p1
110 #%patch1 -p1
111 #%patch2 -p1
112
113 # this file causes unnecessary/unwanted rebuilds of JS module
114 rm -f JS/Makefile.aqua.PL
115
116 %build
117 %{__perl} Makefile.PL \
118         INSTALLDIRS=vendor
119 %{__make} \
120         CC="%{__cc}" \
121         OPTIMIZE="%{rpmcflags}" \
122         OPTIMIZER="%{rpmcflags}" \
123         DESTINSTALLPRIVLIB=%{perl_vendorlib}
124
125 %{__make} -C Plugin \
126         CC="%{__cc}" \
127         OPTIMIZER="%{rpmcflags}"
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT{%{mozilladir}/plugins,%{netscapedir}/plugins} \
132         $RPM_BUILD_ROOT%{_libdir}/{mozilla-firefox/plugins,kde3/plugins/konqueror} \
133         $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT \
137         SITEARCHEXP=$RPM_BUILD_ROOT%{perl_vendorarch} \
138         DESTINSTALLPRIVLIB=$RPM_BUILD_ROOT%{perl_vendorlib}
139
140 # mozilla plugin is installed by make install
141 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{netscapedir}/plugins
142 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/mozilla-firefox/plugins
143 install Plugin/npfreewrl.so $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/konqueror
144
145 # specified in java/classes/Makefile.PL, but finally not installed
146 install java/classes/vrml.jar $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
147 install java/classes/java.policy $RPM_BUILD_ROOT%{perl_vendorlib}/VRML
148
149 # remove copy, make a symlink
150 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/VRML/VRMLFunc/libFreeWRLFunc.so
151 ln -sf %{perl_vendorarch}/auto/VRML/VRMLFunc/VRMLFunc.so $RPM_BUILD_ROOT%{_libdir}/libFreeWRLFunc.so
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc README.html
159 %attr(755,root,root) %{_bindir}/*
160 %attr(755,root,root) %{_libdir}/libFreeWRLFunc.so
161 %dir %{perl_vendorlib}/VRML
162 %attr(755,root,root) %{perl_vendorlib}/VRML/fw2init.pl
163 %{perl_vendorlib}/VRML/java.policy
164 %{perl_vendorlib}/VRML/vrml.jar
165 %dir %{perl_vendorlib}/VRML/fonts
166 # Bitstream Amerigo, BauerBodni, Futura fonts
167 %{perl_vendorlib}/VRML/fonts/*.ttf
168 %{perl_vendorarch}/VRML
169 %dir %{perl_vendorarch}/auto/VRML
170 %dir %{perl_vendorarch}/auto/VRML/*
171 %{perl_vendorarch}/auto/VRML/*/*.bs
172 %attr(755,root,root) %{perl_vendorarch}/auto/VRML/*/*.so
173 %{_mandir}/man1/*.1*
174 %{_mandir}/man3/*.3*
175
176 %files -n mozilla-plugin-%{name}
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{mozilladir}/plugins/*.so
179
180 %files -n netscape-plugin-%{name}
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{netscapedir}/plugins/*.so
183
184 %files -n mozilla-firefox-plugin-%{name}
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/mozilla-firefox/plugins/*.so
187
188 %files -n konqueror-plugin-%{name}
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/kde3/plugins/konqueror/*.so
This page took 0.040221 seconds and 4 git commands to generate.