]> git.pld-linux.org Git - packages/freevo.git/blob - freevo.spec
- initial release
[packages/freevo.git] / freevo.spec
1 %define geometry 800x600
2 %define display  x11
3 %define tv_norm  pal
4 %define chanlist europe-west
5
6 Summary:        Freevo - open-source home theatre PC platform
7 Summary(pl):    Freevo - zestaw kina domowego oparty na platformie PC i otwartych ¼ród³ach
8 Name:           freevo
9 Version:        1.5.0
10 Release:        1
11 License:        GPL
12 Group:          Applications/Multimedia
13 Source0:        http://dl.sourceforge.net/freevo/%{name}-%{version}.tar.gz
14 Source1:        %{name}-boot_config
15 URL:            http://freevo.sourceforge.net/
16 BuildRequires:  SDL_image >= 1.2.3
17 BuildRequires:  SDL_mixer >= 1.2.5
18 BuildRequires:  SDL_ttf >= 2.0.6
19 BuildRequires:  docbook-utils
20 BuildRequires:  libexif-devel >= 0.5.10
21 BuildRequires:  libjpeg-devel >= 6b
22 BuildRequires:  python-Imaging >= 1.1.4
23 BuildRequires:  python-PyXML
24 BuildRequires:  python-Twisted >= 1.1.0
25 BuildRequires:  python-mmpython >= 0.4.4
26 BuildRequires:  python-mx-Tools >= 2.0.5
27 BuildRequires:  python-numpy >= 23.1
28 BuildRequires:  python-pygame >= 1.5.6
29 Requires:       aumix >= 2.8
30 Requires:       lsdvd
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Freevo is a Linux application that turns a PC with a TV capture card
36 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
37 other applications such as xine, mplayer, tvtime and mencoder to play
38 and record video and audio.
39
40 %description -l pl
41 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
42 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
43 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak
44 xine, mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania
45 obrazu i d¼wiêku.
46
47 %package boot
48 Summary:        Files to enable a standalone Freevo system (started from initscript)
49 Summary(pl):    Pliki do w³±czania samodzielnego systemu Freevo (uruchamiane z initscriptów)
50 Group:          Applications/Multimedia
51 PreReq:         rc-scripts
52 Requires(post,preun):   /sbin/chkconfig
53 Requires:       %{name} = %{version}-%{release}
54
55 %description boot
56 Freevo is a Linux application that turns a PC with a TV capture card
57 and/or TV-out into a standalone multimedia jukebox/VCR. It builds on
58 other applications such as mplayer and mencoder to play and record
59 video and audio.
60
61 Note: This installs the initscripts necessary for a standalone Freevo
62 system.
63
64 %description boot -l pl
65 Freevo to linuksowa aplikacja zamieniaj±ca PC z kart± telewizyjn±
66 i/lub wyj¶ciem TV-out na samodzieln± multimedialn± szafê graj±c± /
67 magnetowid. Jest zbudowana w oparciu o inne aplikacje, takie jak
68 xine, mplayer, tvtime i mencoder s³u¿±ce do odtwarzania i nagrywania
69 obrazu i d¼wiêku.
70
71 Ten pakiet instaluje skrypty inicjalizuj±ce potrzebne do samodzielnego
72 systemu Freevo.
73
74 %prep
75 %setup -q
76
77 find . -name CVS | xargs rm -rf
78 find . -name ".cvsignore" |xargs rm -f
79 find . -name "*.pyc" |xargs rm -f
80 find . -name "*.pyo" |xargs rm -f
81 find . -name "*.py" |xargs chmod 644
82
83 %build
84 env CFLAGS="%{rpmcflags}" \
85 python setup.py build
86
87 # ??? removed in install
88 #mkdir -p %{buildroot}%{_sysconfdir}/freevo
89 ## The following is needed to let RPM know that the files should be backed up
90 #touch %{buildroot}%{_sysconfdir}/freevo/freevo.conf
91 #
92 ## boot scripts
93 #mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
94 #mkdir -p %{buildroot}%{_bindir}
95 #install -m 755 boot/freevo %{buildroot}%{_sysconfdir}/rc.d/init.d
96 ##install -m 755 boot/freevo_dep %{buildroot}%{_sysconfdir}/rc.d/init.d
97 #install -m 755 boot/recordserver %{buildroot}%{_sysconfdir}/rc.d/init.d/freevo_recordserver
98 #install -m 755 boot/webserver %{buildroot}%{_sysconfdir}/rc.d/init.d/freevo_webserver
99 #install -m 755 boot/recordserver_init %{buildroot}%{_bindir}/freevo_recordserver_init
100 #install -m 755 boot/webserver_init %{buildroot}%{_bindir}/freevo_webserver_init
101 #install -m 644 -D %{SOURCE1} %{buildroot}%{_sysconfdir}/freevo/boot_config
102 #
103 #
104 #mkdir -p %{buildroot}/var/log/freevo
105 #mkdir -p %{buildroot}/var/cache/freevo
106 #mkdir -p %{buildroot}/var/cache/freevo/{thumbnails,audio}
107 #mkdir -p %{buildroot}/var/cache/xmltv/logos
108 #chmod 777 %{buildroot}/var/cache/{freevo,freevo/thumbnails,freevo/audio,xmltv,xmltv/logos}
109 #chmod 777 %{buildroot}/var/log/freevo
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 python setup.py install \
114         --root=$RPM_BUILD_ROOT \
115         --record=INSTALLED_FILES
116
117 install local_conf.py.example $RPM_BUILD_ROOT%{_docdir}
118
119 install -d $RPM_BUILD_ROOT%{_datadir}/freevo/contrib/lirc
120 cp -av contrib/lirc $RPM_BUILD_ROOT%{_datadir}/freevo/contrib
121
122 %find_lang %{name}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 # Copy old local_conf.py to replace dummy file
129 %{_bindir}/freevo setup --geometry=%{geometry} --display=%{display} \
130         --tv=%{tv_norm} --chanlist=%{chanlist}
131
132 %post boot
133 # Add the service, but don't automatically invoke it
134 # user has to enable it via ntsysv
135 /sbin/chkconfig --add freevo
136 /sbin/chkconfig --levels 234 freevo off
137 #/sbin/chkconfig --add freevo_dep
138 /sbin/chkconfig --add freevo_recordserver
139 /sbin/chkconfig --levels 234 freevo_recordserver off
140 /sbin/chkconfig --add freevo_webserver
141 /sbin/chkconfig --levels 234 freevo_webserver off
142
143 %preun boot
144 if [ "$1" = 0 ] ; then
145         /sbin/chkconfig --del freevo
146 #       /sbin/chkconfig --del freevo_dep
147         /sbin/chkconfig --del freevo_recordserver
148         /sbin/chkconfig --del freevo_webserver
149 fi
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc BUGS COPYING ChangeLog FAQ INSTALL README TODO Docs local_conf.py.example
154 %doc contrib/lirc
155 %{_docdir}/local_conf.py.example
156 %attr(755,root,root) %{_bindir}/*
157 #%dir %{_docdir}/installation
158 #%dir %{_docdir}/plugin_writing
159 %dir %{_datadir}/freevo
160 %dir %{_datadir}/freevo/contrib
161 %dir %{_datadir}/freevo/contrib/fbcon
162 %dir %{_datadir}/freevo/contrib/lirc
163 %{_datadir}/freevo/contrib/lirc/*
164 %dir %{_sysconfdir}/freevo
165 %attr(1777,root,root) %dir /var/log/freevo
166 %attr(1777,root,root) %dir /var/cache/freevo
167 %attr(1777,root,root) %dir /var/cache/freevo/audio
168 %attr(1777,root,root) %dir /var/cache/freevo/thumbnails
169 %attr(1777,root,root) %dir /var/cache/xmltv
170 %attr(1777,root,root) %dir /var/cache/xmltv/logos
171 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/freevo.conf
172 #%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/record_config.py
173 %{py_sitescriptdir}/freevo
174 # ??? DUP
175 #%{_datadir}/freevo
176 %dir %{_datadir}/fxd
177 %{_datadir}/fxd/webradio.fxd
178
179 %files boot
180 %defattr(644,root,root,755)
181 %attr(754,root,root) /etc/rc.d/init.d/*
182 %attr(755,root,root) %{_bindir}/freevo_*
183 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freevo/boot_config
This page took 0.09074 seconds and 3 git commands to generate.