]> git.pld-linux.org Git - packages/freetype.git/commitdiff
- updated to 2.5.1 auto/th/freetype-2.5.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Nov 2013 21:06:45 +0000 (22:06 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Nov 2013 21:06:45 +0000 (22:06 +0100)
- added nodebug patch (fixes demos build without autofit debugging)
- they changed headers layout again... (no changes required for apps using {freetype,pkg}-config)

freetype-nodebug.patch [new file with mode: 0644]
freetype.spec

diff --git a/freetype-nodebug.patch b/freetype-nodebug.patch
new file mode 100644 (file)
index 0000000..659fd6d
--- /dev/null
@@ -0,0 +1,73 @@
+--- freetype-2.5.1/ft2demos-2.5.1/src/ftgrid.c.orig    2013-11-21 16:56:59.920675040 +0100
++++ freetype-2.5.1/ft2demos-2.5.1/src/ftgrid.c 2013-11-27 20:29:23.464470407 +0100
+@@ -53,10 +53,12 @@
+   struct  AF_GlyphHintsRec_;
+   typedef struct AF_GlyphHintsRec_*  AF_GlyphHints;
++#ifdef FT_DEBUG_AUTOFIT
+   extern int            _af_debug_disable_horz_hints;
+   extern int            _af_debug_disable_vert_hints;
+   extern int            _af_debug_disable_blue_hints;
+   extern AF_GlyphHints  _af_debug_hints;
++#endif
+ #ifdef __cplusplus
+   extern "C" {
+@@ -495,19 +497,26 @@
+     if ( status.do_segment )
+     {
+       /* Force hinting first in order to collect segment info. */
++#ifdef FT_DEBUG_AUTOFIT
+       _af_debug_disable_horz_hints = 0;
+       _af_debug_disable_vert_hints = 0;
++#endif
+       if ( !FT_Load_Glyph( size->face, st->Num,
+                            FT_LOAD_DEFAULT        |
+                            FT_LOAD_NO_BITMAP      |
+                            FT_LOAD_FORCE_AUTOHINT |
+                            FT_LOAD_TARGET_NORMAL ) )
+-        grid_hint_draw_segment( &status, _af_debug_hints );
++#ifdef FT_DEBUG_AUTOFIT
++        grid_hint_draw_segment( &status, _af_debug_hints )
++#endif
++              ;
+     }
++#ifdef FT_DEBUG_AUTOFIT
+     _af_debug_disable_horz_hints = !st->do_horz_hints;
+     _af_debug_disable_vert_hints = !st->do_vert_hints;
++#endif
+     if ( FT_Load_Glyph( size->face, st->Num,
+                         handle->load_flags | FT_LOAD_NO_BITMAP ) )
+@@ -862,7 +871,9 @@
+           ft_trace_levels[trace_afhints] = 7;
+           status.header = "dumping glyph edges to stdout";
++#ifdef FT_DEBUG_AUTOFIT
+           af_glyph_hints_dump_edges( _af_debug_hints );
++#endif
+           ft_trace_levels[trace_afhints] = old_trace_level;
+         }
+         else
+@@ -882,7 +893,9 @@
+           ft_trace_levels[trace_afhints] = 7;
+           status.header = "dumping glyph segments to stdout";
++#ifdef FT_DEBUG_AUTOFIT
+           af_glyph_hints_dump_segments( _af_debug_hints );
++#endif
+           ft_trace_levels[trace_afhints] = old_trace_level;
+         }
+         else
+@@ -902,7 +915,9 @@
+           ft_trace_levels[trace_afhints] = 7;
+           status.header = "dumping glyph points to stdout";
++#ifdef FT_DEBUG_AUTOFIT
+           af_glyph_hints_dump_points( _af_debug_hints );
++#endif
+           ft_trace_levels[trace_afhints] = old_trace_level;
+         }
+         else
index c7c84ac9687dac78e87dc173f90c7df20cc10c94..12e4cedcc42dd8729ca9dc512c08d00ba4e11f03 100644 (file)
@@ -12,18 +12,19 @@ Summary(pt_BR.UTF-8):       Biblioteca de renderização de fontes TrueType
 Summary(ru.UTF-8):     Растеризатор шрифтов TrueType
 Summary(uk.UTF-8):     Растеризатор шрифтів TrueType
 Name:          freetype
-Version:       2.5.0.1
-Release:       2
+Version:       2.5.1
+Release:       1
 Epoch:         1
 License:       GPL v2 or FTL
 Group:         Libraries
 Source0:       http://download.savannah.gnu.org/releases/freetype/%{name}-%{version}.tar.bz2
-# Source0-md5: c72e9010b1d986d556fc0b2b5fcbf31a
-Source1:       http://download.savannah.gnu.org/releases/freetype/%{name}-doc-2.5.0.tar.bz2
-# Source1-md5: 40f3d5cc0b16396b3fb6b98eeaa053b2
-Source2:       http://download.savannah.gnu.org/releases/freetype/ft2demos-2.5.0.tar.bz2
-# Source2-md5: 9bbea1989116715d3544d8439c8d2972
-Patch0:                freetype-2.2.1-enable-valid.patch
+# Source0-md5: 93eba7854094f46d7d98a9a2370af4d6
+Source1:       http://download.savannah.gnu.org/releases/freetype/%{name}-doc-%{version}.tar.bz2
+# Source1-md5: b955678d06318b32337bd7c730daa676
+Source2:       http://download.savannah.gnu.org/releases/freetype/ft2demos-%{version}.tar.bz2
+# Source2-md5: 73742ef4b13ff9f7b1d4ad2199964141
+Patch0:                %{name}-2.2.1-enable-valid.patch
+Patch1:                %{name}-nodebug.patch
 URL:           http://www.freetype.org/
 BuildRequires: automake
 BuildRequires: bzip2-devel
@@ -194,6 +195,7 @@ Programy demonstracyjne do biblioteki FreeType.
 %prep
 %setup -q -a1 -a2
 %patch0 -p1
+%patch1 -p1
 
 # avoid propagating -L%{_libdir} through *.la
 %{__sed} -i -e 's,libpng-config --ldflags,libpng-config --libs,' builds/unix/configure
@@ -247,7 +249,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libfreetype.so
 %{_libdir}/libfreetype.la
 %{_includedir}/freetype2
-%{_includedir}/ft2build.h
 %{_aclocaldir}/freetype2.m4
 %{_pkgconfigdir}/freetype2.pc
 
This page took 0.170998 seconds and 4 git commands to generate.