]> git.pld-linux.org Git - packages/freetype.git/blobdiff - freetype.spec
- obsolete
[packages/freetype.git] / freetype.spec
index 46ffbd7a26d1db960eb6b591733f0da30c481d6a..6d0511ed4a1f7348aef9a3c81197b5f8cbbfbdec 100644 (file)
@@ -1,7 +1,9 @@
 #
 # Conditional build:
-# _with_bytecode       - with TT bytecode interpreter
-#                      (patents pending in USA, Japan...)
+%bcond_without bytecode        # without TT bytecode interpreter
+#               (patents pending in USA, Japan etc., but now it includes
+#                also patent-free hinting workaround)
+%bcond_without x11             # don't build examples (X11-based)
 #
 Summary:       TrueType font rasterizer
 Summary(es):   Biblioteca de render 3D de fuentes TrueType
@@ -11,25 +13,28 @@ Summary(pt_BR):     Biblioteca de renderiza
 Summary(ru):   òÁÓÔÅÒÉÚÁÔÏÒ ÛÒÉÆÔÏ× TrueType
 Summary(uk):   òÁÓÔÅÒÉÚÁÔÏÒ ÛÒÉÆԦנTrueType
 Name:          freetype
-Version:       2.1.4
-Release:       3
+Version:       2.1.10
+Release:       1
+Epoch:         1
 License:       GPL or FTL
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/sourceforge/freetype/%{name}-%{version}.tar.bz2
-# Source0-md5: 1fc0b188f1fe1216776e5855d2da141f
-Source1:       http://dl.sourceforge.net/sourceforge/freetype/ftdocs-%{version}.tar.bz2
-# Source1-md5: 367064e81998a302f3844f1dcdb8d77f
-Source2:       http://dl.sourceforge.net/sourceforge/freetype/ft2demos-%{version}.tar.bz2
-# Source2-md5: 92cb4e645fe1cfb8345b64cedb9d332e
-Patch0:        ftlru.c.diff
+Source0:       http://savannah.nongnu.org/download/freetype/%{name}-%{version}.tar.bz2
+# Source0-md5: a4012e7d1f6400df44a16743b11b8423
+Source1:       http://savannah.nongnu.org/download/freetype/%{name}-doc-%{version}.tar.bz2
+# Source1-md5: 10608a55ee9ee12e29ba3d705318e61d
+Source2:       http://savannah.nongnu.org/download/freetype/ft2demos-%{version}.tar.bz2
+# Source2-md5: 4edaff5721fedcf1932e76935f3029b3
 URL:           http://www.freetype.org/
-BuildRequires: SysVinit
-BuildRequires: XFree86-devel
+%{?with_x11:BuildRequires:     XFree86-devel}
+BuildRequires: automake
 BuildRequires: zlib-devel
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: python
 Obsoletes:     freetype2
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                specflags_ia32  "-fomit-frame-pointer"
+%define                specflags_ia32  -fomit-frame-pointer 
+# see <freetype/internal/ftserv.h>, the real horror
+%define                specflags       -fno-strict-aliasing
 
 %description
 The FreeType engine is a free and portable TrueType font rendering
@@ -90,7 +95,7 @@ Summary(pt_BR):       Arquivos de inclus
 Summary(ru):   âÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ ÄÌÑ freetype
 Summary(uk):   â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ ÄÌÑ freetype
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      zlib-devel
 Obsoletes:     freetype2-devel
 
@@ -128,7 +133,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ freetype
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ freetype
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     freetype2-static
 
 %description static
@@ -156,7 +161,7 @@ Summary:    FreeType demo programs
 Summary(ko):   FreeTypeÀ» ½ÃÇèÇغ¼ ¼ö Àִ ÇÁ·Î±×·¥ ¸ðÀ½
 Summary(pl):   Programy demonstracyjne FreeType
 Group:         X11/Applications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description demos
 Demonstration programs for FreeType library.
@@ -166,30 +171,35 @@ Programy demonstracyjne do biblioteki FreeType.
 
 %prep
 %setup -q -a1 -a2
-patch src/cache/ftlru.c < %{PATCH0}
-
-mv -f freetype-%{version}/docs/* docs
 
 %build
-CFLAGS="%{rpmcflags} %{?_with_bytecode:-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER}" \
+CFLAGS="%{rpmcflags} %{?with_bytecode:-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER}" \
 %{__make} setup unix \
-       CFG="--prefix=%{_prefix}"
+       CFG="--prefix=%{_prefix} --libdir=%{_libdir}"
+
+%{__make} \
+       X11_LIB="/usr/X11R6/%{_lib}"
 
-%{__make}
+%if %{with x11}
+%{__make} -C ft2demos-* \
+       TOP_DIR="`pwd`" \
+       X11_LIB="/usr/X11R6/%{_lib}"
+%endif
 
-%{__make} TOP_DIR="`pwd`" -C ft2demos-*
+%{__make} refdoc
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_bindir}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       datadir=%{_datadir}
+       DESTDIR=$RPM_BUILD_ROOT
 
+%if %{with x11}
 install ft2demos-*/bin/.libs/ft{multi,timer,view} $RPM_BUILD_ROOT%{_bindir}
 install ft2demos-*/bin/.libs/ft{dump,lint,memchk} $RPM_BUILD_ROOT%{_bindir}
-install ft2demos-*/bin/.libs/testnames $RPM_BUILD_ROOT%{_bindir}/fttestnames
+install ft2demos-*/bin/.libs/testname $RPM_BUILD_ROOT%{_bindir}/fttestname
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -199,23 +209,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc docs/{CHANGES,FTL.txt,PATENTS,license.txt,TODO,modules.txt}
-%attr(755,root,root) %{_libdir}/lib*so.*.*
+%doc docs/{CHANGES,FTL.TXT,PATENTS,LICENSE.TXT,TODO,modules.txt}
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/*.html docs/{design,freetype2,glyphs,reference,tutorial}
+%doc docs/{DEBUG,TRUETYPE} docs/reference
 %attr(755,root,root) %{_bindir}/freetype-config
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_libdir}/lib*.la
 %{_includedir}/freetype2
 %{_includedir}/*.h
 %{_aclocaldir}/*.m4
+%{_pkgconfigdir}/*.pc
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
 
+%if %{with x11}
 %files demos
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ft*
+%endif
This page took 0.075127 seconds and 4 git commands to generate.