]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
70540b777a87815867a68215ce366c2a6a0fff20
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 %bcond_with     msdblib         # use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.62.3
18 Release:        1
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tar.gz
22 # Source0-md5:  6091902314a9317f0de2bb156151bc3a
23 URL:            http://www.freetds.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  glib-devel
27 BuildRequires:  libltdl-devel
28 BuildRequires:  libtool
29 BuildRequires:  unixODBC-devel
30 Requires(post): /sbin/ldconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/tds
34
35 %description
36 FreeTDS is a free (open source) implementation of Sybase's db-lib,
37 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
38 databases). Currently, dblib and ctlib are most mature. Both of these
39 libraries have several programs known to compile and run against them.
40 ODBC is not quite as mature, but may work depending on your needs.
41
42 %description -l pl
43 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
44 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
45 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
46 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
47 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
48 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
49
50 %package devel
51 Summary:        FreeTDS header files
52 Summary(pl):    Pliki nag³ówkowe FreeTDS
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 FreeTDS header files.
58
59 %description devel -l pl
60 Pliki nag³ówkowe FreeTDS.
61
62 %package static
63 Summary:        FreeTDS static libraries
64 Summary(pl):    Statyczne biblioteki FreeTDS
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 FreeTDS static libraries.
70
71 %description static -l pl
72 Statyczne biblioteki FreeTDS.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         --with-tdsver=%{tdsver} \
84         %{?with_msdblib:--with-msdblib} \
85         --with-unixodbc=/usr
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT \
93         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
94
95 mv -f src/pool/BUGS BUGS.pool
96 mv -f src/pool/README README.pool
97 mv -f src/pool/TODO TODO.pool
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 /sbin/ldconfig
104 if [ -f /etc/freetds.conf ]; then
105         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
106 fi
107
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS BUGS* ChangeLog README* TODO*
113 %attr(755,root,root) %{_libdir}/lib*.so.*.*
114 %attr(755,root,root) %{_bindir}/*
115 %dir %{_sysconfdir}
116 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
117 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
118 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pool.conf
119 %{_mandir}/man1/*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/lib*.so
124 %{_libdir}/lib*.la
125 %{_includedir}/*
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/lib*.a
This page took 0.329145 seconds and 2 git commands to generate.