]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
24de25e65d2da56f5e59b8b73accdd5504988ade
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 # _with_msdblib - use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.61
18 Release:        1
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tgz
22 Patch0:         %{name}-nolibnsl.patch
23 URL:            http://www.freetds.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  glib-devel
27 BuildRequires:  libltdl-devel
28 BuildRequires:  libtool
29 BuildRequires:  unixODBC-devel
30 Requires(post): /sbin/ldconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/tds
34
35 %description
36 FreeTDS is a free (open source) implementation of Sybase's db-lib,
37 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
38 databases). Currently, dblib and ctlib are most mature. Both of these
39 libraries have several programs known to compile and run against them.
40 ODBC is not quite as mature, but may work depending on your needs.
41
42 %description -l pl
43 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
44 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
45 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
46 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
47 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
48 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
49
50 %package devel
51 Summary:        FreeTDS header files
52 Summary(pl):    Pliki nag³ówkowe FreeTDS
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}
55
56 %description devel
57 FreeTDS header files.
58
59 %description devel -l pl
60 Pliki nag³ówkowe FreeTDS.
61
62 %package static
63 Summary:        FreeTDS static libraries
64 Summary(pl):    Statyczne biblioteki FreeTDS
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}
67
68 %description static
69 FreeTDS static libraries.
70
71 %description static -l pl
72 Statyczne biblioteki FreeTDS.
73
74 %prep
75 %setup -q
76 %patch -p1
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --with-tdsver=%{tdsver} \
85         %{?_with_msdblib:--with-msdblib} \
86         --with-unixodbc
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT \
94         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/ldconfig
101 if [ -f /etc/freetds.conf ]; then
102         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
103 fi
104
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS BUGS ChangeLog README* TODO
110 %attr(755,root,root) %{_libdir}/lib*.so.*.*
111 %attr(755,root,root) %{_bindir}/*
112 %dir %{_sysconfdir}
113 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
114 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
115 %{_mandir}/man1/*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_includedir}/*
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/lib*.a
This page took 0.187208 seconds and 2 git commands to generate.