]> git.pld-linux.org Git - packages/freeswan.git/commitdiff
- FreeS/WAN patches
authorJacek Konieczny <jajcus@pld-linux.org>
Tue, 25 Apr 2000 15:33:01 +0000 (15:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    freeswan-Makefiles.patch -> 1.1
    freeswan-config.patch -> 1.1
    freeswan-init.patch -> 1.1
    freeswan-manlink.patch -> 1.1

freeswan-Makefiles.patch [new file with mode: 0644]
freeswan-config.patch [new file with mode: 0644]
freeswan-init.patch [new file with mode: 0644]
freeswan-manlink.patch [new file with mode: 0644]

diff --git a/freeswan-Makefiles.patch b/freeswan-Makefiles.patch
new file mode 100644 (file)
index 0000000..c9e7dc7
--- /dev/null
@@ -0,0 +1,319 @@
+diff -durN freeswan-1.3.orig/Makefile freeswan-1.3/Makefile
+--- freeswan-1.3.orig/Makefile Tue Feb  8 22:22:28 2000
++++ freeswan-1.3/Makefile      Tue Apr 25 11:44:45 2000
+@@ -16,21 +16,17 @@
+ # public and private command directories
+ # Beware, many things define PATH settings which are assumed to include
+ # PUBDIR (or at least, to include *some* copy of the "ipsec" command).
+-PUBDIR=/usr/local/sbin
++PUBDIR=/usr/sbin
+ # PRIVDIR is where things get put, FINALPRIVDIR is where they think they
+ # will be put (currently only used by utils/ipsec)
+-PRIVDIR=/usr/local/lib/ipsec
+-FINALPRIVDIR=/usr/local/lib/ipsec
++PRIVDIR=/usr/lib/ipsec
++FINALPRIVDIR=/usr/lib/ipsec
+ # where manpages go
+-MANTREE=/usr/local/man
++MANTREE=/usr/share/man
+ # all relevant manpage subdirectories
+ MANPLACES=man3 man5 man8
+ # where boot/shutdown scripts go (first one that exists gets it)
+-RCDIRS=/etc/rc.d/init.d /etc/rc.d /etc/init.d /sbin/init.d
+-RCDIR=$(shell for d in $(RCDIRS) ; \
+-              do if test -d $$d ; \
+-              then echo $$d ; exit 0 ; \
+-              fi ; done ; echo /unknown )
++RCDIR=/etc/rc.d/init.d
+ # kernel location, and location of kernel patches in the distribution
+ KERNELSRC=/usr/src/linux
+@@ -205,8 +201,8 @@
+ SETTINGS=BINDIR=$(PRIVDIR) PUBDIR=$(PUBDIR) PRIVDIR=$(PRIVDIR) \
+       FINALPRIVDIR=$(FINALPRIVDIR) MANTREE=$(MANTREE) INSTALL="$(INSTALL)"
+ install:
+-      mkdir -p $(PRIVDIR) $(PUBDIR)
+-      for m in $(MANPLACES) ; do mkdir -p $(MANTREE)/$$m ; done
++      mkdir -p $(DESTDIR)$(PRIVDIR) $(DESTDIR)$(PUBDIR)
++      for m in $(MANPLACES) ; do mkdir -p $(DESTDIR)$(MANTREE)/$$m ; done
+       cd lib ; $(MAKE) install $(SETTINGS)
+       cd klips/utils ; $(MAKE) install $(SETTINGS)
+       cd pluto ; $(MAKE) install $(SETTINGS)
+diff -durN freeswan-1.3.orig/klips/utils/Makefile freeswan-1.3/klips/utils/Makefile
+--- freeswan-1.3.orig/klips/utils/Makefile     Tue Feb  8 22:22:06 2000
++++ freeswan-1.3/klips/utils/Makefile  Tue Apr 25 11:44:45 2000
+@@ -14,7 +14,7 @@
+ # RCSID $Id$
+ CC=gcc
+-CFLAGS=-O2 -I../net/ipsec -I../../lib -g
++CFLAGS=$(OPT_FLAGS) -I../net/ipsec -I../../lib
+ CFLAGS+= -Wall
+ #CFLAGS+= -Wconversion
+@@ -30,8 +30,8 @@
+ CFLAGS+= -Wbad-function-cast 
+ ALL=spi eroute spigrp tncfg klipsdebug
+-BINDIR=/usr/local/lib/ipsec
+-MANTREE=/usr/local/man
++BINDIR=/usr/lib/ipsec
++MANTREE=/usr/share/man
+ MANDIR=$(MANTREE)/man8
+ FREESWANLIB=../../lib/libfreeswan.a
+ INSTALL=install
+@@ -39,9 +39,9 @@
+ all: $(ALL)
+ install: $(ALL)
+-      $(INSTALL) $(ALL) $(BINDIR)
++      $(INSTALL) $(ALL) $(DESTDIR)$(BINDIR)
+       for f in $(addsuffix .8, $(ALL)) ; do \
+-              $(INSTALL) $$f $(MANDIR)/ipsec_$$f || exit 1 ; done
++              $(INSTALL) $$f $(DESTDIR)$(MANDIR)/ipsec_$$f || exit 1 ; done
+ spi: spi.o
+       $(CC) $(DFLAGS) -o $@ $? $(FREESWANLIB)
+diff -durN freeswan-1.3.orig/lib/Makefile freeswan-1.3/lib/Makefile
+--- freeswan-1.3.orig/lib/Makefile     Tue Feb  8 22:22:09 2000
++++ freeswan-1.3/lib/Makefile  Tue Apr 25 11:44:45 2000
+@@ -19,9 +19,9 @@
+ HDRS=freeswan.h internal.h
+ LIB=libfreeswan.a
+ # Original flags
+-CFLAGS=-O3 -I.
++CFLAGS=$(OPT_FLAGS) -I.
+ # Add debugging symbols
+-CFLAGS+= -g
++#CFLAGS+= -g
+ CFLAGS+= -Wall
+ #CFLAGS+= -Wconversion
+ #CFLAGS+= -Wmissing-prototypes
+@@ -36,9 +36,9 @@
+ CFLAGS+= -Wbad-function-cast 
+ ARFLAGS=crvs
+-EXTHDRS=des.h gmp.h
+-EXTLIBS=libdes.a libgmp.a
+-MANTREE=/usr/local/man
++EXTHDRS=des.h
++EXTLIBS=libdes.a
++MANTREE=/usr/share/man
+ MANDIR=$(MANTREE)/man3
+ MANS=atoaddr.3 atoasr.3 atodata.3 atosa.3 atoul.3 goodmask.3 optionsfrom.3 \
+       subnetof.3
+@@ -50,11 +50,11 @@
+ all:  $(EXTHDRS) $(LIB) $(EXTLIBS)
+ install:
+-      mkdir -p $(MANDIR)
++      mkdir -p $(DESTDIR)$(MANDIR)
+       for f in $(MANS) ; \
+       do \
+-              $(INSTALL) $$f $(MANDIR)/ipsec_$$f || exit 1 ; \
+-              ../utils/manlink $(MANDIR) ipsec_$$f ; \
++              $(INSTALL) $$f $(DESTDIR)$(MANDIR)/ipsec_$$f || exit 1 ; \
++              ../utils/manlink $(DESTDIR)$(MANDIR) ipsec_$$f ; \
+       done
+ $(LIB):       $(OBJS)
+diff -durN freeswan-1.3.orig/libdes/Makefile freeswan-1.3/libdes/Makefile
+--- freeswan-1.3.orig/libdes/Makefile  Thu Nov 25 18:04:25 1999
++++ freeswan-1.3/libdes/Makefile       Tue Apr 25 11:44:45 2000
+@@ -46,7 +46,7 @@
+ CC=gcc
+ #CFLAG= -O4 -funroll-loops -fomit-frame-pointer
+-CFLAG= -O3 -fomit-frame-pointer
++CFLAG= $(OPT_FLAGS) -fomit-frame-pointer
+ CFLAGS=$(OPTS) $(CFLAG)
+ CPP=$(CC) -E
+@@ -59,10 +59,10 @@
+ #DES_ENC=asm/dx86-sol.o       asm/yx86-sol.o  # solaris format x86 
+ #DES_ENC=asm/dx86bsdi.o       asm/yx86basi.o  # bsdi format x86 
+-LIBDIR=/usr/local/lib
+-BINDIR=/usr/local/bin
+-INCDIR=/usr/local/include
+-MANDIR=/usr/local/man
++LIBDIR=/usr/lib
++BINDIR=/usr/bin
++INCDIR=/usr/include
++MANDIR=/usr/man
+ MAN1=1
+ MAN3=3
+ SHELL=/bin/sh
+@@ -231,20 +231,16 @@
+           chmod 644 $(INSTALLTOP)/include/des.h; \
+       else \
+           echo Standalone install; \
+-          cp $(DLIB) $(LIBDIR)/$(DLIB); \
++          cp $(DLIB) $(DESTDIR)$(LIBDIR)/$(DLIB); \
+           if test -s /bin/ranlib; then \
+-            /bin/ranlib $(LIBDIR)/$(DLIB); \
++            /bin/ranlib $(DESTDIR)$(LIBDIR)/$(DLIB); \
+           else \
+             if test -s /usr/bin/ranlib; then \
+-              /usr/bin/ranlib $(LIBDIR)/$(DLIB); \
++              /usr/bin/ranlib $(DESTDIR)$(LIBDIR)/$(DLIB); \
+             fi; \
+           fi; \
+-          chmod 644 $(LIBDIR)/$(DLIB); \
+-          cp des_crypt.man $(MANDIR)/man$(MAN3)/des_crypt.$(MAN3); \
+-          chmod 644 $(MANDIR)/man$(MAN3)/des_crypt.$(MAN3); \
+-          cp des.man $(MANDIR)/man$(MAN1)/des.$(MAN1); \
+-          chmod 644 $(MANDIR)/man$(MAN1)/des.$(MAN1); \
+-          cp des.h $(INCDIR)/des.h; \
+-          chmod 644 $(INCDIR)/des.h; \
++          cp des_crypt.man $(DESTDIR)$(MANDIR)/man$(MAN3)/des_crypt.$(MAN3); \
++          cp des.man $(DESTDIR)$(MANDIR)/man$(MAN1)/des.$(MAN1); \
++          cp des.h $(DESTDIR)$(INCDIR)/des.h; \
+       fi
+ # DO NOT DELETE THIS LINE -- make depend depends on it.
+diff -durN freeswan-1.3.orig/pluto/Makefile freeswan-1.3/pluto/Makefile
+--- freeswan-1.3.orig/pluto/Makefile   Fri Dec 17 03:42:19 1999
++++ freeswan-1.3/pluto/Makefile        Tue Apr 25 11:45:57 2000
+@@ -19,10 +19,10 @@
+ CC = gcc
+ # directory in which to install programs
+-BINDIR=/usr/local/lib/ipsec
++BINDIR=/usr/lib/ipsec
+ # directory in which to install man pages
+-MANTREE=/usr/local/man
++MANTREE=/usr/share/man
+ FMANDIR=$(MANTREE)/man5
+ PMANDIR=$(MANTREE)/man8
+@@ -37,7 +37,7 @@
+ INSTALL=install
+ # -O on Linux makes gcc coredump when compiling sha1.c
+-CFLAGS = -g -Wall -W -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast \
++CFLAGS = $(OPT_FLAGS) -Wall -W -Wmissing-prototypes -Wpointer-arith -Wbad-function-cast \
+       -Wcast-qual -Wmissing-declarations -Wwrite-strings -Wstrict-prototypes
+ # where to find klips headers and FreeS/WAN headers
+@@ -74,7 +74,7 @@
+ CPPFLAGS = $(HDRDIRS) $(BYTE_ORDER) \
+       -DPLUTO -DKLIPS -DROAD_WARRIOR_FUDGE -DDODGE_DH_MISSING_ZERO_BUG \
+-      -DDEBUG -DGCC_LINT
++      -DDEBUG -DGCC_LINT -DSHARED_SECRETS_FILE='"/etc/freeswan/ipsec.secrets"'
+ ALLFLAGS = $(CPPFLAGS) $(CFLAGS)
+@@ -142,21 +142,21 @@
+ OBJSPLUTO = connections.o constants.o cookie.o crypto.o defs.o log.o \
+       state.o main.o server.o timer.o id.o ipsec_doi.o kernel.o \
+       kernel_comm.o demux.o packet.o preshared.o rnd.o spdb.o \
+-      sha1.o md5.o $(OBJSGCRYPT) $(LIBDESLITE) $(LIBGMP) $(FREESWANLIB)
++      sha1.o md5.o $(OBJSGCRYPT) $(LIBDESLITE) $(FREESWANLIB)
+ OBJSWHACK = whack.o $(FREESWANLIB)
+ all: $(BINNAMEPLUTO) $(BINNAMEWHACK)
+ install: all
+-      $(INSTALL) $(BINNAMEPLUTO) $(BINNAMEWHACK) $(BINDIR)
+-      $(INSTALL) pluto.8 $(PMANDIR)/ipsec_pluto.8
+-      ../utils/manlink $(PMANDIR) ipsec_pluto.8
+-      $(INSTALL) ipsec.secrets.5 $(FMANDIR)
+-      ../utils/manlink $(FMANDIR) ipsec.secrets.5
++      $(INSTALL) $(BINNAMEPLUTO) $(BINNAMEWHACK) $(DESTDIR)$(BINDIR)
++      $(INSTALL) pluto.8 $(DESTDIR)$(PMANDIR)/ipsec_pluto.8
++      ../utils/manlink $(DESTDIR)$(PMANDIR) ipsec_pluto.8
++      $(INSTALL) ipsec.secrets.5 $(DESTDIR)$(FMANDIR)
++      ../utils/manlink $(DESTDIR)$(FMANDIR) ipsec.secrets.5
+ $(BINNAMEPLUTO): $(OBJSPLUTO)
+-      $(CC) -o $(BINNAMEPLUTO) $(LDFLAGS) $(OBJSPLUTO) $(LIBSPLUTO)
++      $(CC) -o $(BINNAMEPLUTO) $(LDFLAGS) $(OBJSPLUTO) $(LIBSPLUTO) -lgmp
+ $(BINNAMEWHACK): $(OBJSWHACK)
+       $(CC) -o $(BINNAMEWHACK) $(OBJSWHACK) $(LIBSWHACK)
+diff -durN freeswan-1.3.orig/utils/Makefile freeswan-1.3/utils/Makefile
+--- freeswan-1.3.orig/utils/Makefile   Tue Feb  8 22:22:30 2000
++++ freeswan-1.3/utils/Makefile        Tue Apr 25 11:44:45 2000
+@@ -14,12 +14,12 @@
+ # RCSID $Id$
+ # pathnames, subject to overrides from main Makefile
+-PUBDIR=/usr/local/sbin
+-PRIVDIR=/usr/local/lib/ipsec
+-FINALPRIVDIR=/usr/local/lib/ipsec
++PUBDIR=/usr/sbin
++PRIVDIR=/usr/lib/ipsec
++FINALPRIVDIR=/usr/lib/ipsec
+ RCDIR=/etc/rc.d/init.d
+-CONFDIR=/etc
+-MANTREE=/usr/local/man
++CONFDIR=/etc/freeswan
++MANTREE=/usr/share/man
+ FMANDIR=$(MANTREE)/man5
+ CMANDIR=$(MANTREE)/man8
+@@ -50,7 +50,7 @@
+       $(CC) $(CFLAGS) ranbits.o $(LIB) -o $@
+ rsasigkey:    rsasigkey.o
+-      $(CC) $(CFLAGS) rsasigkey.o $(LIB) ../lib/libgmp.a -o $@
++      $(CC) $(CFLAGS) rsasigkey.o $(LIB) -lgmp -o $@
+ man_xref:     man_xref.o
+       $(CC) $(CFLAGS) man_xref.o $(LIB) -o $@
+@@ -80,38 +80,24 @@
+       ./randomize conf.proto | egrep -v RCSI >$@
+ install:      $(PUBS) $(PRIVS) $(MANS) $(GENDFILES)
+-      mkdir -p $(PUBDIR) $(PRIVDIR) $(FMANDIR) $(CMANDIR)
+-      $(INSTALL) $(PUBS) $(PUBDIR)
+-      $(INSTALL) $(PRIVS) $(PRIVDIR)
+-      $(INSTALL) $(PUB) ipsec.conf.5 $(FMANDIR)
+-      $(INSTALL) $(PUB) $(PLAIN_MANS) $(CMANDIR)
++      mkdir -p $(DESTDIR)$(PUBDIR) $(DESTDIR)$(PRIVDIR) $(DESTDIR)$(FMANDIR) $(DESTDIR)$(CMANDIR)
++      $(INSTALL) $(PUBS) $(DESTDIR)$(PUBDIR)
++      $(INSTALL) $(PRIVS) $(DESTDIR)$(PRIVDIR)
++      $(INSTALL) $(PUB) ipsec.conf.5 $(DESTDIR)$(FMANDIR)
++      $(INSTALL) $(PUB) $(PLAIN_MANS) $(DESTDIR)$(CMANDIR)
+       for f in $(IPSEC_CMANS) ; \
+       do \
+-              $(INSTALL) $(PUB) $$f $(CMANDIR)/ipsec_$$f || exit 1 ; \
+-              ./manlink $(CMANDIR) ipsec_$$f ; \
++              $(INSTALL) $(PUB) $$f $(DESTDIR)$(CMANDIR)/ipsec_$$f || exit 1 ; \
++              ./manlink $(DESTDIR)$(CMANDIR) ipsec_$$f ; \
+       done
+-      test -f $(CONFDIR)/ipsec.secrets || \
+-              $(INSTALL) $(PRIV) secrets.eg $(CONFDIR)/ipsec.secrets
+-      test -f $(CONFDIR)/ipsec.conf || \
+-              $(INSTALL) $(PUB) conf.eg $(CONFDIR)/ipsec.conf
++      test -f $(DESTDIR)$(CONFDIR)/ipsec.secrets || \
++              $(INSTALL) $(PRIV) secrets.eg $(DESTDIR)$(CONFDIR)/ipsec.secrets
++      test -f $(DESTDIR)$(CONFDIR)/ipsec.conf || \
++              $(INSTALL) $(PUB) conf.eg $(DESTDIR)$(CONFDIR)/ipsec.conf
+       # main copy must go in RCDIR, PRIVDIR may not be mounted at boot time
+-      $(INSTALL) setup $(RCDIR)/ipsec
+-      rm -f $(PRIVDIR)/setup
+-      ln -s $(RCDIR)/ipsec $(PRIVDIR)/setup
+-      if which chkconfig >/dev/null 2>&1 ; \
+-      then chkconfig --add ipsec ; \
+-      else $(MAKE) setup4 ; \
+-      fi
+-
+-setup4:       $(RCDIR)/ipsec
+-      # fallback rc install -- on in run states 2345, off in 016
+-      -cd $(RCDIR)/../rc0.d ; ln -s ../init.d/ipsec K35ipsec
+-      -cd $(RCDIR)/../rc1.d ; ln -s ../init.d/ipsec K35ipsec
+-      -cd $(RCDIR)/../rc2.d ; ln -s ../init.d/ipsec S35ipsec
+-      -cd $(RCDIR)/../rc3.d ; ln -s ../init.d/ipsec S35ipsec
+-      -cd $(RCDIR)/../rc4.d ; ln -s ../init.d/ipsec S35ipsec
+-      -cd $(RCDIR)/../rc5.d ; ln -s ../init.d/ipsec S35ipsec
+-      -cd $(RCDIR)/../rc6.d ; ln -s ../init.d/ipsec K35ipsec
++      $(INSTALL) setup $(DESTDIR)$(RCDIR)/ipsec
++      rm -f $(DESTDIR)$(PRIVDIR)/setup
++      ln -s $(RCDIR)/ipsec $(DESTDIR)$(PRIVDIR)/setup
+ clean:
+       rm -f *.o $(BINS) $(GENDFILES) $(LOCALS)
diff --git a/freeswan-config.patch b/freeswan-config.patch
new file mode 100644 (file)
index 0000000..9103c85
--- /dev/null
@@ -0,0 +1,51 @@
+diff -durN freeswan-1.3.orig/utils/_confread freeswan-1.3/utils/_confread
+--- freeswan-1.3.orig/utils/_confread  Tue Feb  8 22:22:30 2000
++++ freeswan-1.3/utils/_confread       Tue Apr 25 11:59:19 2000
+@@ -41,7 +41,7 @@
+ #     exit 1
+ # fi
+-config=/etc/ipsec.conf
++config=/etc/freeswan/ipsec.conf
+ include=yes
+ type=conn
+ fieldfmt=yes
+diff -durN freeswan-1.3.orig/utils/auto freeswan-1.3/utils/auto
+--- freeswan-1.3.orig/utils/auto       Tue Feb  8 22:22:30 2000
++++ freeswan-1.3/utils/auto    Tue Apr 25 11:59:59 2000
+@@ -24,7 +24,7 @@
+       other options: [--config ipsecconfigfile] [--verbose] [--show]"
+ showonly=
+-config=/etc/ipsec.conf
++config=/etc/freeswan/ipsec.conf
+ info=/var/run/ipsec.info
+ shopts=
+ noinclude=
+diff -durN freeswan-1.3.orig/utils/barf freeswan-1.3/utils/barf
+--- freeswan-1.3.orig/utils/barf       Tue Feb  8 22:22:30 2000
++++ freeswan-1.3/utils/barf    Tue Apr 25 12:00:35 2000
+@@ -79,9 +79,9 @@
+ _________________________
+ ipsec showdefaults
+ _________________________
+-ipsec _include /etc/ipsec.conf | ipsec _keycensor
++ipsec _include /etc/freeswan/ipsec.conf | ipsec _keycensor
+ _________________________
+-ipsec _include /etc/ipsec.secrets | ipsec _secretcensor
++ipsec _include /etc/freeswan/ipsec.secrets | ipsec _secretcensor
+ _________________________
+ cat /proc/net/dev
+ _________________________
+diff -durN freeswan-1.3.orig/utils/manual freeswan-1.3/utils/manual
+--- freeswan-1.3.orig/utils/manual     Tue Feb  8 22:22:31 2000
++++ freeswan-1.3/utils/manual  Tue Apr 25 12:01:37 2000
+@@ -28,7 +28,7 @@
+ export LANG LC_ALL
+ showonly=
+-config=/etc/ipsec.conf
++config=/etc/freeswan/ipsec.conf
+ info=/var/run/ipsec.info
+ shopts=
+ other=0
diff --git a/freeswan-init.patch b/freeswan-init.patch
new file mode 100644 (file)
index 0000000..9f9c601
--- /dev/null
@@ -0,0 +1,64 @@
+diff -durN freeswan-1.3.orig/utils/setup freeswan-1.3/utils/setup
+--- freeswan-1.3.orig/utils/setup      Tue Feb  8 22:22:32 2000
++++ freeswan-1.3/utils/setup   Tue Apr 25 12:17:30 2000
+@@ -37,6 +37,8 @@
+       export PATH
+ fi
++. /etc/rc.d/init.d/functions
++
+ me='ipsec setup'              # for messages
+ # make sure output of (e.g.) ifconfig is in English
+@@ -376,7 +378,7 @@
+ # logging control
+ logit() {
+       IPSECsyslog=${IPSECsyslog-daemon.error}
+-      logger -s -p $IPSECsyslog -t ipsec_setup 2>&1
++      logger -p $IPSECsyslog -t ipsec_setup 2>&1
+ }
+@@ -395,12 +397,14 @@
+       # Start things rolling.
+       # (Warning, changes to this log message may affect barf.)
+       version="`ipsec --version | awk 'NR == 1 { print $3 }'`"
++      show "Starting FreeS/WAN IPSEC"; busy
+       echo "Starting FreeS/WAN IPSEC $version..." | logit
+       rm -f $nexthop $info
+       if test ! -r /dev/random
+       then
+               echo "...unable to start FreeS/WAN IPSEC, no /dev/random!" |
+                                                                       logit
++              deltext; fail
+               exit 1
+       fi
+       startklips 2>&1 | logit
+@@ -426,10 +430,12 @@
+               plutogo 2>&1 | logit
+       fi
+       echo "...FreeS/WAN IPSEC started" | logit
++      deltext; ok
+       ;;
+   stop|--stop)
+       # Shut things down.
++      show "Stopping FreeS/WAN IPSEC" ; busy
+       echo "Stopping FreeS/WAN IPSEC..." | logit
+       if test " $IPSECforwardcontrol" = " yes"
+       then
+@@ -480,8 +486,14 @@
+       fi
+       rm -f $nexthop $info
+       echo "...FreeS/WAN IPSEC stopped" | logit
++      deltext; ok
+       ;;
++  status|--status)
++      status pluto
++      ipsec look
++      ;;
++      
+   restart|--restart)
+       $0 stop
+       $0 start
diff --git a/freeswan-manlink.patch b/freeswan-manlink.patch
new file mode 100644 (file)
index 0000000..98d8a1a
--- /dev/null
@@ -0,0 +1,12 @@
+diff -durN freeswan-1.3.orig1/utils/manlink freeswan-1.3/utils/manlink
+--- freeswan-1.3.orig1/utils/manlink   Wed Jul  7 05:12:52 1999
++++ freeswan-1.3/utils/manlink Tue Apr 25 11:38:27 2000
+@@ -49,7 +49,7 @@
+               esac
+               if test " $ff" != " $m"
+               then
+-                      ln -f -s $m $ff
++                      echo ".so $m" > $ff
+               fi
+       done
+ done
This page took 0.063297 seconds and 4 git commands to generate.