]> git.pld-linux.org Git - packages/freeradius.git/commitdiff
need more fixes, because dont detect proper location of pgsql headers
authorMaciej Pijanka <agaran@pld-linux.org>
Mon, 2 Jul 2001 01:40:49 +0000 (01:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
(maybe ac/am broken) and some parts looks ugly, btw we should use rm or
%{__rm} and so on?

Changed files:
    freeradius.spec -> 1.3

freeradius.spec

index 9abe461e1711716c758495a2d5ced4b10a4d7c44..e7cecaf397265460bb7c5d1fcf064b875afd4b26 100644 (file)
@@ -1,13 +1,14 @@
 # FIXME: find a way of getting rid of "-" on versions ... rpm will be happy
 Summary:       High-performance and highly configurable RADIUS server
 Summary(pl):   Szybki i wysoce konfigurowalny serwer RADIUS.
-Name:          freeradius
-Version:       0.1
-Release:       0
+Name:          freeradius
+Version:       0.1
+Release:       0
 URL:           http://www.freeradius.org/
-Copyright:     GPL
+License:       GPL
 Group:         Networking/Daemons
-Group(pl):     Sieciowe/Demony
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
 Prereq:                /sbin/chkconfig
 # FIXME: snmpwalk, snmpget and rusers POSSIBLY needed by checkrad
 Requires:      libtool
@@ -18,29 +19,28 @@ BuildRequires:      mysql-devel
 BuildRequires: postgresql-devel
 BuildRequires: pam-devel
 Obsoletes:     cistron-radius
-Source0:       ftp://ftp.freeradius.org/pub/radius/freeradius-0.1.tar.gz
+Source0:       ftp://ftp.freeradius.org/pub/radius/%{name}-%{version}.tar.gz
 
 %define         _localstatedir  /var/radius
-%define                _make           make
-
 
 # FIXME: won't be good to include these contrib examples?
 # Source1:     http://www.ping.de/~fdc/radius/radacct-replay
 # Source2:     http://www.ping.de/~fdc/radius/radlast-0.03
 # Source3:     ftp://ftp.freeradius.org/pub/radius/contrib/radwho.cgi
 
-BuildRoot: /tmp/%{name}-%{version}-root
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The FreeRADIUS Server Project is an attempt to create a high-performance 
-and highly configurable GPL'd RADIUS server. It is generally similar to 
-the Livingston 2.0 RADIUS server, but has a lot more features, and is 
-much more configurable.
+The FreeRADIUS Server Project is an attempt to create a
+high-performance and highly configurable GPL'd RADIUS server. It is
+generally similar to the Livingston 2.0 RADIUS server, but has a lot
+more features, and is much more configurable.
 
 %description(pl)
-Projekt FreeRadius ma na celu stworzenie szybkiego i wysoce konfigurowalnego 
-serwera RADIUS na licencji GPL. Ten jest podobny do Livingston 2.0 RADIUS server
-ale ma o wiele wiêcej ficzersów i jest bardziej podatny na konfiguracjê.
+Projekt FreeRadius ma na celu stworzenie szybkiego i wysoce
+konfigurowalnego serwera RADIUS na licencji GPL. Ten jest podobny do
+Livingston 2.0 RADIUS server ale ma o wiele wiêcej ficzersów i jest
+bardziej podatny na konfiguracjê.
 
 %prep 
 %setup -q
@@ -51,47 +51,46 @@ ale ma o wiele wi
 #cd ..
 
 %build
-CFLAGS="$RPM_OPT_FLAGS
+CFLAGS="%{rpmcflags}
 #libtoolize --copy --force
 #aclocal
 #autoconf
 #automake -a -c
 
-%configure --prefix=/usr --localstatedir=%{_localstatedir} --sysconfdir=/etc \
-       --mandir=/usr/man \
+%configure --localstatedir=%{_localstatedir} \
        --with-threads \
        --with-thread-pool \
        --with-gnu-ld \
        --disable-ltdl-install
-%{_make}
+%{__make}
 
-libtool --finish /usr/lib
+libtool --finish %{_libdir}
 
 %install
 # prepare $RPM_BUILD_ROOT
 rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d,rc.d/init.d}
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/{logrotate.d,pam.d,rc.d/init.d}
 
 # install files
-make install R=$RPM_BUILD_ROOT
+%{__make} install R=$RPM_BUILD_ROOT
 # done here & put noreplace in %files to avoid messing up existing installations
 for i in radutmp radwtmp  radius.log radwatch.log checkrad.log
 do
   touch  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
   echo  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
   #who the hell should own logfiles/ and what sgid should have radiusd ?
-  # do we need /etc/shadow do be +r for wheel ? or better use PAM ?
+# do we need %{_sysconfdir}/shadow do be +r for wheel ? or better use PAM ?
   # Hunter
 done
 
 
 # remove unneeded stuff
-rm -f $RPM_BUILD_ROOT/usr/{man/man8/builddbm.8,sbin/rc.radiusd}
+%{__rm} -f $RPM_BUILD_ROOT%{_prefix}/{man/man8/builddbm.8,sbin/rc.radiusd}
 
 cd redhat
 install -m 555 rc.radiusd-redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/radiusd
-install -m 644 radiusd-logrotate $RPM_BUILD_ROOT/etc/logrotate.d/radiusd
-install -m 644 radiusd-pam       $RPM_BUILD_ROOT/etc/pam.d/radius
+install radiusd-logrotate $RPM_BUILD_ROOT/etc/logrotate.d/radiusd
+install radiusd-pam       $RPM_BUILD_ROOT/etc/pam.d/radius
 cd ..
 
 %preun
@@ -105,32 +104,22 @@ if [ "$1" = "0" ]; then
 fi
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+%{__rm} -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(-,root,root)
+%defattr(644,root,root,755)
 %doc doc/ChangeLog doc/README* todo/ COPYRIGHT INSTALL
 %config /etc/pam.d/radius
 %config /etc/logrotate.d/radiusd
 %config /etc/rc.d/init.d/radiusd
-%config /etc/raddb/*
-/usr/man/*
-/usr/bin/*
-/usr/sbin/*
-/usr/lib/*
+%config %{_sysconfdir}/raddb/*
+%{_prefix}/man/*
+%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_sbindir}/*
+%{_libdir}/*
 %dir %{_localstatedir}/log/radacct/
 %config(missingok noreplace) %{_localstatedir}/log/checkrad.log
 %config(missingok noreplace) %{_localstatedir}/log/radwatch.log
 %config(missingok noreplace) %{_localstatedir}/log/radius.log
 %config(missingok noreplace) %{_localstatedir}/log/radwtmp
 %config(missingok noreplace) %{_localstatedir}/log/radutmp
-
-%changelog
-* Fri Sep 22 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
-- spec file clear accordling to the libltdl fix and minor updates
-
-* Wed Sep 12 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
-- Updated to snapshot-12-Sep-00
-
-* Fri Jun 16 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
-- Initial release
This page took 0.039836 seconds and 4 git commands to generate.