]> git.pld-linux.org Git - packages/freeradius.git/blob - freeradius.spec
e45dc0d4309e11c76e9ae0be3a9515b013b295af
[packages/freeradius.git] / freeradius.spec
1 # FIXME: find a way of getting rid of "-" on versions ... rpm will be happy
2 Summary:        High-performance and highly configurable RADIUS server
3 Summary(pl):    Szybki i wysoce konfigurowalny serwer RADIUS.
4 Name:           freeradius
5 Version:        0.1
6 Release:        0
7 URL:            http://www.freeradius.org/
8 Copyright:      GPL
9 Group:          Networking/Daemons
10 Group(pl):      Sieciowe/Demony
11 Prereq:         /sbin/chkconfig
12 # FIXME: snmpwalk, snmpget and rusers POSSIBLY needed by checkrad
13 Requires:       libtool
14 BuildRequires:  libltdl-devel
15 BuildRequires:  openldap-devel
16 #someone's help needed:split&test into %{name}-{mysql,pgsql,common,devel,static,ldap,pam?} hunter.
17 BuildRequires:  mysql-devel
18 BuildRequires:  postgresql-devel
19 BuildRequires:  pam-devel
20 Obsoletes:      cistron-radius
21 Source0:        freeradius-0.1.tar.gz
22
23 %define         _localstatedir  /var/radius
24 %define         _make           make
25
26
27 # FIXME: won't be good to include these contrib examples?
28 # Source1:      http://www.ping.de/~fdc/radius/radacct-replay
29 # Source2:      http://www.ping.de/~fdc/radius/radlast-0.03
30 # Source3:      ftp://ftp.freeradius.org/pub/radius/contrib/radwho.cgi
31
32 BuildRoot: /tmp/%{name}-%{version}-root
33
34 %description
35 The FreeRADIUS Server Project is an attempt to create a high-performance 
36 and highly configurable GPL'd RADIUS server. It is generally similar to 
37 the Livingston 2.0 RADIUS server, but has a lot more features, and is 
38 much more configurable.
39
40 %description(pl)
41 Projekt FreeRadius ma na celu stworzenie szybkiego i wysoce konfigurowalnego 
42 serwera RADIUS na licencji GPL. Ten jest podobny do Livingston 2.0 RADIUS server
43 ale ma o wiele wiêcej ficzersów i jest bardziej podatny na konfiguracjê.
44
45 %prep 
46 %setup -q
47
48 # FIXME: some folks prefer -dist files ... rename them or not?
49 #cd raddb
50 #chmod 640 clients naspasswd radiusd.conf.in
51 #cd ..
52
53 %build
54 CFLAGS="$RPM_OPT_FLAGS" 
55 #libtoolize --copy --force
56 #aclocal
57 #autoconf
58 #automake -a -c
59
60 %configure --prefix=/usr --localstatedir=%{_localstatedir} --sysconfdir=/etc \
61         --mandir=/usr/man \
62         --with-threads \
63         --with-thread-pool \
64         --with-gnu-ld \
65         --disable-ltdl-install
66 %{_make}
67
68 libtool --finish /usr/lib
69
70 %install
71 # prepare $RPM_BUILD_ROOT
72 rm -rf $RPM_BUILD_ROOT
73 mkdir -p $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d,rc.d/init.d}
74
75 # install files
76 make install R=$RPM_BUILD_ROOT
77 # done here & put noreplace in %files to avoid messing up existing installations
78 for i in radutmp radwtmp  radius.log radwatch.log checkrad.log
79 do
80   touch  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
81   echo  $RPM_BUILD_ROOT%{_localstatedir}/log/$i
82   #who the hell should own logfiles/ and what sgid should have radiusd ?
83   # do we need /etc/shadow do be +r for wheel ? or better use PAM ?
84   # Hunter
85 done
86
87
88 # remove unneeded stuff
89 rm -f $RPM_BUILD_ROOT/usr/{man/man8/builddbm.8,sbin/rc.radiusd}
90
91 cd redhat
92 install -m 555 rc.radiusd-redhat $RPM_BUILD_ROOT/etc/rc.d/init.d/radiusd
93 install -m 644 radiusd-logrotate $RPM_BUILD_ROOT/etc/logrotate.d/radiusd
94 install -m 644 radiusd-pam       $RPM_BUILD_ROOT/etc/pam.d/radius
95 cd ..
96
97 %preun
98 if [ "$1" = "0" ]; then
99         /sbin/chkconfig --del radiusd.init
100 fi
101
102 %postin
103 if [ "$1" = "0" ]; then
104         /sbin/chkconfig --add radiusd.init
105 fi
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(-,root,root)
112 %doc doc/ChangeLog doc/README* todo/ COPYRIGHT INSTALL
113 %config /etc/pam.d/radius
114 %config /etc/logrotate.d/radiusd
115 %config /etc/rc.d/init.d/radiusd
116 %config /etc/raddb/*
117 /usr/man/*
118 /usr/bin/*
119 /usr/sbin/*
120 /usr/lib/*
121 %dir %{_localstatedir}/log/radacct/
122 %config(missingok noreplace) %{_localstatedir}/log/checkrad.log
123 %config(missingok noreplace) %{_localstatedir}/log/radwatch.log
124 %config(missingok noreplace) %{_localstatedir}/log/radius.log
125 %config(missingok noreplace) %{_localstatedir}/log/radwtmp
126 %config(missingok noreplace) %{_localstatedir}/log/radutmp
127
128 %changelog
129 * Fri Sep 22 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
130 - spec file clear accordling to the libltdl fix and minor updates
131
132 * Wed Sep 12 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
133 - Updated to snapshot-12-Sep-00
134
135 * Fri Jun 16 2000 Bruno Lopes F. Cabral <bruno@openline.com.br>
136 - Initial release
This page took 0.117512 seconds and 2 git commands to generate.