]> git.pld-linux.org Git - packages/freenet6-client.git/blob - freenet6-client.spec
- updated for 5.1-RELEASE
[packages/freenet6-client.git] / freenet6-client.spec
1 Summary:        Hexago's TSP Client
2 Summary(pl.UTF-8):      Klient TSP Hexago
3 Name:           freenet6-client
4 Version:        4.2.2
5 Release:        1
6 License:        HPL 1.0
7 Group:          Applications/System
8 # Source0: http://www.go6.net/4105/file.asp?file_id=80
9 Source0:        gw6c4_2_2src.tar.gz
10 # Source0-md5:  5e64305e1408b0d3c2c2a5803692eb93
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 Patch0:         %{name}-pld.patch
14 URL:            http://www.freenet6.net/
15 Requires(post,preun):   /sbin/chkconfig
16 Requires:       glibc >= 2.2.1
17 Requires:       iproute2 >= 2.2.4
18 Requires:       net-tools >= 1.60
19 #Requires:      radvd >= 0.6.2
20 Requires:       rc-scripts
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 TSP is a new initiative launched by Hexago, a private company in
25 Canada involved in IPv6 since 1996, to facilitate a faster deployment
26 of an IPv6 Internet. The Internet is deployed worldwide over IPv4 so
27 this project's goal is large scale deployment of IPv6 by using
28 configured tunnels.
29
30 Configured tunneling is a transition method standardized by IETF to
31 use IPv6 in coexistence with IPv4 by encapsulating IPv6 packets over
32 IPv4. Any host already connected to Internet with IPv4 which has an
33 IPv6 stack can establish a link to the Internet IPv6.
34
35 Freenet6, developed by Viagenie in 1999/2000, was the first public
36 tunnel server service and one of the most used in the world to
37 automatically delegate one single IPv6 address to any host already
38 connected to an IPv4 network over configured tunnel simply by filling
39 a web form and running a script. TSP represents another very important
40 step to accelerate the large scale deployment of IPv6 to everyone on
41 the net.
42
43 Instead of a web interface to request configured tunnels and IPv6
44 addresses, TSP is a new model based on a client/server approach. A
45 protocol is used to request a single IPv6 address to a full IPv6
46 prefix from a client to a tunnel server according to the IPv6 broker
47 model. The protocol could be integrated directly into the operating
48 system to provide a service like DHCP but for requesting IPv6
49 addresses or prefixes over an IPv4 network (Internet).
50
51 %description -l pl.UTF-8
52 TSP to nowa inicjatywa zapoczątkowana przez Hexago - prywatną firmę z
53 Kanady zaangażowaną w IPv6 od 1996 roku - aby ułatwić szybszy rozwój
54 Internetu IPv6. Internet jest rozwinięty na całym świecie w oparciu o
55 IPv4, więc celem tego projektu jest rozwinięcie IPv6 na wielką skalę
56 poprzez użycie skonfigurowanych tuneli.
57
58 Skonfigurowane tunele to metoda przejściowa ustandaryzowana przez IETF
59 w celu używania IPv6 w koegzystencji z IPv4 poprzez pakowanie pakietów
60 IPv6 w IPv4. Dowolny host podłączony do Internetu po IPv4 mający stos
61 IPv6 może łączyć się z Internetem IPv6.
62
63 Freenet6 rozwijany przez Viagenie w latach 1999-2000 był pierwszym
64 publicznym serwerem tuneli i jednym z najbardziej używanych na świecie
65 do automatycznego delegowania pojedynczych adresów IPv6 do dowolnego
66 hosta już podłączonego do sieci IPv4 poprzez skonfigurowany tunel po
67 zwykłym wypełnieniu formularza WWW i uruchomieniu skryptu. TSP
68 reprezentuje kolejny bardzo ważny krok do przyspieszenia rozwoju IPv6
69 na szerszą skalę.
70
71 Zamiast interfejsu WWW do żądania skonfigurowanych tuneli i adresów
72 IPv6, TSP jest nowym modelem opartym na komunikacji klient/serwer.
73 Protokół jest używany do żądania od pojedynczego adresu IPv6 do
74 pełnego prefiksu IPv6 od klienta do serwera tuneli zgodnie z modelem
75 brokera IPv6. Protokół może być zintegrowany z systemem operacyjnym,
76 aby udostępnić usługę typu DHCP, ale do żądania adresów lub prefiksów
77 IPv6 po sieci IPv4 (Internecie).
78
79 %prep
80 %setup -q -n tspc-advanced
81 %patch0 -p1
82
83 %build
84 %{__make} all \
85         CC="%{__cc} %{rpmcflags} -I\$(INC) -Wall" \
86         target=linux \
87         installdir=%{_prefix}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/gw6c,%{_initrddir}}
92
93 %{__make} install \
94         target=linux \
95         installdir=$RPM_BUILD_ROOT%{_prefix} \
96         install_bin=$RPM_BUILD_ROOT%{_sbindir} \
97         install_man=$RPM_BUILD_ROOT%{_mandir} \
98         install_template=$RPM_BUILD_ROOT%{_datadir}/gw6c/template
99
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/freenet6
101 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gw6c/gw6c.conf
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_sbindir}/gw6c
109 %dir %{_sysconfdir}/gw6c
110 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gw6c/gw6c.conf
111 %attr(754,root,root) %{_initrddir}/*
112 %dir %{_datadir}/gw6c
113 %dir %{_datadir}/gw6c/template
114 %{_datadir}/gw6c/template/checktunnel.sh
115 %{_datadir}/gw6c/template/linux.sh
116 %{_mandir}/man5/*
117 %{_mandir}/man8/*
118
119 %post
120 /sbin/chkconfig --add freenet6
121 if [ -f /var/lock/subsys/freenet6 ]; then
122         /etc/rc.d/init.d/freenet6 restart 1>&2
123 else
124         echo "Run \"/etc/rc.d/init.d/freenet6 start\" to start freenet6 connection"
125 fi
126
127 %preun
128 if [ "$1" = "0" ]; then
129         if [ -f /var/lock/subsys/freenet6 ]; then
130                 /etc/rc.d/init.d/freenet6 stop 1>&2
131         fi
132         /sbin/chkconfig --del freenet6
133 fi
This page took 0.061381 seconds and 3 git commands to generate.