]> git.pld-linux.org Git - packages/freenet6-client.git/blob - freenet6-client.spec
- rel 2
[packages/freenet6-client.git] / freenet6-client.spec
1 Summary:        Hexago's TSP Client
2 Summary(pl):    Klient TSP Hexago
3 Name:           freenet6-client
4 Version:        1.0
5 Release:        2
6 License:        HPL 1.0
7 Group:          Applications/System
8 Vendor:         Hexago
9 # http://www.freenet6.net/cgi-bin/download.cgi?fn=freenet6-client-1.0.tgz
10 Source0:        http://www.kernel.pl/~djurban/pld/%{name}-%{version}.tgz
11 # Source0-md5:  382450da40cd4334f39e4cad99c583ae
12 Source1:        freenet6.init
13 Source2:        tspc.conf
14 Patch0:         %{name}-paths.patch
15 Patch1:         %{name}-play-nice.patch
16 URL:            http://www.freenet6.net
17 Requires:       glibc >= 2.2.1
18 Requires:       iproute2 >= 2.2.4
19 Requires:       net-tools >= 1.60
20 Requires:       radvd >= 0.6.2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 TSP is a new initiative launched by Hexago, a private company in
25 Canada involved in IPv6 since 1996, to facilitate a faster deployment
26 of an IPv6 Internet. The Internet is deployed worldwide over IPv4 so
27 this project's goal is large scale deployment of IPv6 by using
28 configured tunnels.
29
30 Configured tunneling is a transition method standardized by IETF to
31 use IPv6 in coexistence with IPv4 by encapsulating IPv6 packets over
32 IPv4. Any host already connected to Internet with IPv4 which has an
33 IPv6 stack can establish a link to the Internet IPv6.
34
35 Freenet6, developed by Viagenie in 1999/2000, was the first public
36 tunnel server service and one of the most used in the world to
37 automatically delegate one single IPv6 address to any host already
38 connected to an IPv4 network over configured tunnel simply by filling
39 a web form and running a script. TSP represents another very important
40 step to accelerate the large scale deployment of IPv6 to everyone on
41 the net.
42
43 Instead of a web interface to request configured tunnels and IPv6
44 addresses, TSP is a new model based on a client/server approach. A
45 protocol is used to request a single IPv6 address to a full IPv6
46 prefix from a client to a tunnel server according to the IPv6 broker
47 model. The protocol could be integrated directly into the operating
48 system to provide a service like DHCP but for requesting IPv6
49 addresses or prefixes over an IPv4 network (Internet).
50
51 %description -l pl
52 TSP to nowa inicjatywa zapocz±tkowana przez Hexago - prywatn± firmê z
53 Kanady zaanga¿owan± w IPv6 od 1996 roku - aby u³atwiæ szybszy rozwój
54 Internetu IPv6. Internet jest rozwiniêty na ca³ym ¶wiecie w oparciu o
55 IPv4, wiêc celem tego projektu jest rozwiniêcie IPv6 na wielk± skalê
56 poprzez u¿ycie skonfigurowanych tuneli.
57
58 Skonfigurowane tunele to metoda przej¶ciowa ustandaryzowana przez IETF
59 w celu u¿ywania IPv6 w koegzystencji z IPv4 poprzez pakowanie pakietów
60 IPv6 w IPv4. Dowolny host pod³±czony do Internetu po IPv4 maj±cy stos
61 IPv6 mo¿e ³±czyæ siê z Internetem IPv6.
62
63 Freenet6 rozwijany przez Viagenie w latach 1999-2000 by³ pierwszym
64 publicznym serwerem tuneli i jednym z najbardziej u¿ywanych na ¶wiecie
65 do automatycznego delegowania pojedynczych adresów IPv6 do dowolnego
66 hosta ju¿ pod³±czonego do sieci IPv4 poprzez skonfigurowany tunel po
67 zwyk³ym wype³nieniu formularza WWW i uruchomieniu skryptu. TSP
68 reprezentuje kolejny bardzo wa¿ny krok do przyspieszenia rozwoju IPv6
69 na szersz± skalê.
70
71 Zamiast interfejsu WWW do ¿±dania skonfigurowanych tuneli i adresów
72 IPv6, TSP jest nowym modelem opartym na komunikacji klient/serwer.
73 Protokó³ jest u¿ywany do ¿±dania od pojedynczego adresu IPv6 do
74 pe³nego prefiksu IPv6 od klienta do serwera tuneli zgodnie z modelem
75 brokera IPv6. Protokó³ mo¿e byæ zintegrowany z systemem operacyjnym,
76 aby udostêpniæ us³ugê typu DHCP, ale do ¿±dania adresów lub prefiksów
77 IPv6 po sieci IPv4 (Internecie).
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 %{__make} all \
86         CC="%{__cc} %{rpmcflags} -I\$(INC) -Wall" \
87         target=linux \
88         installdir=%{_prefix}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/tspc,%{_initrddir}}
93
94 %{__make} install \
95         target=linux \
96         installdir=$RPM_BUILD_ROOT%{_prefix} \
97         install_bin=$RPM_BUILD_ROOT%{_sbindir} \
98         install_man=$RPM_BUILD_ROOT%{_mandir} \
99         install_template=$RPM_BUILD_ROOT%{_datadir}/tspc
100
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/freenet6
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tspc
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README LEGAL CONTRIB.txt UPDATES
110 %attr(755,root,root) %{_sbindir}/tspc
111 %dir %{_sysconfdir}/tspc
112 %{_sysconfdir}/tspc/tspc.conf
113 %attr(754,root,root) %{_initrddir}/*
114 %dir %{_datadir}/tspc
115 %{_datadir}/tspc/checktunnel.sh
116 %{_datadir}/tspc/linux.sh
117 %{_mandir}/man5/*
118 %{_mandir}/man8/*
119
120 %post
121 /sbin/chkconfig --add freenet6
122 if [ -f /var/lock/subsys/freenet6 ]; then
123         /etc/rc.d/init.d/freenet6 restart 1>&2
124 else
125         echo "Run \"/etc/rc.d/init.d/freenet6 start\" to start freenet6 connection"
126 fi
127
128 %preun
129 if [ "$1" = "0" ]; then
130         if [ -f /var/lock/subsys/freenet6 ]; then
131                 /etc/rc.d/init.d/freenet6 stop 1>&2
132         fi
133         /sbin/chkconfig --del freenet6
134 fi
This page took 0.58005 seconds and 3 git commands to generate.