]> git.pld-linux.org Git - packages/freehdl.git/blob - freehdl.spec
- initial, builds/works here, unfinished spec anyway
[packages/freehdl.git] / freehdl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        freehdl
7 Name:           freehdl
8 Version:        0.0.6
9 Release:        0.1
10 License:        GPL
11 # library is under lgpl but its not separated as package so all falls under GPL imo
12 Group:          Applications
13 Source0:        http://%{name}.seul.org/~enaroska/freehdl-%{version}.tar.gz
14 # Source0-md5:  bd168382c72f9fbd392f89ab2c5fddf8
15 URL:            http://freehdl.seul.org/
16 #BuildRequires: -
17 #BuildRequires: autoconf
18 #BuildRequires: automake
19 #BuildRequires: intltool
20 #BuildRequires: libtool
21 #Patch0: %{name}-DESTDIR.patch
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Provides:      group(foo)
28 #Provides:      user(foo)
29 #Obsoletes:     -
30 #Conflicts:     -
31 #BuildArch:     noarch
32 #ExclusiveArch: %{ix86}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36
37 %prep
38 %setup -q
39 #%setup -q -c -T
40 #%setup -q -n %{name}
41 #%setup -q -n %{name}-%{version}.orig -a 1
42 #%patch0 -p1
43
44 # undos the source
45 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
46
47 # remove CVS control files
48 #find -name CVS -print0 | xargs -0 rm -rf
49
50 # you'll need this if you cp -a complete dir in source
51 # cleanup backups after patching
52 #find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
53
54 %build
55 # if ac/am/* rebuilding is necessary, do it in this order and add
56 # appropriate BuildRequires
57 #%%{__intltoolize}
58 #%%{__gettextize}
59 #%%{__libtoolize}
60 #%%{__aclocal}
61 #%%{__autoconf}
62 #%%{__autoheader}
63 #%%{__automake}
64 # if not running libtool or automake, but config.sub is too old:
65 #cp -f /usr/share/automake/config.sub .
66 %configure
67 %{__make}
68
69 #%{__make} \
70 #       CFLAGS="%{rpmcflags}" \
71 #       LDFLAGS="%{rpmldflags}"
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 # create directories if necessary
76 #install -d $RPM_BUILD_ROOT
77 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81 #install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
82 #install AUTHORS COPYING COPYING.LIB README README.AIRE README.gen-nodes README.libraries README.v2cc README.vaul ChangeLog $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS COPYING COPYING.LIB README README.AIRE README.gen-nodes README.libraries README.v2cc README.vaul ChangeLog
93 %attr(755,root,root) %{_libdir}/*.so*
94 %{_libdir}/*.la
95 %{_libdir}/*.a
96 %dir %{_libdir}/freehdl
97 %attr(755,root,root) %{_libdir}/freehdl/*.so*
98 %{_libdir}/freehdl/*.la
99 %{_libdir}/freehdl/*.a
100 %{_datadir}/freehdl
101 %dir %{_includedir}/freehdl
102 %{_includedir}/freehdl/*h
103 %{_includedir}/freehdl/*t
104 %attr(755,root,root) %{_bindir}/*
105 %{_pkgconfigdir}/freehdl.pc
106 #%{_docdir}/%{name}-%{version}
107 %{_mandir}/man[15]/*
This page took 0.092804 seconds and 4 git commands to generate.