]> git.pld-linux.org Git - packages/fpc.git/commitdiff
- updated to 2.6.0 with gdb bits from fixes_2_6 branch
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 18 Nov 2012 18:36:04 +0000 (19:36 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 18 Nov 2012 18:36:04 +0000 (19:36 +0100)
fpc-gdb.patch [new file with mode: 0644]
fpc.spec

diff --git a/fpc-gdb.patch b/fpc-gdb.patch
new file mode 100644 (file)
index 0000000..93f2bf3
--- /dev/null
@@ -0,0 +1,693 @@
+--- fpcbuild-2.6.0/fpcsrc/packages/gdbint/Makefile     2011-12-10 21:19:00.000000000 +0100
++++ fixes_2_6/fpcsrc/packages/gdbint/Makefile  2012-11-18 19:06:54.295222330 +0100
+@@ -2337,10 +2318,12 @@
+ endif
+ ifeq ($(OS_SOURCE),openbsd)
+ override FPCOPT+=-FD$(NEW_BINUTILS_PATH)
++override FPCMAKEOPT+=-FD$(NEW_BINUTILS_PATH)
+ endif
+ ifndef CROSSBOOTSTRAP
+ ifneq ($(BINUTILSPREFIX),)
+ override FPCOPT+=-XP$(BINUTILSPREFIX)
++override FPCMAKEOPT+=-XP$(BINUTILSPREFIX)
+ endif
+ ifneq ($(BINUTILSPREFIX),)
+ override FPCOPT+=-Xr$(RLINKPATH)
+--- fpcbuild-2.6.0/fpcsrc/packages/gdbint/src/gdbint.pp        2012-11-18 19:12:04.578544717 +0100
++++ fixes_2_6/fpcsrc/packages/gdbint/src/gdbint.pp     2012-11-18 19:06:54.121889002 +0100
+@@ -50,7 +50,6 @@
+ {$ifdef GDB_V601}
+   {$info using gdb 6.1.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+   {$undef GDB_HAS_DEPRECATED_CBPH}
+ {$endif def GDB_V601}
+@@ -58,14 +57,12 @@
+ {$ifdef GDB_V602}
+   {$info using gdb 6.2.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+ {$endif def GDB_V602}
+ { 6.3.x }
+ {$ifdef GDB_V603}
+   {$info using gdb 6.3.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+ {$endif def GDB_V603}
+ { 6.4.x }
+@@ -73,7 +70,6 @@
+   {$info using gdb 6.4.x}
+   {$define GDB_V6}
+   {$define GDB_NEEDS_NO_ERROR_INIT}
+-  {$define GDB_HAS_DB_COMMANDS}
+ {$endif def GDB_V604}
+ { 6.5.x }
+@@ -87,7 +83,6 @@
+ {$ifdef GDB_V606}
+   {$info using gdb 6.6.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+   {$define GDB_USES_BP_LOCATION}
+   {$define GDB_NEEDS_NO_ERROR_INIT}
+   {$define GDB_USES_EXPAT_LIB}
+@@ -98,7 +93,6 @@
+ {$ifdef GDB_V607}
+   {$info using gdb 6.7.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+   {$define GDB_USES_BP_LOCATION}
+   {$define GDB_NEEDS_NO_ERROR_INIT}
+   {$define GDB_USES_EXPAT_LIB}
+@@ -109,7 +103,6 @@
+ {$ifdef GDB_V608}
+   {$info using gdb 6.8.x}
+   {$define GDB_V6}
+-  {$define GDB_HAS_DB_COMMANDS}
+   {$define GDB_USES_BP_LOCATION}
+   {$define GDB_BP_LOCATION_HAS_GLOBAL_NEXT}
+   {$define GDB_NEEDS_NO_ERROR_INIT}
+@@ -120,13 +113,44 @@
+   {$define GDB_HAS_BP_NONE}
+ {$endif def GDB_V608}
++{ 7.4.x }
++{$ifdef GDB_V704}
++  {$info using gdb 7.4.x}
++  {$define GDB_V7}
++  {$define GDB_BP_LOCATION_HAS_GDBARCH}
++  {$define GDB_HAS_PROGRAM_SPACE}
++  {$define GDB_NO_UIOUT}
++  {$define GDB_NEEDS_INTERPRETER_SETUP}
++  {$define GDB_NEEDS_SET_INSTREAM}
++  {$define GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
++  {$define GDB_USES_BP_OPS}
++  {$define GDB_BP_TI_HAS_LENGTH}
++  {$define GDB_BP_LOCATION_HAS_REFCOUNT}
++  {$define GDB_BP_LOCATION_HAS_OPS}
++  {$define GDB_UI_FILE_HAS_WRITE_ASYNC}
++  {$ifdef win32}
++      {$define GDB_USES_LIBADVAPI32}
++  {$endif win32}
++{$endif def GDB_V704}
++
+ { 7.3.x }
+ {$ifdef GDB_V703}
+   {$info using gdb 7.3.x}
+   {$define GDB_V7}
+   {$define GDB_BP_LOCATION_HAS_GDBARCH}
+   {$define GDB_HAS_PROGRAM_SPACE}
+-{$endif def GDB_V702}
++  {$define GDB_BP_TI_HAS_LENGTH}
++  {$define GDB_BP_LOCATION_HAS_REFCOUNT}
++  {$ifdef GDB_CVS}
++    {$define GDB_NO_UIOUT}
++    {$define GDB_NEEDS_INTERPRETER_SETUP}
++    {$define GDB_NEEDS_SET_INSTREAM}
++    {$define GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
++    {$define GDB_USES_BP_OPS}
++    {$define GDB_BP_LOCATION_HAS_OPS}
++    {$define GDB_UI_FILE_HAS_WRITE_ASYNC}
++  {$endif GDB_CVS}
++{$endif def GDB_V703}
+ { 7.2.x }
+ {$ifdef GDB_V702}
+@@ -449,8 +472,11 @@
+   {$LINKLIB libintl.a}
+   {$LINKLIB imagehlp}
+   {$endif not USE_MINGW_GDB}
+-  {$LINKLIB kernel32}
++  {$ifdef GDB_USES_LIBADVAPI32}
++    {$LINKLIB advapi32}
++  {$endif GDB_USES_LIBADVAPI32}
+   {$LINKLIB user32}
++  {$LINKLIB kernel32}
+ {$endif win32}
+ {$ifdef win64}
+@@ -589,9 +615,11 @@
+ type
+   pui_file = ^ui_file;
++  pstdio_file = ^stdio_file;
+   ui_file_flush_ftype = procedure(stream : pui_file);cdecl;
+   ui_file_write_ftype = procedure(stream : pui_file;buf : pchar;len : longint);cdecl;
++  ui_file_write_async_save_ftype = procedure(stream : pui_file;buf : pchar;len : longint);cdecl;
+   ui_file_fputs_ftype = procedure(buf : pchar; stream : pui_file);cdecl;
+   ui_file_delete_ftype = procedure(stream : pui_file);cdecl;
+   ui_file_isatty_ftype = function(stream : pui_file) : longbool;cdecl;
+@@ -606,6 +634,9 @@
+       magic : plongint;
+       to_flush  : ui_file_flush_ftype;
+       to_write  : ui_file_write_ftype;
++      {$ifdef GDB_UI_FILE_HAS_WRITE_ASYNC}
++      to_write_async_safe   : ui_file_write_async_save_ftype;
++      {$endif}
+       to_fputs  : ui_file_fputs_ftype;
+       {$ifdef GDB_V6}
+       to_read   : ui_file_read_ftype;
+@@ -617,6 +648,13 @@
+       to_data   : pointer;
+     end;
++  stdio_file = record
++      magic : plongint;
++      _file : P_C_FILE;
++      df : longint;
++      close_p : longint;
++    end;
++
+   { used to delete stdio_ui_file  gdb_stdout and gdb_stderr }
+   procedure ui_file_delete(stream : pui_file);cdecl;external;
+@@ -775,10 +813,16 @@
+ {$ifdef GDB_V6}
+ type
+   ui_out = pointer;
++{$ifndef GDB_NO_UIOUT}
+ var
+   uiout : ui_out;cvar;external;
++{$else  GDB_NO_UIOUT}
++var
++  cli_uiout : ui_out;cvar;external;
++  current_uiout : ui_out;cvar;external;
++{$endif GDB_NO_UIOUT}
+ function cli_out_new (stream : pui_file):ui_out;cdecl;external;
+-{$endif}
++{$endif GDB_V6}
+ {$ifdef go32v2}
+   { needed to be sure %fs contains the DOS memory selector
+@@ -816,8 +860,11 @@
+   jmp_buf = dpmi_jmp_buf;
+   pjmp_buf = pdpmi_jmp_buf;
++
+   function setjmp(var rec : jmp_buf) : longint;cdecl;external;
++  function malloc(size : longint) : pointer;cdecl;external;
++
+   procedure longjmp(var rec : jmp_buf;return_value : longint);cdecl;external;
+   procedure reload_fs;assembler;
+@@ -870,6 +917,13 @@
+      pCORE_ADDR = ^CORE_ADDR;
+      pblock = ^block;
++     tframe_id = record
++       stack_addr, code_addr, special_addr : CORE_ADDR;
++       addr_p_flags : byte;{ for three 1 bit flags
++       stack_addr_p, code_addr_p, special_addr_p : cint : 1; }
++       inline_depth : longint;
++     end;
++
+      tlanguage = (language_unknown,language_auto,language_c,
+        language_cplus,language_java,language_chill,
+        language_fortran,language_m2,language_asm,
+@@ -898,9 +952,18 @@
+      target_hw_bp_type = (hw_write, hw_read, hw_access, hw_execute);
++     { pointer to structures that we don't need }
++     pbp_ops = pointer;
++     pbp_location_ops = pointer;
++     pprogram_space = pointer;
++     pgdbarch = pointer;
++
+ {$PACKRECORDS 4}
+      pbreakpoint = ^breakpoint;
+      breakpoint = record
++{$ifdef GDB_USES_BP_OPS}
++          ops : pbp_ops;
++{$endif GDB_USES_BP_OPS}
+           next : pbreakpoint;
+           typ : bptype;
+           enable : tenable;
+@@ -911,19 +974,36 @@
+ {$else not GDB_USES_BP_LOCATION}
+           address : CORE_ADDR;
+ {$endif not GDB_USES_BP_LOCATION}
++{$ifndef GDB_USES_BP_OPS}
+           line_number : longint;
+           source_file : pchar;
++{$endif not GDB_USES_BP_OPS}
+           silent : byte;
++{$ifdef GDB_USES_BP_OPS}
++          display_canonical: byte;
++{$endif GDB_USES_BP_OPS}
++
+           ignore_count : longint;
+ {$ifndef GDB_USES_BP_LOCATION}
+           shadow_contents : array[0..15] of char;
+           inserted : char;
+           duplicate : char;
+ {$endif not GDB_USES_BP_LOCATION}
++
+           commands : pointer; {^command_line}
++{$ifdef GDB_USES_BP_OPS}
++          frame_id : tframe_id;
++          pspace : pprogram_space;
++{$else not GDB_USES_BP_OPS}
+           frame : CORE_ADDR;
+           cond : pointer; {^expression}
+-          addr_string : ^char;
++{$endif GDB_USES_BP_OPS}
++          addr_string : pchar;
++{$ifdef GDB_USES_BP_OPS}
++          filter : pchar;
++          addr_string_range_end : pchar;
++          gdbarch : pgdbarch;
++{$endif GDB_USES_BP_OPS}
+           language : tlanguage;
+           input_radix : longint;
+           cond_string : ^char;
+@@ -942,6 +1022,9 @@
+      bp_target_info = record
+           placed_address_space : pointer;{paddress_space;}
+           placed_address : CORE_ADDR;
++{$ifdef GDB_BP_TI_HAS_LENGTH}
++          length : longint;
++{$endif GDB_BP_TI_HAS_LENGTH}
+           shadow_contents : array[0..15] of char;
+           shadow_len : longint;
+           placed_size : longint;
+@@ -949,9 +1032,17 @@
+      bp_location = record
+          next : pbp_location;
++{$ifdef GDB_BP_LOCATION_HAS_OPS}
++         ops : pbp_location_ops;
++{$endif GDB_BP_LOCATION_HAS_OPS}
++
++{$ifdef GDB_BP_LOCATION_HAS_REFCOUNT}
++        refc : longint;
++{$else}
+ {$ifdef GDB_BP_LOCATION_HAS_GLOBAL_NEXT}
+          global_next : pbp_location;
+ {$endif GDB_BP_LOCATION_HAS_GLOBAL_NEXT}
++{$endif}
+          loc_type : bp_loc_type;
+          owner : pbreakpoint;
+ {$ifdef GDB_BP_LOCATION_HAS_GLOBAL_NEXT}
+@@ -962,10 +1053,10 @@
+          inserted : byte;
+          duplicate : byte;
+ {$ifdef GDB_BP_LOCATION_HAS_GDBARCH}
+-         gdbarch : pointer;{pgdbarch;}
++         gdbarch : pgdbarch;
+ {$endif GDB_BP_LOCATION_HAS_GDBARCH}
+ {$ifdef GDB_HAS_PROGRAM_SPACE}
+-         pspace : pointer;{pprogram_space;}
++         pspace : pprogram_space;
+ {$endif GDB_HAS_PROGRAM_SPACE}
+          address : CORE_ADDR;
+ {$ifdef GDB_BP_LOCATION_HAS_GLOBAL_NEXT}
+@@ -980,6 +1071,11 @@
+          target_info : bp_target_info;
+          overlay_target_info : bp_target_info;
+          events_till_retirement : longint;
++{$ifdef GDB_USES_BP_OPS}
++        { line and source file are in location }
++          line_number : longint;
++          source_file : pchar;
++{$endif not GDB_USES_BP_OPS}
+       end;
+      tfreecode=(free_nothing,free_contents,free_linetable);
+@@ -1489,7 +1585,9 @@
+   {$endif ndef GDB_HAS_OBSERVER_NOTIFY_BREAKPOINT_CREATED}
+   current_target : target_ops;cvar;external;
+   stop_pc      : CORE_ADDR;cvar;external;
+-  { Only used from GDB 5.01 but doesn't hurst otherwise }
++  { Only used from GDB 5.0 but doesn't hurst otherwise }
++  { This global variable is declared in defs.h as external
++    and instanciated in main.c since version 5.0. }
+   interpreter_p : pchar;cvar;public;
+ { we need also to declare some vars }
+@@ -1503,13 +1601,22 @@
+ { Whether xdb commands will be handled }
+ {$ifdef GDB_HAS_DB_COMMANDS}
++  { These two global variables are declared in defs.h
++    since version 4.18 }
+   xdb_commands : longint;cvar;public;
+ { Whether dbx commands will be handled }
+   dbx_commands : longint;cvar;public;
+ {$endif GDB_HAS_DB_COMMANDS}
++{$ifdef GDB_NEEDS_SET_INSTREAM}
++var
++  instream : P_C_FILE;cvar;external;
++  function gdb_fopen (filename : pchar; mode : pchar) : pui_file;cdecl;external;
++{$endif GDB_NEEDS_SET_INSTREAM}
+ var
++  { The four following variables are defined in defs.h 
++    and instanciated in main.c since version 5.0 }
+   gdb_stdout : pui_file;cvar;public;
+   gdb_stderr : pui_file;cvar;public;
+   gdb_stdlog : pui_file;cvar;public;
+@@ -1517,6 +1624,9 @@
+   event_loop_p : longint;cvar;public;
+ {$ifdef GDB_V6}
+ (* target IO streams *)
++  { The three following variables are declared in defs.h
++    and instanciated in main.c since version 6.0 }
++  gdb_stdin : pui_file;cvar;public;
+   gdb_stdtargin : pui_file;cvar;public;
+   gdb_stdtargerr : pui_file;cvar;public;
+ {$endif}
+@@ -1524,7 +1634,10 @@
+ { used for gdb_stdout and gdb_stderr }
+ function  xmalloc(size : longint) : pointer;cdecl;external;
+ { used for QueryHook }
+-function xstrvprintf(msg : pchar) : pchar; varargs; cdecl; external;
++{ xvasprintf is present at least from GDB 5.3
++  while xstrvprintf only appears in version 6.2,
++  so only use xvasprintf function }
++function xvasprintf(ret : ppchar; msg : pchar) : pchar; varargs; cdecl; external;
+ procedure xfree(p : pointer); cdecl; external;
+ function  find_pc_line(i:CORE_ADDR;l:longint):symtab_and_line;cdecl;external;
+ function  find_pc_function(i:CORE_ADDR):psymbol;cdecl;external;
+@@ -2407,11 +2520,15 @@
+     QueryHook:=0
+   else
+     begin
+-      if curr_gdb^.reset_command and (pos('Kill',question)>0) then
++      if curr_gdb^.reset_command and ((pos('Kill',question)>0) or
++         (pos('Discard symbol table',question)>0)) then
+         QueryHook:=1
+       else if pos('%',question)>0 then
+         begin
+-          local:=xstrvprintf(question,arg);
++          xvasprintf(@local,question,arg);
++          { xvasprintf can failed, in that case local is set to nil }
++          if not assigned(local) then
++            local:=question;
+           QueryHook:=curr_gdb^.Query(local, nil);
+           xfree(local);
+         end
+@@ -2452,7 +2569,12 @@
+      last_breakpoint_number:=b.number;
+      { function breakpoints have zero as file and as line !!
+        but they are valid !! }
++{$ifndef GDB_USES_BP_OPS}
+      invalid_breakpoint_line:=(b.line_number<>sym.line) and (b.line_number<>0);
++{$else GDB_USES_BP_OPS}
++     invalid_breakpoint_line:=(b.loc=nil) or
++       ((b.loc^.line_number<>sym.line) and (b.loc^.line_number<>0));
++{$endif GDB_USES_BP_OPS}
+ {$ifdef GDB_USES_BP_LOCATION}
+      if assigned (b.loc) then
+        last_breakpoint_address:=b.loc^.address
+@@ -2472,7 +2594,11 @@
+ {$ifdef GDB_HAS_OBSERVER_NOTIFY_BREAKPOINT_CREATED}
+ type
++{$ifdef GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
++  breakpoint_created_function_type = procedure (bpp : pbreakpoint); cdecl;
++{$else not GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
+   breakpoint_created_function_type = procedure (bpnum : longint); cdecl;
++{$endif not GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
+   pobserver = pointer;
+ var
+   breakpoint_created_observer : pobserver = nil;
+@@ -2480,8 +2606,14 @@
+ function observer_attach_breakpoint_created(create_func : breakpoint_created_function_type) : pobserver;cdecl;external;
+ procedure observer_detach_breakpoint_created(pob : pobserver);cdecl;external;
+-var breakpoint_chain : pbreakpoint ;cvar;external;
++{$ifdef GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
++procedure notify_breakpoint_created(bpp : pbreakpoint); cdecl;
++begin
++  CreateBreakpointHook(bpp^);
++end;
++{$else not GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
++var breakpoint_chain : pbreakpoint ;cvar;external;
+ procedure notify_breakpoint_created(bpnum : longint);cdecl;
+ var
+@@ -2499,8 +2631,16 @@
+         pb:=pb^.next;
+     end;
+ end;
++{$endif not GDB_NOTIFY_BREAKPOINT_ARG_IS_BREAKPOINT_PTR}
+ {$endif def GDB_HAS_OBSERVER_NOTIFY_BREAKPOINT_CREATED}
++{ Avoid loading of main.o object by providing a
++  stripped down version of relocate_gdb_directory function }
++function relocate_gdb_directory(path : pchar) : pchar; cdecl; public;
++begin
++  relocate_gdb_directory:=path;
++end;
++
+ {*****************************************************************************
+                                  tgdbinterface
+ *****************************************************************************}
+@@ -2529,7 +2669,7 @@
+   gdb_command('set print object on');
+   gdb_command('set print null-stop');
+   {$ifdef USE_MINGW_GDB}  // maybe this also should be done for newer cygwin gdbs.
+-  gdb_command('set confirm off');
++  //gdb_command('set confirm off');
+   {$endif}
+ end;
+@@ -2610,9 +2750,9 @@
+ var
+    top_level_val : longint;
+-function catch_errors(func : pointer; command : pchar; from_tty,mask : longint) : longint;cdecl;external;
++function catch_command_errors(func : pointer; command : pchar; from_tty,mask : longint) : longint;cdecl;external;
+-function gdbint_execute_command(command : pchar; from_tty,mask : longint) : longint;cdecl;
++function gdbint_execute_command(command : pchar; from_tty : longint) : longint;cdecl;
+ begin
+   gdbint_execute_command:=1;
+   execute_command(command,from_tty);
+@@ -2659,6 +2799,8 @@
+ begin
+ {$ifdef cpui386}
+   MaskAllFPUExceptions := control or MaskAllExceptions;
++{$else}
++  MaskAllFPUExceptions:=0;
+ {$endif}
+ end;
+@@ -2717,7 +2859,8 @@
+    begin
+      quit_return:=error_return;
+      mask:=longint($ffffffff);
+-     catch_errors(@gdbint_execute_command,@command,0,mask);
++     catch_command_errors(@gdbint_execute_command,@command,
++       1,mask);
+ {$ifdef go32v2}
+      reload_fs;
+ {$endif go32v2}
+@@ -2974,11 +3117,43 @@
+   c_environ : ppchar;external name '_environ';
+   c_argc : longint;external name '___crt0_argc';
+   c_argv : ppchar;external name '___crt0_argv';
++
++  procedure ReallocateEnvironUsingCMalloc;
++
++  var
++    neededsize , count : longint;
++    penv : pchar;
++    newenv : ppchar;
++  begin
++    if not assigned(c_environ) then
++      neededsize:=0
++    else
++      begin
++        count:=0;
++        penv:=c_environ^;
++        while assigned(penv) do
++          begin
++            inc(count);
++            inc(penv,sizeof(pchar));
++          end;
++        neededsize:=count*sizeof(pchar);
++      end;
++    newenv:=malloc(neededsize);
++    system.move(c_environ,newenv,neededsize);
++    c_environ:=newenv;
++  end;
++
+ {$endif def go32v2}
+ var
+   current_directory : pchar; cvar; external;
+   gdb_dirbuf : array[0..0] of char; cvar; external;
+   CurrentDir : AnsiString;
++{$ifdef GDB_NEEDS_INTERPRETER_SETUP}
++  type
++     interpreter_struct_p = pointer; { to opaque type }
++  function interp_lookup (name : pchar) : interpreter_struct_p;cdecl; external;
++  function interp_set (interp : interpreter_struct_p) : longbool;cdecl; external;
++{$endif GDB_NEEDS_INTERPRETER_SETUP}
+ const
+   DIRBUF_SIZE = 1024;
+@@ -2987,13 +3162,28 @@
+ var
+   OldSigInt : SignalHandler;
+ {$endif supportexceptions}
++{$ifdef GDB_NEEDS_SET_INSTREAM}
++var
++  dummy_file : pui_file;
++{$endif GDB_NEEDS_SET_INSTREAM}
++
+ {$ifdef GDB_INIT_HAS_ARGV0}
+ var
+   argv0 : pchar;
+ {$endif not GDB_INIT_HAS_ARGV0}
++{$ifdef GDB_NEEDS_INTERPRETER_SETUP}
++var
++  interp : interpreter_struct_p;
++{$endif GDB_NEEDS_INTERPRETER_SETUP}
++var
++ save_gdb_stdin,
++ save_gdb_stdout,
++ save_gdb_stderr : pui_file;
+ begin
+ {$ifdef go32v2}
+-  c_environ:=system.envp;
++  { c_environ:=system.envp; }
++  { DJGPP libC presupposes the c_enivron was malloc'ated }
++  ReallocateEnvironUsingCMalloc;
+   c_argc:=system.argc;
+   c_argv:=system.argv;
+ {$endif def go32v2}
+@@ -3013,8 +3203,25 @@
+     ui_file_delete(gdb_stderr);
+   if assigned(gdb_stdout) then
+     ui_file_delete(gdb_stdout);
++{$ifdef GDB_NEEDS_SET_INSTREAM}
++  if assigned(gdb_stdin) then
++    ui_file_delete(gdb_stdin);
++  gdb_stdin:=mem_fileopen;
++  save_gdb_stdin:=gdb_stdin;
++  dummy_file :=gdb_fopen('dummy.$$$','a');
++  {in captured_main code, this is simply
++   instream:=stdin; but stdin is a highly system dependent macro
++   so that we try to avoid it here }
++  if assigned(dummy_file) then
++    instream:=pstdio_file(dummy_file^.to_data)^._file
++  else
++    instream:=nil;
++{$endif GDB_NEEDS_SET_INSTREAM}
++
+   gdb_stderr:=mem_fileopen;
+   gdb_stdout:=mem_fileopen;
++  save_gdb_stderr:=gdb_stderr;
++  save_gdb_stdout:=gdb_stdout;
+   gdb_stdlog:=gdb_stderr;
+   gdb_stdtarg:=gdb_stderr;
+   set_ui_file_write(gdb_stdout,@gdbint_ui_file_write);
+@@ -3023,7 +3230,9 @@
+   error_init;
+ {$endif GDB_NEEDS_NO_ERROR_INIT}
+ {$ifdef GDB_V6}
+-//  gdb_stdtargin := gdb_stdin;
++{$ifdef GDB_NEEDS_SET_INSTREAM}
++  gdb_stdtargin := gdb_stdin;
++{$endif GDB_NEEDS_SET_INSTREAM}
+   gdb_stdtargerr := gdb_stderr;
+ {$endif}
+   GetDir(0, CurrentDir);
+@@ -3035,8 +3244,10 @@
+   next_exit:=exitproc;
+   exitproc:=@DoneLibGDB;
+ {$ifdef GDB_V6}
++{$ifndef GDB_NO_UIOUT}
+   uiout := cli_out_new (gdb_stdout);
+-{$endif}
++{$endif not GDB_NO_UIOUT}
++{$endif GDB_V6}
+ {$ifdef GDB_INIT_HAS_ARGV0}
+   getmem(argv0,length(paramstr(0))+1);
+   strpcopy(argv0,paramstr(0));
+@@ -3045,6 +3256,31 @@
+ {$else not GDB_INIT_HAS_ARGV0}
+   gdb_init;
+ {$endif not GDB_INIT_HAS_ARGV0}
++{$ifdef GDB_NEEDS_INTERPRETER_SETUP}
++  { interpreter can only be set after all files are
++    initialized, which is done in gdb_init function. }
++  interp := interp_lookup ('console');
++  interp_set (interp);
++
++  { We need to re-set gdb_stdXX ui_files }
++  if assigned(gdb_stderr) then
++    ui_file_delete(gdb_stderr);
++  if assigned(gdb_stdout) then
++    ui_file_delete(gdb_stdout);
++  if assigned(gdb_stdin) then
++    ui_file_delete(gdb_stdin);
++  gdb_stdin:=save_gdb_stdin;
++  gdb_stderr:=save_gdb_stderr;
++  gdb_stdout:=save_gdb_stdout;
++  gdb_stdlog:=gdb_stderr;
++  gdb_stdtarg:=gdb_stderr;
++  set_ui_file_write(gdb_stdout,@gdbint_ui_file_write);
++  set_ui_file_write(gdb_stderr,@gdbint_ui_file_write);
++{$ifdef GDB_NO_UIOUT}
++  cli_uiout := cli_out_new (gdb_stdout);
++  current_uiout:=cli_uiout;
++{$endif GDB_NO_UIOUT}
++{$endif GDB_NEEDS_INTERPRETER_SETUP}
+ {$ifdef supportexceptions}
+   {$ifdef unix}
+     fpsignal(SIGINT,OldSigInt);
+@@ -3070,14 +3306,34 @@
+ end;
+ {$ifdef GDB_HAS_SYSROOT}
+-var gdb_sysroot  : pchar; cvar;public;
++  { Here we declare as cvar;public; a bunch of global
++    variables that are defined in main.c source.
++    We must not load main.o otherwise, we will get
++    into multiply defined symbols troubles. }
++var 
++    gdb_sysrootc : char;
++    { used locally only to provide a pchar pointing to '\0' }
++    gdb_sysroot  : pchar; cvar;public; 
++    { gdb_sysroot global variable is declared in defs.h and
++      instanciated in main.c since version 6.0 }
+     gdb_datadir  : pchar; cvar;public;
++    { gdb_datadir global variable is declared in defs.h and
++      instanciated in main.c since version 7.0 }
+     python_libdir : pchar;cvar;public;
+-    gdb_sysrootc : char;
++    { python_libdir global variable is declared in defs.h and instanciated
++      in main.c since version 7.2 }
+     return_child_result : longbool;cvar;public;
++    { return_chlid_result global variable is declared in main.h and
++      instanciated in main.c since version 6.4 }
+     return_child_result_value : longint;cvar;public;
++    { return_child_result_value global variable is declared in main.h and
++      instanciated in main.c since version 6.4 with a startup value of -1 }
+     batch_silent : longbool;cvar;public;
++    { batch_silent global variable is declared in main.h since 7.0, but
++      instanciated in main.c since version 6.4 }
+     batch_flag : longbool;cvar;public;
++    { batch_flag global variable is declared in main.h and
++      instanciated in main.c since version 7.2 }
+ {$endif}
+ {$ifdef GDB_HAS_DEBUG_FILE_DIRECTORY}
+ var
+@@ -3087,6 +3343,7 @@
+ begin
+ {$ifdef GDB_HAS_SYSROOT}
+   gdb_sysrootc := #0;
++  return_child_result_value := -1;
+   gdb_sysroot := @gdb_sysrootc;
+   gdb_datadir := @gdb_sysrootc;
+   python_libdir := @gdb_sysrootc;
index f4a1762b07681e882c1c7b7b31f6d66271a77aa9..e55f631f73b3ec3f872c2b5166687613e21daf9b 100644 (file)
--- a/fpc.spec
+++ b/fpc.spec
@@ -8,20 +8,21 @@ Summary(pl.UTF-8):    32 bitowy kompilator dla procesorów i386 i m68k
 Summary(ru.UTF-8):     Свободный компилятор Pascal
 Summary(uk.UTF-8):     Вільний компілятор Pascal
 Name:          fpc
-Version:       2.4.4
-Release:       3
+Version:       2.6.0
+Release:       0.1
 License:       GPL
 Group:         Development/Languages
 Source0:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/source/%{name}build-%{version}.tar.gz
-# Source0-md5: d069dfd3412bd0d26dcd1b81ac998305
+# Source0-md5: 17375e665a4e1311f85812fe2754f609
 Source1:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/i386-linux/%{name}-%{version}.i386-linux.tar
-# Source1-md5: e761c4866ac4c8fcbe09f657f315ec32
+# Source1-md5: 42b8fcaba867f515446a84aa0430db91
 Source2:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/x86_64-linux/%{name}-%{version}.x86_64-linux.tar
-# Source2-md5: 058e6cd765026748a2bd24c86f1ecf18
+# Source2-md5: 631d93ca49778537cd84fa3a2878883c
 Source3:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/powerpc-linux/%{name}-%{version}.powerpc-linux.tar
-# Source3-md5: cea93e5da48c45da3147236cba75dc76
+# Source3-md5: e08ac5d45747d8a12589b55c7cd58ded
 Patch0:                %{name}-skip-dev-dot.patch
 Patch1:                %{name}-link.patch
+Patch2:                %{name}-gdb.patch
 URL:           http://www.freepascal.org/
 BuildRequires: binutils-static >= 3:2.17.50
 BuildRequires: gpm-devel
@@ -112,28 +113,34 @@ Dokumentacja do fpc w formacie PDF.
 %setup -q -n %{name}build-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %ifarch %{ix86}
 tar xf %{SOURCE1}
 %define _bver %{version}
 %define _bname 386
+%define _barch i386
 %endif
 %ifarch %{x8664}
 tar xf %{SOURCE2}
 %define _bver %{version}
 %define _bname x64
+%define _barch x86_64
 %endif
 %ifarch ppc
 tar xf %{SOURCE3}
 %define _bver %{version}
 %define _bname ppc
+%define _barch powepc
 %endif
 
+cd %{name}-%{version}.%{_barch}-linux
 tar xf binary.*-linux.tar
+cd ..
 
 mkdir bin
 cd bin
-for i in ../*.tar.gz ; do
+for i in ../%{name}-%{version}.%{_barch}-linux/*.tar.gz ; do
        tar xzf $i
 done
 ln -sf `pwd`/lib/%{name}/%{_bver}/ppc* bin
This page took 0.081909 seconds and 4 git commands to generate.