]> git.pld-linux.org Git - packages/fpc.git/blobdiff - fpc.spec
- BR gdb-lib with libdecnumber.a
[packages/fpc.git] / fpc.spec
index 420085253a25843f468537a8d369724d16aebde8..03530ddc9ad99c0700f99702cc6045eea1de9fbe 100644 (file)
--- a/fpc.spec
+++ b/fpc.spec
@@ -1,10 +1,6 @@
-# TODO:
-# - check why it builds all static..
-# - doesn't build on ppc :/ hgw why - drop this ?
-# - repair ide build
 #
 # Conditional build:
-%bcond_with    ide                     # build with ide
+%bcond_without ide                     # build with ide
 %bcond_without doc                     # build without doc
 
 Summary:       32-bit compiler for the i386 and m68k processors
@@ -12,32 +8,38 @@ Summary(pl.UTF-8):   32 bitowy kompilator dla procesorów i386 i m68k
 Summary(ru.UTF-8):     Свободный компилятор Pascal
 Summary(uk.UTF-8):     Вільний компілятор Pascal
 Name:          fpc
-Version:       2.2.2
+Version:       2.4.4
 Release:       0.1
 License:       GPL
 Group:         Development/Languages
-Source0:       ftp://ftp.freepascal.org/fpc/dist/source-%{version}/%{name}build-%{version}.tar.gz
-# Source0-md5: ec3d463ec9859da4122e9edfa2ab992d
-Source1:       ftp://ftp.freepascal.org/fpc/dist/i386-linux-%{version}/%{name}-%{version}.i386-linux.tar
-# Source1-md5: ee7ddbf3ad50f6c6f237439e3ecd83d6
-Source2:       ftp://ftp.freepascal.org/fpc/dist/x86_64-linux-%{version}/%{name}-%{version}.x86_64-linux.tar
-# Source2-md5: 9671bb9f89fd64fd8db4de6c76393c62
-Source3:       ftp://ftp.freepascal.org/fpc/dist/powerpc-linux-%{version}/%{name}-%{version}.powerpc-linux.tar
-# Source3-md5: e83013af5e6fd8272c6d26b41234f288
+Source0:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/source/%{name}build-%{version}.tar.gz
+# Source0-md5: d069dfd3412bd0d26dcd1b81ac998305
+Source1:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/i386-linux/%{name}-%{version}.i386-linux.tar
+# Source1-md5: e761c4866ac4c8fcbe09f657f315ec32
+Source2:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/x86_64-linux/%{name}-%{version}.x86_64-linux.tar
+# Source2-md5: 058e6cd765026748a2bd24c86f1ecf18
+Source3:       ftp://ftp.freepascal.org/pub/fpc/dist/%{version}/powerpc-linux/%{name}-%{version}.powerpc-linux.tar
+# Source3-md5: cea93e5da48c45da3147236cba75dc76
 Patch0:                %{name}-skip-dev-dot.patch
-Patch1:                %{name}-makedocs.patch
-Patch2:                %{name}-avoid-RE.patch
+Patch1:                %{name}-link.patch
 URL:           http://www.freepascal.org/
 BuildRequires: binutils-static >= 3:2.17.50
-BuildRequires: gdb-lib
 BuildRequires: gpm-devel
 BuildRequires: ncurses-devel
-%{?with_ide:BuildRequires:     readline-static}
 BuildRequires: rpmbuild(macros) >= 1.213
-%{?with_doc:BuildRequires:     tetex-fonts-jknappen}
-%{?with_doc:BuildRequires:     tetex-format-pdflatex}
-%{?with_doc:BuildRequires:     tetex-makeindex}
-%{?with_doc:BuildRequires:     tetex-metafont}
+%if %{with ide}
+BuildRequires: gdb-lib >= 7.2-7
+BuildRequires: python-static
+BuildRequires: readline-static
+BuildRequires: zlib-static
+%endif
+%if %{with doc}
+BuildRequires: tetex-fonts-jknappen
+BuildRequires: tetex-format-pdflatex
+BuildRequires: tetex-makeindex
+BuildRequires: tetex-metafont
+BuildRequires: texlive-xetex
+%endif
 Requires:      binutils
 Provides:      fpc-bootstrap
 ExclusiveArch: %{ix86} %{x8664} ppc
@@ -98,7 +100,7 @@ Przykładowe programy do kompilatora Free Pascal.
 Summary:       Free Pascal Compiler documentation
 Summary(pl.UTF-8):     Dokumentacja do kompilatora Free Pascal
 Group:         Documentation
-Requires:      %{name} = %{version}-%{release}
+# doesn't require base
 
 %description doc
 Documentation for fpc in PDF format.
@@ -110,7 +112,6 @@ Dokumentacja do fpc w formacie PDF.
 %setup -q -n %{name}build-%{version}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %ifarch %{ix86}
 tar xf %{SOURCE1}
@@ -136,12 +137,18 @@ for i in ../*.tar.gz ; do
        tar xzf $i
 done
 ln -sf `pwd`/lib/%{name}/%{_bver}/ppc* bin
+cd ..
 
-%build
 # save for fpc-src
 install -d fpc-src
 cp -af fpcsrc/* fpc-src
 
+%build
+# use ld.bfd
+[ -d our-ld ] || install -d our-ld
+ln -sf %{_bindir}/ld.bfd our-ld/ld
+export PATH=$(pwd)/our-ld:$PATH
+
 PP=`pwd`/bin/lib/%{name}/%{_bver}/ppc%{_bname}
 NEWPP=`pwd`/fpcsrc/compiler/ppc%{_bname}
 NEWFPDOC=`pwd`/fpcsrc/utils/fpdoc/fpdoc
@@ -182,30 +189,11 @@ esac
        %{?with_ide: ide_clean installer_clean} \
        rtl_all \
        packages_all \
-       utils_all %{?with_ide:installer_all}
-
-#      %{?with_ide:IDE=YES} \
-%if %{with ide}
-%{__make} -C fpcsrc/ide OPT="$OPTF -Xs -n" \
-       RELEASE="1" \
-       BASEINSTALLDIR=%{_libdir}/%{name}/%{version} \
-       BININSTALLDIR=%{_bindir} \
-       GDBLIBDIR=%{_libdir} \
-       PP="$NEWPP" \
-       FPC="$NEWPP" \
-       FPDOC=$NEWFPDOC \
-       DATA2INC=`pwd`/utils/data2inc \
-       LINKSMART=YES \
-       clean \
-       default \
-       gdb
-%endif
-#      %{?with_ide:installer_clean} \
-#      %{?with_ide:installer_all}
+       utils_all %{?with_ide:ide_all installer_all}
 
 %if %{with doc}
 export save_size=10000
-%{__make} -C fpcdocs \
+%{__make} -j1 -C fpcdocs \
        FPDOC=$NEWFPDOC \
        FPC="$NEWPP" \
        pdf
@@ -219,7 +207,7 @@ cp -af fpc-src/* $RPM_BUILD_ROOT%{_datadir}/fpcsrc
 
 NEWPP=`pwd`/fpcsrc/compiler/ppc%{_bname}
 FPCMAKE=`pwd`/fpcsrc/utils/fpcm/fpcmake
-%{__make} -C fpcsrc \
+%{__make} -j1 -C fpcsrc \
        compiler_distinstall \
        rtl_distinstall \
        packages_distinstall \
@@ -238,7 +226,7 @@ FPCMAKE=`pwd`/fpcsrc/utils/fpcm/fpcmake
        INSTALL_MANDIR=$RPM_BUILD_ROOT%{_mandir} \
        CODPATH=$RPM_BUILD_ROOT%{_libdir}/%{name}/lexyacc
 
-%{__make} -C install/man installman \
+%{__make} -j1 -C install/man installman \
        INSTALL_MANDIR=$RPM_BUILD_ROOT%{_mandir}
 
 ln -sf %{_libdir}/%{name}/%{version}/ppc%{_bname} $RPM_BUILD_ROOT%{_bindir}
This page took 0.071317 seconds and 4 git commands to generate.