]> git.pld-linux.org Git - packages/fox16.git/blob - fox16.spec
bfdc5e1c034cfff156c38a8625626abe7d0ae6b7
[packages/fox16.git] / fox16.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # CUPS support
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        The FOX 1.6 C++ GUI Toolkit
7 Summary(pl.UTF-8):      FOX 1.6 - toolkit graficzny w C++
8 Name:           fox16
9 Version:        1.6.44
10 Release:        4
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://fox-toolkit.org/ftp/fox-%{version}.tar.gz
14 # Source0-md5:  f3c66bbe87b65de3a3fb480278bcfffd
15 Patch0:         %{name}-opt.patch
16 Patch1:         %{name}-link.patch
17 Patch2:         %{name}-Makefile.patch
18 URL:            http://www.fox-toolkit.org/
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  autoconf >= 2.59-9
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel >= 1.0.2
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  doxygen
25 BuildRequires:  graphviz
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.2.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel >= 3.5.7
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  xorg-lib-libXcursor-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXft-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  zlib-devel >= 1.1.4
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 FOX is a C++-Based Library for Graphical User Interface Development
40 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
41 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
42 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
43 graphics. Subclassing of basic FOX widgets allows for easy extension
44 beyond the built-in widgets by application writers.
45
46 This package contains FOX 1.6.x series.
47
48 %description -l pl.UTF-8
49 FOX jest biblioteką bazującą na C++ do projektowania graficznych
50 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
51 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
52 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
53 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
54 rozszerzanie.
55
56 Ten pakiet zawiera FOX z serii 1.6.x.
57
58 %package progs
59 Summary:        FOX 1.6 example applications
60 Summary(pl.UTF-8):      Przykłady aplikacji wykorzystujących FOX 1.6
61 Group:          X11/Applications
62 Requires:       %{name} = %{version}-%{release}
63 Obsoletes:      fox-example-apps
64 Obsoletes:      fox-progs < 1.7
65 Conflicts:      fox-progs >= 1.7
66
67 %description progs
68 Editor and file browser, written with FOX 1.6.
69
70 %description progs -l pl.UTF-8
71 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX 1.6.
72
73 %package devel
74 Summary:        Header files for FOX 1.6 library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX 1.6
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       OpenGL-GLU-devel
79 Requires:       bzip2-devel >= 1.0.2
80 Requires:       libjpeg-devel >= 6b
81 Requires:       libpng-devel >= 1.2.5
82 Requires:       libstdc++-devel
83 Requires:       libtiff-devel >= 3.5.7
84 Requires:       xorg-lib-libXcursor-devel
85 Requires:       xorg-lib-libXext-devel
86 Requires:       xorg-lib-libXft-devel
87 Requires:       xorg-lib-libXrandr-devel
88 Requires:       zlib-devel >= 1.1.4
89
90 %description devel
91 Header files for FOX 1.6 library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki FOX 1.6.
95
96 %package static
97 Summary:        FOX 1.6 static libraries
98 Summary(pl.UTF-8):      Biblioteki statyczne FOX 1.6
99 Group:          X11/Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 FOX 1.6 static libraries.
104
105 %description static -l pl.UTF-8
106 Biblioteki statyczne FOX 1.6.
107
108 %package doc
109 Summary:        Development documentation for FOX 1.6 library
110 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX 1.6
111 Group:          X11/Development/Libraries
112
113 %description doc
114 Development documentation for FOX 1.6 library.
115
116 %description doc -l pl.UTF-8
117 Dokumentacja programisty do biblioteki FOX 1.6.
118
119 %package examples
120 Summary:        FOX 1.6 - example programs
121 Summary(pl.UTF-8):      FOX 1.6 - programy przykładowe
122 Group:          X11/Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124
125 %description examples
126 FOX 1.6 - example programs.
127
128 %description examples -l pl.UTF-8
129 FOX 1.6 - przykładowe programy.
130
131 %prep
132 %setup -q -n fox-%{version}
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         %{?with_cups:--enable-cups} \
144         %{?debug:--enable-debug}%{!?debug:--enable-release} \
145         --enable-static%{!?with_static_libs:=no} \
146         --with-opengl \
147         --with-xft \
148         --with-shape \
149         --with-xshm \
150         --with-xcursor \
151         --with-xrandr \
152         --with-xim
153
154 %{__make}
155
156 %{__make} -C doc docs
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 %{__make} -C tests clean
166 cp -a tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
167
168 mv -v $RPM_BUILD_ROOT%{_bindir}/fox-config $RPM_BUILD_ROOT%{_bindir}/fox16-config
169 mv -v $RPM_BUILD_ROOT%{_bindir}/reswrap $RPM_BUILD_ROOT%{_bindir}/reswrap16
170 mv -v $RPM_BUILD_ROOT%{_mandir}/man1/reswrap.1 $RPM_BUILD_ROOT%{_mandir}/man1/reswrap16.1
171 mv -v $RPM_BUILD_ROOT%{_pkgconfigdir}/fox.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/fox-1.6.pc
172
173 %{__rm} doc/Makefile* doc/*/Makefile*
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc AUTHORS LICENSE_ADDENDUM README
184 %attr(755,root,root) %{_libdir}/libCHART-1.6.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.6.so.0
186 %attr(755,root,root) %{_libdir}/libFOX-1.6.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.6.so.0
188
189 %files progs
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/Adie.stx
192 %attr(755,root,root) %{_bindir}/PathFinder
193 %attr(755,root,root) %{_bindir}/adie
194 %attr(755,root,root) %{_bindir}/calculator
195 %attr(755,root,root) %{_bindir}/shutterbug
196 %{_mandir}/man1/PathFinder.1*
197 %{_mandir}/man1/adie.1*
198 %{_mandir}/man1/calculator.1*
199 %{_mandir}/man1/shutterbug.1*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %doc ADDITIONS TRACING
204 %attr(755,root,root) %{_bindir}/fox16-config
205 %attr(755,root,root) %{_bindir}/reswrap16
206 %attr(755,root,root) %{_libdir}/libCHART-1.6.so
207 %attr(755,root,root) %{_libdir}/libFOX-1.6.so
208 %{_libdir}/libCHART-1.6.la
209 %{_libdir}/libFOX-1.6.la
210 %{_includedir}/fox-1.6
211 %{_pkgconfigdir}/fox-1.6.pc
212 %{_mandir}/man1/reswrap16.1*
213
214 %if %{with static_libs}
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libCHART-1.6.a
218 %{_libdir}/libFOX-1.6.a
219 %endif
220
221 %files doc
222 %defattr(644,root,root,755)
223 %doc doc/*
224
225 %files examples
226 %defattr(644,root,root,755)
227 %{_examplesdir}/%{name}-%{version}
This page took 0.050222 seconds and 2 git commands to generate.