]> git.pld-linux.org Git - packages/fox14.git/blob - fox14.spec
- tabs in preamble
[packages/fox14.git] / fox14.spec
1 #
2 %bcond_without  static_libs # don't build static libraries
3 #
4 %define _oname  fox
5 %define _suffix 14
6 #
7 Summary:        The FOX C++ GUI Toolkit
8 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
9 Name:           %{_oname}%{_suffix}
10 Version:        1.4.27
11 Release:        0.1
12 License:        LGPL
13 Group:          X11/Libraries
14 Source0:        ftp://ftp.fox-toolkit.com/pub/%{_oname}-%{version}.tar.gz
15 # Source0-md5:  0f2925b1d595a889640b4222ab1c6a15
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-Makefile.patch
19 URL:            http://www.fox-toolkit.org/fox.html
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bzip2-devel
24 BuildRequires:  cups-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  libtool
30 BuildRequires:  xcursor-devel
31 Requires:       OpenGL
32 Provides:       %{_oname} = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
36
37 %description
38 FOX is a C++-Based Library for Graphical User Interface Development
39 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
40 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
41 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
42 graphics. Subclassing of basic FOX widgets allows for easy extension
43 beyond the built-in widgets by application writers.
44
45 %description -l pl.UTF-8
46 FOX jest biblioteką bazującą na C++ do projektowania graficznych
47 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
48 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
49 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
50 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
51 rozszerzanie.
52
53 %package progs
54 Summary:        FOX example applications
55 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
56 Group:          X11/Applications
57 Requires:       %{name} = %{version}-%{release}
58 Provides:       %{_oname}-progs = %{version}-%{release}
59 Obsoletes:      %{name}-example-apps
60
61 %description progs
62 Editor and file browser, written with FOX.
63
64 %description progs -l pl.UTF-8
65 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
66
67 %package devel
68 Summary:        Header files for FOX library
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       OpenGL-devel
73 Requires:       bzip2-devel
74 Requires:       libjpeg-devel
75 Requires:       libpng-devel
76 Requires:       libstdc++-devel
77 Requires:       libtiff-devel
78 Requires:       xcursor-devel
79 Provides:       %{_oname}-devel = %{version}-%{release}
80
81 %description devel
82 Header files for FOX library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki FOX.
86
87 %package static
88 Summary:        FOX static libraries
89 Summary(pl.UTF-8):      Biblioteki statyczne FOX
90 Group:          X11/Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92 Provides:       %{_oname}-static = %{version}-%{release}
93
94 %description static
95 FOX static libraries.
96
97 %description static -l pl.UTF-8
98 Biblioteki statyczne FOX.
99
100 %package doc
101 Summary:        Development documentation for FOX library
102 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
103 Group:          X11/Development/Libraries
104
105 %description doc
106 Development documentation for FOX library.
107
108 %description doc -l pl.UTF-8
109 Dokumentacja programisty do biblioteki FOX.
110
111 %prep
112 %setup -q -n %{_oname}-%{version}
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__automake}
122 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
123 %configure \
124         --enable-cups \
125         --enable-release \
126         --enable-threadsafe \
127         --with-xcursor \
128         --with-xrandr \
129         --with-opengl \
130         --with-shape \
131         --with-xshm \
132         --with-xft \
133         %{?debug:--enable-debug}%{!?_debug:--enable-release} \
134         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{_datadir}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 rm -f doc/Makefile* doc/*/Makefile*
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS LICENSE_ADDENDUM README
155 %attr(755,root,root) %{_libdir}/lib*.so.*.*
156
157 %files progs
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/adie
160 %attr(755,root,root) %{_bindir}/calculator
161 %attr(755,root,root) %{_bindir}/PathFinder
162 %attr(755,root,root) %{_bindir}/shutterbug
163 %attr(755,root,root) %{_bindir}/Adie.stx
164 %{_mandir}/man1/*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %doc ADDITIONS TRACING
169 %attr(755,root,root) %{_bindir}/fox-config
170 %attr(755,root,root) %{_bindir}/reswrap
171 %attr(755,root,root) %{_libdir}/lib*.so
172 %{_libdir}/lib*.la
173 %{_includedir}/fox-1.4
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
179 %endif
180
181 %files doc
182 %defattr(644,root,root,755)
183 %doc doc/*
This page took 0.073423 seconds and 3 git commands to generate.