]> git.pld-linux.org Git - packages/fox.git/commitdiff
- updated x32 patch auto/th/fox-1.7.84-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 26 Oct 2023 04:29:58 +0000 (06:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 26 Oct 2023 04:29:58 +0000 (06:29 +0200)
fox.spec
x32.patch

index 3d19e6cf0b8868457f413710d0fe4b4bbc32ec14..96e78a535859d6973103356661ce69ed783546d5 100644 (file)
--- a/fox.spec
+++ b/fox.spec
@@ -9,7 +9,7 @@ Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
 Name:          fox
 # NOTE: after switching to 1.8.x keep stable (1.8.x) on HEAD and devel (1.9.x) on DEVEL
 Version:       1.7.84
-Release:       0.1
+Release:       1
 License:       LGPL v3+ with relinking exemption
 Group:         X11/Libraries
 Source0:       http://fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
index e5efb3155b8078b316341511b6b194b96f6fcae3..2da05d731a29ee46c07611a1e5d37ccc19fc8588 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,38 +1,38 @@
---- fox-1.7.57/lib/FXAtomic.cpp.orig   2017-02-06 05:34:36.826461208 +0100
-+++ fox-1.7.57/lib/FXAtomic.cpp        2017-02-06 05:40:53.793123570 +0100
-@@ -404,7 +404,7 @@
+--- fox-1.7.84/lib/FXAtomic.cpp.orig   2023-06-14 06:50:33.000000000 +0200
++++ fox-1.7.84/lib/FXAtomic.cpp        2023-10-26 06:19:01.695280795 +0200
+@@ -721,7 +721,7 @@ FXptr atomicSet(volatile FXptr* ptr,FXpt
    return result;
  #elif (defined(WIN32) && (_MSC_VER >= 1500))
    return (FXptr)_InterlockedExchange((LONG*)ptr,(LONG)v);
 -#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__i386__))
-+#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64) && defined(__ILP32__))))
++#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64__) && defined(__ILP32__))))
    FXptr ret=v;
    __asm__ __volatile__("xchgl %0, (%1)\n\t" : "=r"(ret) : "r"(ptr), "0"(ret) : "memory", "cc");
    return ret;
-@@ -429,7 +429,7 @@
-   return (FXptr)_InterlockedExchangeAdd64((LONGLONG*)ptr,(LONGLONG)v);
+@@ -746,7 +746,7 @@ FXptr atomicAdd(volatile FXptr* ptr,FXiv
+   return (FXptr)_InterlockedExchangeAdd64((volatile LONGLONG*)ptr,(LONGLONG)v);
  #elif (defined(WIN32) && (_MSC_VER >= 1600))
-   return (FXptr)_InterlockedExchangeAdd((LONG*)ptr,(LONG)v);
+   return (FXptr)_InterlockedExchangeAdd((volatile LONG*)ptr,(LONG)v);
 -#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__i386__))
-+#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64) && defined(__ILP32__))))
-   register FXptr ret=(void*)v;
++#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64__) && defined(__ILP32__))))
+   FXptr ret=(void*)v;
    __asm__ __volatile__ ("lock\n\t"
                          "xaddl %0, (%1)\n\t" : "=r"(ret) : "r"(ptr), "0"(ret) : "memory", "cc");
-@@ -455,7 +455,7 @@
-   return (FXptr)_InterlockedCompareExchange64((LONGLONG*)ptr,(LONGLONG)v,(LONGLONG)expect);
+@@ -772,7 +772,7 @@ FXptr atomicCas(volatile FXptr* ptr,FXpt
+   return (FXptr)_InterlockedCompareExchange64((volatile LONGLONG*)ptr,(LONGLONG)v,(LONGLONG)expect);
  #elif defined(WIN32) && (MSC_VER >=1500)
-   return (FXptr)_InterlockedCompareExchange((LONG*)ptr,(LONG)v,(LONG)expect);
+   return (FXptr)_InterlockedCompareExchange((volatile LONG*)ptr,(LONG)v,(LONG)expect);
 -#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__i386__))
-+#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64) && defined(__ILP32__))))
-   register FXptr ret;
++#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64__) && defined(__ILP32__))))
+   FXptr ret;
    __asm__ __volatile__("lock\n\t"
                         "cmpxchgl %2, (%1)\n\t" : "=a"(ret) : "r"(ptr), "r"(v), "a"(expect) : "memory", "cc");
-@@ -483,7 +483,7 @@
-   return (_InterlockedCompareExchange64((LONGLONG*)ptr,(LONGLONG)v,(LONGLONG)expect)==(LONGLONG)expect);
+@@ -800,7 +800,7 @@ FXbool atomicBoolCas(volatile FXptr* ptr
+   return (_InterlockedCompareExchange64((volatile LONGLONG*)ptr,(LONGLONG)v,(LONGLONG)expect)==(LONGLONG)expect);
  #elif defined(WIN32) && (MSC_VER >=1500)
-   return (_InterlockedCompareExchange((LONG*)ptr,(LONG)v,(LONG)expect)==(LONG)expect);
+   return (_InterlockedCompareExchange((volatile LONG*)ptr,(LONG)v,(LONG)expect)==(LONG)expect);
 -#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__i386__))
-+#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64) && defined(__ILP32__))))
-   register FXbool ret;
++#elif (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || (defined(__x86_64__) && defined(__ILP32__))))
+   FXbool ret;
    __asm__ __volatile__ ("lock\n\t"
                          "cmpxchgl %2, (%1)\n\t"
This page took 0.076633 seconds and 4 git commands to generate.