]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
66b9cbe2dc49aa042916c162f29ea67eebc71648
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.7.19
9 Release:        7
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  fb4d0934be26c27c7e76fcbefe2b5d30
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 Patch3:         pkgconfig.patch
18 URL:            http://www.fox-toolkit.org/
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  autoconf >= 2.59-9
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel >= 1.0.2
23 BuildRequires:  cups-devel
24 BuildRequires:  doxygen
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.2.5
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.5.7
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  xorg-lib-libXcursor-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXft-devel
34 BuildRequires:  xorg-lib-libXi-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 BuildRequires:  zlib-devel >= 1.1.4
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
40
41 %description
42 FOX is a C++-Based Library for Graphical User Interface Development
43 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
44 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
45 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
46 graphics. Subclassing of basic FOX widgets allows for easy extension
47 beyond the built-in widgets by application writers.
48
49 %description -l pl.UTF-8
50 FOX jest biblioteką bazującą na C++ do projektowania graficznych
51 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
52 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
53 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
54 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
55 rozszerzanie.
56
57 %package progs
58 Summary:        FOX example applications
59 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62 Obsoletes:      fox-example-apps
63
64 %description progs
65 Editor and file browser, written with FOX.
66
67 %description progs -l pl.UTF-8
68 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
69
70 %package devel
71 Summary:        Header files for FOX library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
73 Group:          X11/Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       OpenGL-GLU-devel
76 Requires:       bzip2-devel >= 1.0.2
77 Requires:       cups-devel
78 Requires:       libjpeg-devel >= 6b
79 Requires:       libpng-devel >= 1.2.5
80 Requires:       libstdc++-devel
81 Requires:       libtiff-devel >= 3.5.7
82 Requires:       xorg-lib-libXcursor-devel
83 Requires:       xorg-lib-libXext-devel
84 Requires:       xorg-lib-libXft-devel
85 Requires:       xorg-lib-libXi-devel
86 Requires:       xorg-lib-libXrandr-devel
87 Requires:       zlib-devel >= 1.1.4
88
89 %description devel
90 Header files for FOX library.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki FOX.
94
95 %package static
96 Summary:        FOX static libraries
97 Summary(pl.UTF-8):      Biblioteki statyczne FOX
98 Group:          X11/Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100
101 %description static
102 FOX static libraries.
103
104 %description static -l pl.UTF-8
105 Biblioteki statyczne FOX.
106
107 %package doc
108 Summary:        Development documentation for FOX library
109 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
110 Group:          X11/Development/Libraries
111
112 %description doc
113 Development documentation for FOX library.
114
115 %description doc -l pl.UTF-8
116 Dokumentacja programisty do biblioteki FOX.
117
118 %package examples
119 Summary:        FOX - example programs
120 Summary(pl.UTF-8):      FOX - programy przykładowe
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description examples
125 FOX - example programs.
126
127 %description examples -l pl.UTF-8
128 FOX - przykładowe programy.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133 %patch1 -p1
134 %patch2 -p1
135 %patch3 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         --enable-cups \
144         %{?debug:--enable-debug}%{!?debug:--enable-release} \
145         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
146         --with-opengl \
147         --with-xft \
148         --with-shape \
149         --with-xshm \
150         --with-xcursor \
151         --with-xrandr \
152         --with-xim
153
154 %{__make}
155
156 %{__make} -C doc docs
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
166
167 rm -f doc/Makefile* doc/*/Makefile*
168
169 %{__make} -C tests clean
170 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS LICENSE_ADDENDUM README
181 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
183 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
185 %attr(755,root,root) %{_bindir}/ControlPanel
186
187 %files progs
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/adie
190 %attr(755,root,root) %{_bindir}/calculator
191 %attr(755,root,root) %{_bindir}/PathFinder
192 %attr(755,root,root) %{_bindir}/shutterbug
193 %attr(755,root,root) %{_bindir}/Adie.stx
194 %{_mandir}/man1/*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %doc ADDITIONS TRACING
199 %attr(755,root,root) %{_bindir}/fox-config
200 %attr(755,root,root) %{_bindir}/reswrap
201 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
202 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
203 %attr(755,root,root) %{_libdir}/libFOX.so
204 %{_libdir}/libCHART-1.7.la
205 %{_libdir}/libFOX-1.7.la
206 %{_includedir}/fox-1.7
207 %{_pkgconfigdir}/fox.pc
208
209 %if %{with static_libs}
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libCHART-1.7.a
213 %{_libdir}/libFOX-1.7.a
214 %endif
215
216 %files doc
217 %defattr(644,root,root,755)
218 %doc doc/*
219
220 %files examples
221 %defattr(644,root,root,755)
222 %{_examplesdir}/%{name}-%{version}
This page took 0.062499 seconds and 2 git commands to generate.