]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
0c7b71104dd1c0fa1f8fa12bc31d3ab8b830986b
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # CUPS support
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        The FOX C++ GUI Toolkit
7 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
8 Name:           fox
9 # 1.7 is devel, we should try to keep stable line
10 Version:        1.7.32
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://ftp.fox-toolkit.org/pub/%{name}-%{version}.tar.gz
15 # Source0-md5:  1cf2607d15ffad5b664cf65bfcd249bc
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-Makefile.patch
19 URL:            http://www.fox-toolkit.org/
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  autoconf >= 2.59-9
22 BuildRequires:  automake
23 BuildRequires:  bzip2-devel >= 1.0.2
24 %{?with_cups:BuildRequires:     cups-devel}
25 BuildRequires:  doxygen
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.2.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel >= 3.5.7
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libXcursor-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXft-devel
35 BuildRequires:  xorg-lib-libXi-devel
36 BuildRequires:  xorg-lib-libXrandr-devel
37 BuildRequires:  zlib-devel >= 1.1.4
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
41
42 %description
43 FOX is a C++-Based Library for Graphical User Interface Development
44 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
45 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
46 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
47 graphics. Subclassing of basic FOX widgets allows for easy extension
48 beyond the built-in widgets by application writers.
49
50 %description -l pl.UTF-8
51 FOX jest biblioteką bazującą na C++ do projektowania graficznych
52 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
53 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
54 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
55 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
56 rozszerzanie.
57
58 %package progs
59 Summary:        FOX example applications
60 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
61 Group:          X11/Applications
62 Requires:       %{name} = %{version}-%{release}
63 Obsoletes:      fox-example-apps
64
65 %description progs
66 Editor and file browser, written with FOX.
67
68 %description progs -l pl.UTF-8
69 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
70
71 %package devel
72 Summary:        Header files for FOX library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       OpenGL-GLU-devel
77 Requires:       bzip2-devel >= 1.0.2
78 Requires:       cups-devel
79 Requires:       libjpeg-devel >= 6b
80 Requires:       libpng-devel >= 1.2.5
81 Requires:       libstdc++-devel
82 Requires:       libtiff-devel >= 3.5.7
83 Requires:       xorg-lib-libXcursor-devel
84 Requires:       xorg-lib-libXext-devel
85 Requires:       xorg-lib-libXft-devel
86 Requires:       xorg-lib-libXi-devel
87 Requires:       xorg-lib-libXrandr-devel
88 Requires:       zlib-devel >= 1.1.4
89
90 %description devel
91 Header files for FOX library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki FOX.
95
96 %package static
97 Summary:        FOX static libraries
98 Summary(pl.UTF-8):      Biblioteki statyczne FOX
99 Group:          X11/Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 FOX static libraries.
104
105 %description static -l pl.UTF-8
106 Biblioteki statyczne FOX.
107
108 %package doc
109 Summary:        Development documentation for FOX library
110 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
111 Group:          X11/Development/Libraries
112
113 %description doc
114 Development documentation for FOX library.
115
116 %description doc -l pl.UTF-8
117 Dokumentacja programisty do biblioteki FOX.
118
119 %package examples
120 Summary:        FOX - example programs
121 Summary(pl.UTF-8):      FOX - programy przykładowe
122 Group:          X11/Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124
125 %description examples
126 FOX - example programs.
127
128 %description examples -l pl.UTF-8
129 FOX - przykładowe programy.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__automake}
142 %configure \
143         %{?with_cups:--enable-cups} \
144         %{?debug:--enable-debug}%{!?debug:--enable-release} \
145         --enable-static%{!?with_static_libs:=no} \
146         --with-opengl \
147         --with-xft \
148         --with-shape \
149         --with-xshm \
150         --with-xcursor \
151         --with-xrandr \
152         --with-xim
153
154 %{__make}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
164
165 %{__make} -C tests clean
166 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
167
168 %{__rm} doc/Makefile* doc/*/Makefile*
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS LICENSE_ADDENDUM README
179 %attr(755,root,root) %{_bindir}/ControlPanel
180 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
182 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
184 %{_mandir}/man1/ControlPanel.1*
185
186 %files progs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/Adie.stx
189 %attr(755,root,root) %{_bindir}/PathFinder
190 %attr(755,root,root) %{_bindir}/adie
191 %attr(755,root,root) %{_bindir}/calculator
192 %attr(755,root,root) %{_bindir}/shutterbug
193 %{_mandir}/man1/PathFinder.1*
194 %{_mandir}/man1/adie.1*
195 %{_mandir}/man1/calculator.1*
196 %{_mandir}/man1/shutterbug.1*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %doc ADDITIONS TRACING
201 %attr(755,root,root) %{_bindir}/reswrap
202 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
203 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
204 %attr(755,root,root) %{_libdir}/libFOX.so
205 %{_libdir}/libCHART-1.7.la
206 %{_libdir}/libFOX-1.7.la
207 %{_includedir}/fox-1.7
208 %{_pkgconfigdir}/fox17.pc
209 %{_mandir}/man1/reswrap.1*
210
211 %if %{with static_libs}
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/libCHART-1.7.a
215 %{_libdir}/libFOX-1.7.a
216 %endif
217
218 %files doc
219 %defattr(644,root,root,755)
220 %doc doc/*
221
222 %files examples
223 %defattr(644,root,root,755)
224 %{_examplesdir}/%{name}-%{version}
This page took 0.031401 seconds and 2 git commands to generate.