]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- rel2; ppr into bcond: default off
[packages/foomatic-filters.git] / foomatic-filters.spec
1
2 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
3
4 %include        /usr/lib/rpm/macros.perl
5
6 Summary:        System for using free software printer drivers
7 Summary(pl):    System umo¿liwiaj±cy u¿ywanie darmowych sterowników drukarek
8 Name:           foomatic-filters
9 Version:        3.0.1
10 Release:        2
11 Epoch:          1
12 License:        GPL
13 Group:          Applications/System
14 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-%{version}.tar.gz
15 # Source0-md5:  afa2bfcee2661252ec56af5616017d1e
16 URL:            http://www.linuxprinting.org/foomatic.html
17 BuildRequires:  a2ps
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  rpm-perlprov
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define _ulibdir        %{_prefix}/lib
24
25 %description
26 Foomatic is a system for using free software printer drivers with
27 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux
28 LPD, LPRng, PPR, and direct spooler-less printing and any free
29 software driver for which execution data has been entered in the
30 database.
31
32 %description -l pl
33 Foomatic to system pozwalaj±cy na u¿ywanie wolnodostêpnych
34 sterowników drukarek z popularnymi uniksowymi serwerami wydruków.
35 Obs³uguje LPD, PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpo¶rednie
36 drukowanie bez kolejkowania oraz dowolny wolnodostêpny sterownik,
37 dla którego parametry zosta³y wprowadzone do bazy danych.
38
39 %package gswrapper
40 Summary:        foomatic wrapper for ghostscript
41 Summary(pl):    wrapper dla ghostscripta do u¿ycia z foomatic
42 Group:          Applications/System
43 Requires:       ghostscript
44 Requires:       a2ps
45 Obsoletes:      foomatic-gswrapper
46
47 %description gswrapper
48 A little Ghostscript regularization script. It massages arguments to
49 make Ghostscript execute properly as a filter, with output on stdout
50 and errors etc on stderr.
51
52 NOTE: This script is needed in a few situations only and may not work
53 with some Ghostscript versions. Moreover in some situations his
54 presence in the system may have effect that Your printer will
55 not print. So - Do not install this package if You don't know
56 what You're doing.
57
58 %description gswrapper -l pl
59 Ma³y skrypt uzdatniaj±cy Ghostscripta. Obrabia parametry tak, ¿eby
60 Ghostscript dzia³a³ w³a¶ciwie jako filtr, generuj±c dane wyj¶ciowe na
61 stdout, a b³êdy na stderr.
62
63 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i mo¿e
64 nie dzia³ac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
65 sytuacjach jego obecno¶æ w systemie mo¿e spowodowaæ, ¿e drukarka nie
66 bêdzie drukowa³a. Tak wiêc - nie instaluj tego pakietu, je¶li nie
67 wiesz, co robisz.
68
69 %package -n cups-filter-foomatic
70 Summary:        cupsomatic - CUPS filter
71 Summary(pl):    cupsomatic - filtr do CUPS
72 Group:          Applications/System
73 Requires:       cups
74 Requires:       %{name} = %{epoch}:%{version}
75 Obsoletes:      foomatic-cups
76 Obsoletes:      cups-foomatic
77
78 %description -n cups-filter-foomatic
79 Cupsomatic is intended to be used as a CUPS filter for printers
80 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
81 Linux Printing Database.
82
83 %description -n cups-filter-foomatic -l pl
84 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
85 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
86 Database.
87
88 %package ppr
89 Summary:        ppromatic - PPR interface
90 Summary(pl):    ppromatic - interfejs do PPR
91 Group:          Applications/System
92 Requires:       %{name} = %{epoch}:%{version}
93 Requires:       ppr
94 Obsoletes:      foomatic-ppr
95
96 %description ppr
97 ppromatic is intended to be used as a PPR interface for printers
98 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
99 Database.
100
101 %description ppr -l pl
102 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
103 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
104
105 %prep
106 %setup -q
107
108 %build
109 %{__aclocal}
110 %{__autoconf}
111 %configure
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install \
117         DESTDIR="$RPM_BUILD_ROOT"
118
119 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ChangeLog TODO README USAGE
127 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/direct
128 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/filter.conf
129 %attr(755,root,root) %{_bindir}/foomatic-rip
130 %{_mandir}/man1/foomatic-rip*
131
132 %files gswrapper
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
135 %{_mandir}/man1/foomatic-gswrapper*
136
137 %files -n cups-filter-foomatic
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_ulibdir}/cups/filter/*
140
141 %if %{with ppr}
142 %files ppr
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
145 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
146 %endif
This page took 0.061516 seconds and 4 git commands to generate.