]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- updated to 3.0.2 see CAN-2004-0801
[packages/foomatic-filters.git] / foomatic-filters.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Sep/1011290.html
3 #
4
5 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
6
7 %include        /usr/lib/rpm/macros.perl
8
9 Summary:        System for using free software printer drivers
10 Summary(pl):    System umo¿liwiaj±cy u¿ywanie darmowych sterowników drukarek
11 Name:           foomatic-filters
12 Version:        3.0.2
13 Release:        1
14 Epoch:          1
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-%{version}.tar.gz
18 # Source0-md5:  f0f4c90fa0ae346f53bf19a165e071a6
19 # Source0-size: 125875
20 URL:            http://www.linuxprinting.org/foomatic.html
21 BuildRequires:  a2ps
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  rpm-perlprov
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define _ulibdir        %{_prefix}/lib
28
29 %description
30 Foomatic is a system for using free software printer drivers with
31 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux
32 LPD, LPRng, PPR, and direct spooler-less printing and any free
33 software driver for which execution data has been entered in the
34 database.
35
36 %description -l pl
37 Foomatic to system pozwalaj±cy na u¿ywanie wolnodostêpnych
38 sterowników drukarek z popularnymi uniksowymi serwerami wydruków.
39 Obs³uguje LPD, PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpo¶rednie
40 drukowanie bez kolejkowania oraz dowolny wolnodostêpny sterownik,
41 dla którego parametry zosta³y wprowadzone do bazy danych.
42
43 %package gswrapper
44 Summary:        foomatic wrapper for ghostscript
45 Summary(pl):    wrapper dla ghostscripta do u¿ycia z foomatic
46 Group:          Applications/System
47 Requires:       ghostscript
48 Requires:       a2ps
49 Obsoletes:      foomatic-gswrapper
50
51 %description gswrapper
52 A little Ghostscript regularization script. It massages arguments to
53 make Ghostscript execute properly as a filter, with output on stdout
54 and errors etc on stderr.
55
56 NOTE: This script is needed in a few situations only and may not work
57 with some Ghostscript versions. Moreover in some situations his
58 presence in the system may have effect that Your printer will
59 not print. So - Do not install this package if You don't know
60 what You're doing.
61
62 %description gswrapper -l pl
63 Ma³y skrypt uzdatniaj±cy Ghostscripta. Obrabia parametry tak, ¿eby
64 Ghostscript dzia³a³ w³a¶ciwie jako filtr, generuj±c dane wyj¶ciowe na
65 stdout, a b³êdy na stderr.
66
67 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i mo¿e
68 nie dzia³ac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
69 sytuacjach jego obecno¶æ w systemie mo¿e spowodowaæ, ¿e drukarka nie
70 bêdzie drukowa³a. Tak wiêc - nie instaluj tego pakietu, je¶li nie
71 wiesz, co robisz.
72
73 %package -n cups-filter-foomatic
74 Summary:        cupsomatic - CUPS filter
75 Summary(pl):    cupsomatic - filtr do CUPS
76 Group:          Applications/System
77 Requires:       cups
78 Requires:       %{name} = %{epoch}:%{version}
79 Obsoletes:      foomatic-cups
80 Obsoletes:      cups-foomatic
81
82 %description -n cups-filter-foomatic
83 Cupsomatic is intended to be used as a CUPS filter for printers
84 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
85 Linux Printing Database.
86
87 %description -n cups-filter-foomatic -l pl
88 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
89 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
90 Database.
91
92 %package ppr
93 Summary:        ppromatic - PPR interface
94 Summary(pl):    ppromatic - interfejs do PPR
95 Group:          Applications/System
96 Requires:       %{name} = %{epoch}:%{version}
97 Requires:       ppr
98 Obsoletes:      foomatic-ppr
99
100 %description ppr
101 ppromatic is intended to be used as a PPR interface for printers
102 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
103 Database.
104
105 %description ppr -l pl
106 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
107 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
108
109 %prep
110 %setup -q
111
112 %build
113 %{__aclocal}
114 %{__autoconf}
115 %configure
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} install \
121         DESTDIR="$RPM_BUILD_ROOT"
122
123 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc ChangeLog TODO README USAGE
131 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/direct
132 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/filter.conf
133 %attr(755,root,root) %{_bindir}/foomatic-rip
134 %{_mandir}/man1/foomatic-rip*
135
136 %files gswrapper
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
139 %{_mandir}/man1/foomatic-gswrapper*
140
141 %files -n cups-filter-foomatic
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_ulibdir}/cups/filter/*
144
145 %if %{with ppr}
146 %files ppr
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
149 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
150 %endif
This page took 0.040333 seconds and 4 git commands to generate.