]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- adapterized (sorted %verify attrs)
[packages/foomatic-filters.git] / foomatic-filters.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Sep/1011290.html
3 #
4
5 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
6
7 %include        /usr/lib/rpm/macros.perl
8
9 Summary:        System for using free software printer drivers
10 Summary(pl):    System umo¿liwiaj±cy u¿ywanie darmowych sterowników drukarek
11 Name:           foomatic-filters
12 Version:        3.0.2
13 Release:        1
14 Epoch:          1
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-%{version}.tar.gz
18 # Source0-md5:  f0f4c90fa0ae346f53bf19a165e071a6
19 URL:            http://www.linuxprinting.org/foomatic.html
20 BuildRequires:  a2ps
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  rpm-perlprov
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define _ulibdir        %{_prefix}/lib
27
28 %description
29 Foomatic is a system for using free software printer drivers with
30 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux LPD,
31 LPRng, PPR, and direct spooler-less printing and any free software
32 driver for which execution data has been entered in the database.
33
34 %description -l pl
35 Foomatic to system pozwalaj±cy na u¿ywanie wolnodostêpnych sterowników
36 drukarek z popularnymi uniksowymi serwerami wydruków. Obs³uguje LPD,
37 PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpo¶rednie drukowanie bez
38 kolejkowania oraz dowolny wolnodostêpny sterownik, dla którego
39 parametry zosta³y wprowadzone do bazy danych.
40
41 %package gswrapper
42 Summary:        foomatic wrapper for ghostscript
43 Summary(pl):    wrapper dla ghostscripta do u¿ycia z foomatic
44 Group:          Applications/System
45 Requires:       a2ps
46 Requires:       ghostscript
47 Obsoletes:      foomatic-gswrapper
48
49 %description gswrapper
50 A little Ghostscript regularization script. It massages arguments to
51 make Ghostscript execute properly as a filter, with output on stdout
52 and errors etc on stderr.
53
54 NOTE: This script is needed in a few situations only and may not work
55 with some Ghostscript versions. Moreover in some situations his
56 presence in the system may have effect that Your printer will not
57 print. So - Do not install this package if You don't know what You're
58 doing.
59
60 %description gswrapper -l pl
61 Ma³y skrypt uzdatniaj±cy Ghostscripta. Obrabia parametry tak, ¿eby
62 Ghostscript dzia³a³ w³a¶ciwie jako filtr, generuj±c dane wyj¶ciowe na
63 stdout, a b³êdy na stderr.
64
65 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i mo¿e nie
66 dzia³ac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
67 sytuacjach jego obecno¶æ w systemie mo¿e spowodowaæ, ¿e drukarka nie
68 bêdzie drukowa³a. Tak wiêc - nie instaluj tego pakietu, je¶li nie
69 wiesz, co robisz.
70
71 %package -n cups-filter-foomatic
72 Summary:        cupsomatic - CUPS filter
73 Summary(pl):    cupsomatic - filtr do CUPS
74 Group:          Applications/System
75 Requires:       %{name} = %{epoch}:%{version}
76 Requires:       cups
77 Obsoletes:      foomatic-cups
78 Obsoletes:      cups-foomatic
79
80 %description -n cups-filter-foomatic
81 Cupsomatic is intended to be used as a CUPS filter for printers
82 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
83 Linux Printing Database.
84
85 %description -n cups-filter-foomatic -l pl
86 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
87 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
88 Database.
89
90 %package ppr
91 Summary:        ppromatic - PPR interface
92 Summary(pl):    ppromatic - interfejs do PPR
93 Group:          Applications/System
94 Requires:       %{name} = %{epoch}:%{version}
95 Requires:       ppr
96 Obsoletes:      foomatic-ppr
97
98 %description ppr
99 ppromatic is intended to be used as a PPR interface for printers
100 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
101 Database.
102
103 %description ppr -l pl
104 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
105 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
106
107 %prep
108 %setup -q
109
110 %build
111 %{__aclocal}
112 %{__autoconf}
113 %configure
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} install \
119         DESTDIR="$RPM_BUILD_ROOT"
120
121 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog TODO README USAGE
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/direct
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/filter.conf
131 %attr(755,root,root) %{_bindir}/foomatic-rip
132 %{_mandir}/man1/foomatic-rip*
133
134 %files gswrapper
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
137 %{_mandir}/man1/foomatic-gswrapper*
138
139 %files -n cups-filter-foomatic
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_ulibdir}/cups/filter/*
142
143 %if %{with ppr}
144 %files ppr
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
147 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
148 %endif
This page took 0.066495 seconds and 4 git commands to generate.