]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- kill Source0-size
[packages/foomatic-filters.git] / foomatic-filters.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Sep/1011290.html
3 #
4
5 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
6
7 %include        /usr/lib/rpm/macros.perl
8
9 Summary:        System for using free software printer drivers
10 Summary(pl):    System umo¿liwiaj±cy u¿ywanie darmowych sterowników drukarek
11 Name:           foomatic-filters
12 Version:        3.0.2
13 Release:        1
14 Epoch:          1
15 License:        GPL
16 Group:          Applications/System
17 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-%{version}.tar.gz
18 # Source0-md5:  f0f4c90fa0ae346f53bf19a165e071a6
19 URL:            http://www.linuxprinting.org/foomatic.html
20 BuildRequires:  a2ps
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  rpm-perlprov
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define _ulibdir        %{_prefix}/lib
27
28 %description
29 Foomatic is a system for using free software printer drivers with
30 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux
31 LPD, LPRng, PPR, and direct spooler-less printing and any free
32 software driver for which execution data has been entered in the
33 database.
34
35 %description -l pl
36 Foomatic to system pozwalaj±cy na u¿ywanie wolnodostêpnych
37 sterowników drukarek z popularnymi uniksowymi serwerami wydruków.
38 Obs³uguje LPD, PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpo¶rednie
39 drukowanie bez kolejkowania oraz dowolny wolnodostêpny sterownik,
40 dla którego parametry zosta³y wprowadzone do bazy danych.
41
42 %package gswrapper
43 Summary:        foomatic wrapper for ghostscript
44 Summary(pl):    wrapper dla ghostscripta do u¿ycia z foomatic
45 Group:          Applications/System
46 Requires:       ghostscript
47 Requires:       a2ps
48 Obsoletes:      foomatic-gswrapper
49
50 %description gswrapper
51 A little Ghostscript regularization script. It massages arguments to
52 make Ghostscript execute properly as a filter, with output on stdout
53 and errors etc on stderr.
54
55 NOTE: This script is needed in a few situations only and may not work
56 with some Ghostscript versions. Moreover in some situations his
57 presence in the system may have effect that Your printer will
58 not print. So - Do not install this package if You don't know
59 what You're doing.
60
61 %description gswrapper -l pl
62 Ma³y skrypt uzdatniaj±cy Ghostscripta. Obrabia parametry tak, ¿eby
63 Ghostscript dzia³a³ w³a¶ciwie jako filtr, generuj±c dane wyj¶ciowe na
64 stdout, a b³êdy na stderr.
65
66 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i mo¿e
67 nie dzia³ac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
68 sytuacjach jego obecno¶æ w systemie mo¿e spowodowaæ, ¿e drukarka nie
69 bêdzie drukowa³a. Tak wiêc - nie instaluj tego pakietu, je¶li nie
70 wiesz, co robisz.
71
72 %package -n cups-filter-foomatic
73 Summary:        cupsomatic - CUPS filter
74 Summary(pl):    cupsomatic - filtr do CUPS
75 Group:          Applications/System
76 Requires:       cups
77 Requires:       %{name} = %{epoch}:%{version}
78 Obsoletes:      foomatic-cups
79 Obsoletes:      cups-foomatic
80
81 %description -n cups-filter-foomatic
82 Cupsomatic is intended to be used as a CUPS filter for printers
83 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
84 Linux Printing Database.
85
86 %description -n cups-filter-foomatic -l pl
87 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
88 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
89 Database.
90
91 %package ppr
92 Summary:        ppromatic - PPR interface
93 Summary(pl):    ppromatic - interfejs do PPR
94 Group:          Applications/System
95 Requires:       %{name} = %{epoch}:%{version}
96 Requires:       ppr
97 Obsoletes:      foomatic-ppr
98
99 %description ppr
100 ppromatic is intended to be used as a PPR interface for printers
101 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
102 Database.
103
104 %description ppr -l pl
105 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
106 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
107
108 %prep
109 %setup -q
110
111 %build
112 %{__aclocal}
113 %{__autoconf}
114 %configure
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 %{__make} install \
120         DESTDIR="$RPM_BUILD_ROOT"
121
122 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc ChangeLog TODO README USAGE
130 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/direct
131 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/foomatic/filter.conf
132 %attr(755,root,root) %{_bindir}/foomatic-rip
133 %{_mandir}/man1/foomatic-rip*
134
135 %files gswrapper
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
138 %{_mandir}/man1/foomatic-gswrapper*
139
140 %files -n cups-filter-foomatic
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_ulibdir}/cups/filter/*
143
144 %if %{with ppr}
145 %files ppr
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
148 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
149 %endif
This page took 0.05244 seconds and 4 git commands to generate.