]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- own /etc/foomatic (i don't know if it's a proper soluttion to get dir of installati...
[packages/foomatic-filters.git] / foomatic-filters.spec
1 #
2 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
3 #
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        System for using free software printer drivers
6 Summary(pl):    System umo¿liwiaj±cy u¿ywanie darmowych sterowników drukarek
7 Name:           foomatic-filters
8 Version:        3.0.2
9 Release:        2
10 Epoch:          1
11 License:        GPL
12 Group:          Applications/System
13 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-%{version}.tar.gz
14 # Source0-md5:  f0f4c90fa0ae346f53bf19a165e071a6
15 URL:            http://www.linuxprinting.org/foomatic.html
16 BuildRequires:  a2ps
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  rpm-perlprov
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define _ulibdir        %{_prefix}/lib
23
24 %description
25 Foomatic is a system for using free software printer drivers with
26 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux LPD,
27 LPRng, PPR, and direct spooler-less printing and any free software
28 driver for which execution data has been entered in the database.
29
30 %description -l pl
31 Foomatic to system pozwalaj±cy na u¿ywanie wolnodostêpnych sterowników
32 drukarek z popularnymi uniksowymi serwerami wydruków. Obs³uguje LPD,
33 PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpo¶rednie drukowanie bez
34 kolejkowania oraz dowolny wolnodostêpny sterownik, dla którego
35 parametry zosta³y wprowadzone do bazy danych.
36
37 %package gswrapper
38 Summary:        foomatic wrapper for ghostscript
39 Summary(pl):    wrapper dla ghostscripta do u¿ycia z foomatic
40 Group:          Applications/System
41 Requires:       a2ps
42 Requires:       ghostscript
43 Obsoletes:      foomatic-gswrapper
44
45 %description gswrapper
46 A little Ghostscript regularization script. It massages arguments to
47 make Ghostscript execute properly as a filter, with output on stdout
48 and errors etc on stderr.
49
50 NOTE: This script is needed in a few situations only and may not work
51 with some Ghostscript versions. Moreover in some situations his
52 presence in the system may have effect that Your printer will not
53 print. So - Do not install this package if You don't know what You're
54 doing.
55
56 %description gswrapper -l pl
57 Ma³y skrypt uzdatniaj±cy Ghostscripta. Obrabia parametry tak, ¿eby
58 Ghostscript dzia³a³ w³a¶ciwie jako filtr, generuj±c dane wyj¶ciowe na
59 stdout, a b³êdy na stderr.
60
61 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i mo¿e nie
62 dzia³ac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
63 sytuacjach jego obecno¶æ w systemie mo¿e spowodowaæ, ¿e drukarka nie
64 bêdzie drukowa³a. Tak wiêc - nie instaluj tego pakietu, je¶li nie
65 wiesz, co robisz.
66
67 %package -n cups-filter-foomatic
68 Summary:        cupsomatic - CUPS filter
69 Summary(pl):    cupsomatic - filtr do CUPS
70 Group:          Applications/System
71 Requires:       %{name} = %{epoch}:%{version}
72 Requires:       cups
73 Obsoletes:      foomatic-cups
74 Obsoletes:      cups-foomatic
75
76 %description -n cups-filter-foomatic
77 Cupsomatic is intended to be used as a CUPS filter for printers
78 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
79 Linux Printing Database.
80
81 %description -n cups-filter-foomatic -l pl
82 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
83 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
84 Database.
85
86 %package ppr
87 Summary:        ppromatic - PPR interface
88 Summary(pl):    ppromatic - interfejs do PPR
89 Group:          Applications/System
90 Requires:       %{name} = %{epoch}:%{version}
91 Requires:       ppr
92 Obsoletes:      foomatic-ppr
93
94 %description ppr
95 ppromatic is intended to be used as a PPR interface for printers
96 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
97 Database.
98
99 %description ppr -l pl
100 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
101 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %configure
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} install \
115         DESTDIR="$RPM_BUILD_ROOT"
116
117 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc ChangeLog TODO README USAGE
125 %dir %{_sysconfdir}/foomatic
126 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/direct
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/filter.conf
128 %attr(755,root,root) %{_bindir}/foomatic-rip
129 %{_mandir}/man1/foomatic-rip*
130
131 %files gswrapper
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
134 %{_mandir}/man1/foomatic-gswrapper*
135
136 %files -n cups-filter-foomatic
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_ulibdir}/cups/filter/*
139
140 %if %{with ppr}
141 %files ppr
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
144 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
145 %endif
This page took 0.058491 seconds and 4 git commands to generate.