]> git.pld-linux.org Git - packages/foomatic-filters.git/blob - foomatic-filters.spec
- 20080317
[packages/foomatic-filters.git] / foomatic-filters.spec
1 #
2 %bcond_with     ppr     # ppr support disabled until we have ppr.spec in working shape
3 #
4 %include        /usr/lib/rpm/macros.perl
5 %define         snap    20080317
6 Summary:        System for using free software printer drivers
7 Summary(pl.UTF-8):      System umożliwiający używanie darmowych sterowników drukarek
8 Name:           foomatic-filters
9 Version:        3.0.%{snap}
10 Release:        2
11 Epoch:          1
12 License:        GPL
13 Group:          Applications/System
14 Source0:        http://www.linuxprinting.org/download/foomatic/%{name}-3.0-%{snap}.tar.gz
15 # Source0-md5:  7a39b08e1a8b1b63917277a021d403eb
16 URL:            http://www.linuxprinting.org/foomatic.html
17 BuildRequires:  a2ps
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  rpm-perlprov
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define _ulibdir        %{_prefix}/lib
24
25 %description
26 Foomatic is a system for using free software printer drivers with
27 common spoolers on Unix. It supports LPD, PDQ, CUPS, the VA Linux LPD,
28 LPRng, PPR, and direct spooler-less printing and any free software
29 driver for which execution data has been entered in the database.
30
31 %description -l pl.UTF-8
32 Foomatic to system pozwalający na używanie wolnodostępnych sterowników
33 drukarek z popularnymi uniksowymi serwerami wydruków. Obsługuje LPD,
34 PDQ, CUPS, VA Linux LPD, LPRng, PPR i bezpośrednie drukowanie bez
35 kolejkowania oraz dowolny wolnodostępny sterownik, dla którego
36 parametry zostały wprowadzone do bazy danych.
37
38 %package gswrapper
39 Summary:        foomatic wrapper for ghostscript
40 Summary(pl.UTF-8):      wrapper dla ghostscripta do użycia z foomatic
41 Group:          Applications/System
42 Requires:       a2ps
43 Requires:       ghostscript
44 Obsoletes:      foomatic-gswrapper
45
46 %description gswrapper
47 A little Ghostscript regularization script. It massages arguments to
48 make Ghostscript execute properly as a filter, with output on stdout
49 and errors etc on stderr.
50
51 NOTE: This script is needed in a few situations only and may not work
52 with some Ghostscript versions. Moreover in some situations his
53 presence in the system may have effect that Your printer will not
54 print. So - Do not install this package if You don't know what You're
55 doing.
56
57 %description gswrapper -l pl.UTF-8
58 Mały skrypt uzdatniający Ghostscripta. Obrabia parametry tak, żeby
59 Ghostscript działał właściwie jako filtr, generując dane wyjściowe na
60 stdout, a błędy na stderr.
61
62 UWAGA: Ten skrypt jest potrzebny tylko w kilku przypadkach i może nie
63 działac z niektórymi wersjami Ghostscripta. Ponadto w niektórych
64 sytuacjach jego obecność w systemie może spowodować, że drukarka nie
65 będzie drukowała. Tak więc - nie instaluj tego pakietu, jeśli nie
66 wiesz, co robisz.
67
68 %package -n cups-filter-foomatic
69 Summary:        cupsomatic - CUPS filter
70 Summary(pl.UTF-8):      cupsomatic - filtr do CUPS
71 Group:          Applications/System
72 Requires:       %{name} = %{epoch}:%{version}
73 Requires:       cups
74 Obsoletes:      foomatic-cups
75 Obsoletes:      cups-foomatic
76
77 %description -n cups-filter-foomatic
78 Cupsomatic is intended to be used as a CUPS filter for printers
79 defined in a PPD file (CUPS-O-Matic or PPD-O-Matic) obtained from the
80 Linux Printing Database.
81
82 %description -n cups-filter-foomatic -l pl.UTF-8
83 Cupsomatic jest filtrem do CUPS dla drukarek zdefiniowanych w pliku
84 PPD (CUPS-O-Matic lub PPD-O-Matic), uzyskanym z Linux Printing
85 Database.
86
87 %package ppr
88 Summary:        ppromatic - PPR interface
89 Summary(pl.UTF-8):      ppromatic - interfejs do PPR
90 Group:          Applications/System
91 Requires:       %{name} = %{epoch}:%{version}
92 Requires:       ppr
93 Obsoletes:      foomatic-ppr
94
95 %description ppr
96 ppromatic is intended to be used as a PPR interface for printers
97 defined in a PPD-O-Matic PPD file obtained from the Linux Printing
98 Database.
99
100 %description ppr -l pl.UTF-8
101 ppromatic jest interfejsem do PPR dla drukarek zdefiniowanych w pliku
102 PPD (PPD-O-Matic) uzyskanym z Linux Printing Database.
103
104 %prep
105 %setup -q -n %{name}-3.0-%{snap}
106
107 %build
108 %{__aclocal}
109 %{__autoconf}
110 %configure
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR="$RPM_BUILD_ROOT"
117
118 ln -sf %{_bindir}/foomatic-rip $RPM_BUILD_ROOT%{_ulibdir}/cups/filter/cupsomatic
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc ChangeLog TODO README USAGE
126 %dir %{_sysconfdir}/foomatic
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/direct
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/foomatic/filter.conf
129 %attr(755,root,root) %{_bindir}/foomatic-rip
130 %{_mandir}/man1/foomatic-rip*
131
132 %files gswrapper
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/foomatic-gswrapper
135 %{_mandir}/man1/foomatic-gswrapper*
136
137 %files -n cups-filter-foomatic
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_ulibdir}/cups/backend/beh
140 %attr(755,root,root) %{_ulibdir}/cups/filter/*
141
142 %if %{with ppr}
143 %files ppr
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_ulibdir}/ppr/interfaces/foomatic-rip
146 %attr(755,root,root) %{_ulibdir}/ppr/lib/foomatic-rip
147 %endif
This page took 0.070295 seconds and 4 git commands to generate.