]> git.pld-linux.org Git - packages/foo2zjs.git/blob - foo2zjs.spec
- package new file: command2foo2lava-pjl
[packages/foo2zjs.git] / foo2zjs.spec
1 Summary:        Linux printer driver for ZjStream protocol
2 Summary(pl.UTF-8):      Linuksowy sterownik drukarek dla protokołu ZjStream
3 Name:           foo2zjs
4 Version:        20120504
5 Release:        1
6 License:        GPL v2
7 Group:          Applications/System
8 Source0:        http://foo2zjs.rkkda.com/foo2zjs.tar.gz#/%{name}-%{version}.tar.gz
9 # Source0-md5:  88fd5a0982001cfc17a58885802f37d7
10 Source1:        http://foo2zjs.rkkda.com/firmware/sihp1000.tar.gz
11 # Source1-md5:  eb7f6e1edfec313e6ca23abd27a0d1c2
12 Source2:        http://foo2zjs.rkkda.com/firmware/sihp1005.tar.gz
13 # Source2-md5:  04f7bd2eec09131371e27403626f38b5
14 Source3:        http://foo2zjs.rkkda.com/firmware/sihpP1006.tar.gz
15 # Source3-md5:  df4b0b84c6feb0d45f64d7fc219895a5
16 Source4:        http://foo2zjs.rkkda.com/firmware/sihp1018.tar.gz
17 # Source4-md5:  bf61f2ce504b233f999bc358f5a79499
18 Source5:        http://foo2zjs.rkkda.com/firmware/sihp1020.tar.gz
19 # Source5-md5:  1d408fa44fb43f2f5f8c8f7eabcc70c6
20 Patch0:         %{name}-udev-rules.patch
21 Patch1:         %{name}-hplj1000.patch
22 URL:            http://foo2zjs.rkkda.com/
23 BuildRequires:  cups-filter-foomatic
24 BuildRequires:  ghostscript
25 BuildRequires:  groff
26 Requires:       foomatic-db
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 foo2zjs is an open source printer driver for printers that use the
31 Zenographics ZjStream wire protocol for their print data. With
32 foo2zjs, you can print to some HP and Minolta/QMS ZjStream printers,
33 such as these:
34
35 - HP LaserJet 1000 B/W
36 - HP LaserJet 1005 B/W
37 - HP LaserJet 1006 B/W
38 - HP LaserJet 1018 B/W
39 - HP LaserJet 1020 B/W
40 - Konica Minolta magicolor 2430 DL B/W and color
41 - Minolta/QMS 2300 DL B/W and color
42 - Minolta/QMS 2200 DL B/W and color
43
44 %description -l pl.UTF-8
45 foo2zjs to otwarty sterownik dla drukarek używających do druku
46 protokołu Zenographics ZjStream. Dzięki foo2zjs można drukować na
47 drukarkach HP oraz Minolta/QMS ZjStream takich jak:
48
49 - HP LaserJet 1000 B/W
50 - HP LaserJet 1005 B/W
51 - HP LaserJet 1006 B/W
52 - HP LaserJet 1018 B/W
53 - HP LaserJet 1020 B/W
54 - Konica Minolta magicolor 2430 DL B/W and color
55 - Minolta/QMS 2300 DL B/W and color
56 - Minolta/QMS 2200 DL B/W and color
57
58 %package firmware
59 Summary:        Firmware for HP LaserJet 10xx printers
60 Summary(pl.UTF-8):      Firmware dla drukarek HP LaserJet 10xx
61 License:        distributable
62 Group:          Applications/System
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       cups-foomatic-db-HP
65
66 %description firmware
67 Firmware for HP LaserJet 10xx printers:
68 - HP LaserJet 1000, 1005, 1006, 1018, 1020
69
70 %description firmware -l pl.UTF-8
71 Firmware dla drukarek HP LaserJet 10xx:
72 - HP LaserJet 1000, 1005, 1006, 1018, 1020
73
74 %package udev-rules
75 Summary:        udev rules for HP LaserJet 10xx printers
76 Summary(pl.UTF-8):      Reguły udev dla drukarek HP LaserJet 10xx
77 Group:          Applications/System
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       %{name}-firmware = %{version}-%{release}
80 Requires:       udev-core
81
82 %description udev-rules
83 udev rules for printers:
84 - HP LaserJet 1000, 1005, 1006, 1018, 1020
85
86 %description udev-rules -l pl.UTF-8
87 Reguły udev dla drukarek:
88 - HP LaserJet 1000, 1005, 1006, 1018, 1020
89
90 %prep
91 %setup -qc -a1 -a2 -a3 -a4 -a5
92 mv %{name}/* .; rmdir %{name}
93 %patch0 -p1
94 %patch1 -p1
95
96 %build
97 %{__make} -j1 \
98         CC="%{__cc}" \
99         CFLAGS="%{rpmcflags} %{rpmcppflags}"
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_datadir}/%{name}/{firmware,crd},/lib/udev/rules.d}
104
105 %{__make} install-prog \
106         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
107         MANDIR=$RPM_BUILD_ROOT%{_mandir} \
108         UDEVBIN=$RPM_BUILD_ROOT%{_bindir}
109
110 %{__make} install-man \
111         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
112         MANDIR=$RPM_BUILD_ROOT%{_mandir}
113
114 install -p hplj1000 $RPM_BUILD_ROOT%{_bindir}/hplj10xx
115 cp -p hplj10xx.rules $RPM_BUILD_ROOT/lib/udev/rules.d/11-hplj10xx.rules
116
117 for i in sihp1000 sihp1005 sihpP1006 sihp1018 sihp1020; do
118         ./arm2hpdl $i.img > $i.dl
119         cp -p $i.dl $RPM_BUILD_ROOT%{_datadir}/%{name}/firmware
120 done
121 cp -p *.ps $RPM_BUILD_ROOT%{_datadir}/%{name}
122 cp -p crd/zjs/*.{crd,ps} \
123         $RPM_BUILD_ROOT%{_datadir}/%{name}/crd
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %service -q cups restart
130
131 %files
132 %defattr(644,root,root,755)
133 %doc ChangeLog README manual.pdf
134 %attr(755,root,root) %{_bindir}/arm2hpdl
135 %attr(755,root,root) %{_bindir}/command2foo2lava-pjl
136 %attr(755,root,root) %{_bindir}/foo2hiperc
137 %attr(755,root,root) %{_bindir}/foo2hiperc-wrapper
138 %attr(755,root,root) %{_bindir}/foo2hp
139 %attr(755,root,root) %{_bindir}/foo2hp2600-wrapper
140 %attr(755,root,root) %{_bindir}/foo2lava
141 %attr(755,root,root) %{_bindir}/foo2lava-wrapper
142 %attr(755,root,root) %{_bindir}/foo2oak
143 %attr(755,root,root) %{_bindir}/foo2oak-wrapper
144 %attr(755,root,root) %{_bindir}/foo2qpdl
145 %attr(755,root,root) %{_bindir}/foo2qpdl-wrapper
146 %attr(755,root,root) %{_bindir}/foo2slx
147 %attr(755,root,root) %{_bindir}/foo2slx-wrapper
148 %attr(755,root,root) %{_bindir}/foo2xqx
149 %attr(755,root,root) %{_bindir}/foo2xqx-wrapper
150 %attr(755,root,root) %{_bindir}/foo2zjs
151 %attr(755,root,root) %{_bindir}/foo2zjs-pstops
152 %attr(755,root,root) %{_bindir}/foo2zjs-wrapper
153 %attr(755,root,root) %{_bindir}/gipddecode
154 %attr(755,root,root) %{_bindir}/hbpldecode
155 %attr(755,root,root) %{_bindir}/hipercdecode
156 %attr(755,root,root) %{_bindir}/hplj10xx
157 %attr(755,root,root) %{_bindir}/lavadecode
158 %attr(755,root,root) %{_bindir}/oakdecode
159 %attr(755,root,root) %{_bindir}/opldecode
160 %attr(755,root,root) %{_bindir}/printer-profile
161 %attr(755,root,root) %{_bindir}/qpdldecode
162 %attr(755,root,root) %{_bindir}/slxdecode
163 %attr(755,root,root) %{_bindir}/usb_printerid
164 %attr(755,root,root) %{_bindir}/xqxdecode
165 %attr(755,root,root) %{_bindir}/zjsdecode
166 %dir %{_datadir}/%{name}
167 %{_datadir}/%{name}/*.ps
168 %{_datadir}/%{name}/crd
169 %{_mandir}/man1/*.1*
170
171 %files firmware
172 %defattr(644,root,root,755)
173 %{_datadir}/%{name}/firmware
174
175 %files udev-rules
176 %defattr(644,root,root,755)
177 /lib/udev/rules.d/11-hplj10xx.rules
This page took 0.036816 seconds and 3 git commands to generate.