]> git.pld-linux.org Git - packages/fonttools.git/blame_incremental - fonttools.spec
- release 4 (by relup.sh)
[packages/fonttools.git] / fonttools.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5%bcond_without doc # Sphinx documentation
6%bcond_without tests # pytest tests
7
8Summary: A tool to convert TrueType/OpenType fonts to XML and back
9Summary(pl.UTF-8): Narzędzie do konwersji fontów TrueType/OpenType do/z XML-a
10Name: fonttools
11Version: 3.44.0
12Release: 4
13# basic license is BSD
14# FontTools includes Adobe AGL & AGLFN, which is under 3-clauses BSD license
15License: MIT, BSD
16Group: Development/Tools
17#Source0Download: https://github.com/fonttools/fonttools/releases
18Source0: https://github.com/fonttools/fonttools/archive/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 3f9ff311081a0f591a09552902671d29
20URL: https://github.com/fonttools/fonttools
21%if %(locale -a | grep -q '^C\.utf8$'; echo $?)
22BuildRequires: glibc-localedb-all
23%endif
24%if %{with python2}
25BuildRequires: python-devel >= 1:2.7
26BuildRequires: python-setuptools
27%if %{with tests}
28BuildRequires: python-enum34 >= 1.1.6
29BuildRequires: python-fs >= 2.2.0
30BuildRequires: python-pytest >= 3.0
31BuildRequires: python-unicodedata2 >= 12.0.0
32%endif
33%endif
34%if %{with python3}
35BuildRequires: python3-devel >= 1:3.4
36%if %{with tests}
37BuildRequires: python3-fs >= 2.2.0
38BuildRequires: python3-pytest >= 3.0
39%if "%{py3_ver}" < "3.7"
40BuildRequires: python3-unicodedata2 >= 12.0.0
41%endif
42%endif
43%endif
44BuildRequires: rpmbuild(macros) >= 1.714
45%if %{with doc}
46BuildRequires: sphinx-pdg-3 >= 1.5.5
47%endif
48%if %{with python2}
49Requires: python-fonttools = %{version}-%{release}
50Requires: python-setuptools
51%else
52Requires: python3-fonttools = %{version}-%{release}
53Requires: python3-setuptools
54%endif
55Provides: ttx = %{version}-%{release}
56BuildArch: noarch
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%description
60TTX/FontTools is a tool for manipulating TrueType and OpenType fonts.
61It is written in Python and has a BSD-style, open-source license. TTX
62can dump TrueType and OpenType fonts to an XML-based text format and
63vice versa.
64
65%description -l pl.UTF-8
66TTX/FontTools to narzędzie do operacji na fontach TrueType i OpenType.
67Zostało napisane w Pythonie i ma otwartą licencję w stylu BSD. TTX
68potrafi wykonywać zrzuty fontów TrueType i OpenType do formatu
69tekstowego opartego na XML-u oraz dokonać operacji odwrotnej.
70
71%package -n python-fonttools
72Summary: Python 2 tools to manipulate font files
73Summary(pl.UTF-8): Narzędzia do manipulacji na plikach fontów dla Pythona 2
74Group: Libraries/Python
75Requires: python-modules >= 1:2.7
76Requires: python-unicodedata2 >= 11.0.0
77
78%description -n python-fonttools
79Python 2 tools to manipulate font files.
80
81%description -n python-fonttools -l pl.UTF-8
82Narzędzia do manipulacji na plikach fontów dla Pythona 2.
83
84%package -n python-fonttools-apidocs
85Summary: Documentation for Python fonttools module
86Summary(pl.UTF-8): Dokumentacja modułu Pythona fonttools
87Group: Documentation
88
89%description -n python-fonttools-apidocs
90Documentation for Python fonttools module.
91
92%description -n python-fonttools-apidocs -l pl.UTF-8
93Dokumentacja modułu Pythona fonttools.
94
95%package -n python3-fonttools
96Summary: Python 3 tools to manipulate font files
97Summary(pl.UTF-8): Narzędzia do manipulacji na plikach fontów dla Pythona 3
98Group: Libraries/Python
99Requires: python3-modules >= 1:3.4
100%if "%{py3_ver}" < "3.7"
101Requires: python3-unicodedata2 >= 11.0.0
102%endif
103
104%description -n python3-fonttools
105Python 3 tools to manipulate font files.
106
107%description -n python3-fonttools -l pl.UTF-8
108Narzędzia do manipulacji na plikach fontów dla Pythona 3.
109
110%prep
111%setup -q
112
113%build
114export LC_ALL=C.UTF-8
115%if %{with python2}
116%py_build
117
118%if %{with tests}
119PYTHONPATH=Lib \
120%{__python} -m pytest Tests
121%endif
122%endif
123
124%if %{with python3}
125%py3_build
126
127%if %{with tests}
128PYTHONPATH=Lib \
129%{__python} -m pytest Tests
130%endif
131%endif
132
133%if %{with doc}
134PYTHONPATH=$(pwd)/build-3/lib \
135%{__make} -C Doc html \
136 SPHINXBUILD=sphinx-build-3
137%endif
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142%if %{with python3}
143%py3_install
144%endif
145
146%if %{with python2}
147%py_install
148
149%py_postclean
150%endif
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%files
156%defattr(644,root,root,755)
157%doc LICENSE LICENSE.external NEWS.rst README.rst
158%attr(755,root,root) %{_bindir}/fonttools
159%attr(755,root,root) %{_bindir}/pyftmerge
160%attr(755,root,root) %{_bindir}/pyftsubset
161%attr(755,root,root) %{_bindir}/ttx
162%{_mandir}/man1/ttx.1*
163
164%if %{with python2}
165%files -n python-fonttools
166%defattr(644,root,root,755)
167%{py_sitescriptdir}/fontTools
168%{py_sitescriptdir}/fonttools-%{version}-py*.egg-info
169
170%if %{with doc}
171%files -n python-fonttools-apidocs
172%defattr(644,root,root,755)
173%doc Doc/build/html/{_static,designspaceLib,misc,pens,ttLib,varLib,*.html,*.js}
174%endif
175%endif
176
177%if %{with python3}
178%files -n python3-fonttools
179%defattr(644,root,root,755)
180%{py3_sitescriptdir}/fontTools
181%{py3_sitescriptdir}/fonttools-%{version}-py*.egg-info
182%endif
This page took 0.062903 seconds and 4 git commands to generate.