]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blob - fonts-TTF-microsoft.spec
- message fixes
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 Summary:        Microsoft True Type fonts
6 Summary(pl):    Fonty True Type firmy Microsoft
7 %define         base_name       fonts-TTF-microsoft
8 %if %{with license_agreement}
9 Name:           %{base_name}
10 %else
11 Name:           %{base_name}-installer
12 %endif
13 Version:        20020525
14 Release:        4%{?with_license_agreement:wla}
15 License:        Microsoft EULA (for non-commercial use)
16 Group:          Fonts
17 %if %{with license_agreement}
18 Source0:        http://dl.sourceforge.net/corefonts/andale32.exe
19 # NoSource0-md5:        cbdc2fdd7d2ed0832795e86a8b9ee19a
20 Source1:        http://dl.sourceforge.net/corefonts/arial32.exe
21 # NoSource1-md5:        9637df0e91703179f0723ec095a36cb5
22 Source2:        http://dl.sourceforge.net/corefonts/arialb32.exe
23 # NoSource2-md5:        c9089ae0c3b3d0d8c4b0a95979bb9ff0
24 Source3:        http://dl.sourceforge.net/corefonts/comic32.exe
25 # NoSource3-md5:        2b30de40bb5e803a0452c7715fc835d1
26 Source4:        http://dl.sourceforge.net/corefonts/courie32.exe
27 # NoSource4-md5:        4e412c772294403ab62fb2d247d85c60
28 Source5:        http://dl.sourceforge.net/corefonts/georgi32.exe
29 # NoSource5-md5:        4d90016026e2da447593b41a8d8fa8bd
30 Source6:        http://dl.sourceforge.net/corefonts/impact32.exe
31 # NoSource6-md5:        7907c7dd6684e9bade91cff82683d9d7
32 Source7:        http://dl.sourceforge.net/corefonts/times32.exe
33 # NoSource7-md5:        ed39c8ef91b9fb80f76f702568291bd5
34 Source8:        http://dl.sourceforge.net/corefonts/trebuc32.exe
35 # NoSource8-md5:        0d7ea16cac6261f8513a061fbfcdb2b5
36 Source9:        http://dl.sourceforge.net/corefonts/verdan32.exe
37 # NoSource9-md5:        12d2a75f8156e10607be1eaa8e8ef120
38 Source10:       http://dl.sourceforge.net/corefonts/webdin32.exe
39 # NoSource10-md5:       230a1d13a365b22815f502eb24d9149b
40 %else
41 # extracted from one of the above
42 Source20:       Microsoft-EULA.txt
43 %endif
44 URL:            http://corefonts.sourceforge.net/
45 %if %{with license_agreement}
46 BuildRequires:  cabextract
47 Requires:       %{_fontsdir}/TTF
48 Requires(post,postun):  fontpostinst
49 %else
50 Requires:       rpm-build-tools
51 Requires:       wget
52 %endif
53 BuildArch:      noarch
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         ttffontsdir     %{_fontsdir}/TTF
57
58 %description
59 Microsoft free True Type fonts collection.
60 %if ! %{with license_agreement}
61 License issues made us not to include inherent files into this package
62 by default. If you want to create full working package please build it
63 with one of the following command:
64
65 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
66 %{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
67 %endif
68
69 %description -l pl
70 Kolekcja darmowych fontów True Type firmy Microsoft.
71 %if ! %{with license_agreement}
72 Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
73 plików. Je¶li chcesz stworzyæ w pe³ni funkcjonalny pakiet, zbuduj go za
74 pomoc± polecenia:
75
76 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
77 %{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
78 %endif
79
80 %prep
81 %if %{with license_agreement}
82 %setup -q -c -T
83 /usr/bin/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
84 %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
85 %{SOURCE10}
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if ! %{with license_agreement}
92 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
93
94 cat <<EOF >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
95 #!/bin/sh
96 if [ "\$1" = "--with" -a "\$2" = "license_agreement" ]
97 then
98         TMPDIR=\`rpm --eval "%%{tmpdir}"\`; export TMPDIR
99         SPECDIR=\`rpm --eval "%%{_specdir}"\`; export SPECDIR
100         SRPMDIR=\`rpm --eval "%%{_srcrpmdir}"\`; export SRPMDIR
101         SOURCEDIR=\`rpm --eval "%%{_sourcedir}"\`; export SOURCEDIR
102         BUILDDIR=\`rpm --eval "%%{_builddir}"\`; export BUILDDIR
103         RPMDIR=\`rpm --eval "%%{_rpmdir}"\`; export RPMDIR
104         BACKUP_SPEC=0
105         mkdir -p \$TMPDIR \$SPECDIR \$SRPMDIR \$RPMDIR \$SRPMDIR \$SOURCEDIR \$BUILDDIR
106         if [ -f \$SPECDIR/%{base_name}.spec ]; then
107                 BACKUP_SPEC=1
108                 mv -f \$SPECDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec.prev
109         fi
110         if echo "\$3" | grep '\.src\.rpm$' >/dev/null; then
111                 ( cd \$SRPMDIR
112                 if echo "\$3" | grep '://' >/dev/null; then
113                         wget --passive-ftp -t0 "\$3"
114                 else
115                         cp -f "\$3" .
116                 fi
117                 rpm2cpio \`basename "\$3"\` | ( cd \$TMPDIR; cpio -i %{base_name}.spec ) )
118                 if ! cp -i \$TMPDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec; then
119                         exit 1
120                 fi
121         else
122                 if ! cp -i "\$3" \$SPECDIR; then
123                         exit 1
124                 fi
125         fi
126         ( cd \$SPECDIR
127         %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
128         if [ "\$?" -ne 0 ]; then
129                 exit 2
130         fi
131         RPMNAME=%{base_name}-%{version}-%{release}wla.noarch.rpm
132         rpm -U \$RPMDIR/\$RPMNAME || \
133                 echo -e Install manually the file:\\\n   \$RPMDIR/\$RPMNAME )
134         if [ "\$BACKUP_SPEC" -eq 1 ]; then
135                 mv -f \$SPECDIR/%{base_name}.spec.prev \$SPECDIR/%{base_name}.spec
136         fi
137 else
138         cat %{_datadir}/%{base_name}/Microsot-EULA.txt
139         echo "
140 If you accept the above license rebuild the package using:
141
142 \$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
143 "
144 fi
145 EOF
146
147 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
148 install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
149
150 %else
151 install -d $RPM_BUILD_ROOT%{ttffontsdir}
152 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
153 %endif
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %if %{with license_agreement}
159 %post
160 fontpostinst TTF
161
162 %postun
163 fontpostinst TTF
164
165 %else
166 %pre
167 echo "
168 If you accept the license enclosed in the file
169 %{_datadir}/%{base_name}/Microsoft-EULA.txt
170 and want to install real fonts, then rebuild the package with the
171 following command:
172
173 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
174 "
175 %endif
176
177 %files
178 %defattr(644,root,root,755)
179 %if %{with license_agreement}
180 %doc licen.txt
181 %{ttffontsdir}/*
182 %else
183 %attr(755,root,root) %{_bindir}/%{base_name}.install
184 %{_datadir}/%{base_name}
185 %endif
This page took 0.048582 seconds and 4 git commands to generate.