]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/blob - fonts-TTF-microsoft-tahoma.spec
- s/True Type/TrueType/
[packages/fonts-TTF-microsoft-tahoma.git] / fonts-TTF-microsoft-tahoma.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package (requires Windows license)
4 #
5 %define         base_name               fonts-TTF-microsoft-tahoma
6 Summary:        Microsoft Tahoma TrueType font
7 Summary(pl.UTF-8):      Font TrueType Tahoma firmy Microsoft
8 %if %{with license_agreement}
9 Name:           %{base_name}
10 %else
11 Name:           %{base_name}-installer
12 %endif
13 Version:        20020525
14 %define         _rel    3
15 Release:        %{_rel}%{?with_license_agreement:wla}
16 # part of IE update - requires Windows license to use
17 License:        Windows EULA
18 Group:          Fonts
19 %if %{with license_agreement}
20 Source0:        http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB
21 # NoSource0-md5: 358584cddb75ac90472c25f01b308ebe
22 NoSource:       0
23 BuildRequires:  cabextract
24 Requires(post,postun):  fontpostinst
25 Requires:       %{_fontsdir}/TTF
26 %else
27 Source1:        license-installer.sh
28 Requires:       cabextract
29 Requires:       rpm-build-tools
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         ttffontsdir     %{_fontsdir}/TTF
35
36 %description
37 Microsoft Tahoma TrueType font.
38
39 %description -l pl.UTF-8
40 Font TrueType Tahoma firmy Microsoft.
41
42 %prep
43 %if %{with license_agreement}
44 %setup -q -c -T
45 %{_bindir}/cabextract -L %{SOURCE0}
46 %endif
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %if !%{with license_agreement}
51 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
52
53 sed -e '
54         s/@BASE_NAME@/%{base_name}/g
55         s/@TARGET_CPU@/%{_target_cpu}/g
56         s-@VERSION@-%{version}-g
57         s-@RELEASE@-%{release}-g
58         s,@USE_DISTFILES@,no,g
59         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
60 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
61
62 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
63
64 %else
65 install -d $RPM_BUILD_ROOT%{ttffontsdir}
66 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
67 %endif
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with license_agreement}
73 %post
74 fontpostinst TTF
75
76 %postun
77 fontpostinst TTF
78
79 %else
80 %post
81 echo "
82 License issues made us not to include inherent files into this package
83 by default (You need Windows license). If you want to create full
84 working package please build it with the following command:
85
86 %{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
87 "
88 %endif
89
90 %files
91 %defattr(644,root,root,755)
92 %if %{with license_agreement}
93 %{ttffontsdir}/*
94 %else
95 %attr(755,root,root) %{_bindir}/%{base_name}.install
96 %{_datadir}/%{base_name}
97 %endif
This page took 0.046617 seconds and 4 git commands to generate.