]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/blob - fonts-TTF-microsoft-tahoma.spec
- use shared license-installer.sh script from SOURCES
[packages/fonts-TTF-microsoft-tahoma.git] / fonts-TTF-microsoft-tahoma.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package (may require Windows license?)
4 #
5 Summary:        Microsoft Tahoma True Type font
6 Summary(pl):    Font True Type Tahoma firmy Microsoft
7 %define         base_name               fonts-TTF-microsoft-tahoma
8 %if %{with license_agreement}
9 Name:           %{base_name}
10 %else
11 Name:           %{base_name}-installer
12 %endif
13 Version:        20020525
14 Release:        2%{?with_license_agreement:wla}
15 # part of IE update - may require Windows license to use
16 License:        ?
17 Group:          Fonts
18 %if %{with license_agreement}
19 # also at http://dl.sourceforge.net/corefonts/
20 Source0:        http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB
21 # NoSource0-md5: 358584cddb75ac90472c25f01b308ebe
22 BuildRequires:  cabextract
23 Requires:       %{_fontsdir}/TTF
24 Requires(post,postun):  fontpostinst
25 %else
26 Source0:        license-installer.sh
27 Requires:       cabextract
28 Requires:       rpm-build-tools
29 Requires:       wget
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         ttffontsdir     %{_fontsdir}/TTF
35
36 %description
37 Microsoft Tahoma True Type font.
38 %if %{without license_agreement}
39 License issues made us not to include inherent files into this package
40 by default (it probably requires Windows license). If you want to
41 create full working package please build it with one of the following
42 command:
43
44 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
45 %endif
46
47 %description -l pl
48 Font True Type Tahoma firmy Microsoft.
49 %if %{without license_agreement}
50 Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
51 plików (prawdopodobnie wymaga licencji na Windows). Je¶li chcesz stworzyæ
52 w pe³ni funkcjonalny pakiet, zbuduj go za pomoc± polecenia:
53
54 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
55 %endif
56
57 %prep
58 %if %{with license_agreement}
59 %setup -q -c -T
60 /usr/bin/cabextract -L %{SOURCE0}
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %if %{without license_agreement}
66 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
67
68 sed -e '
69         s/@BASE_NAME@/%{base_name}/g
70         s/@TARGET_CPU@/%{_target_cpu}/g
71         s-@VERSION@-%{version}-g
72         s-@RELEASE@-%{release}-g
73         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
74 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
75
76 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
77
78 %else
79 install -d $RPM_BUILD_ROOT%{ttffontsdir}
80 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
81 %endif
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with license_agreement}
87 %post
88 fontpostinst TTF
89
90 %postun
91 fontpostinst TTF
92
93 %else
94 %pre
95 echo "
96 License issues made us not to include inherent files into this package
97 by default (it probably requires Windows license). If you want to
98 create full working package please build it with the following command:
99
100 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
101 "
102 %endif
103
104 %files
105 %defattr(644,root,root,755)
106 %if %{with license_agreement}
107 %{ttffontsdir}/*
108 %else
109 %attr(755,root,root) %{_bindir}/%{base_name}.install
110 %{_datadir}/%{base_name}
111 %endif
This page took 0.035121 seconds and 4 git commands to generate.