]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/blob - fonts-TTF-microsoft-tahoma.spec
- release 6 (by relup.sh)
[packages/fonts-TTF-microsoft-tahoma.git] / fonts-TTF-microsoft-tahoma.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package (requires Windows license)
4 #
5 %define         base_name               fonts-TTF-microsoft-tahoma
6 %define         _rel                    5
7 Summary:        Microsoft Tahoma TrueType font
8 Summary(pl.UTF-8):      Font TrueType Tahoma firmy Microsoft
9 %if %{with license_agreement}
10 Name:           %{base_name}
11 %else
12 Name:           %{base_name}-installer
13 %endif
14 Version:        20020525
15 Release:        %{_rel}%{?with_license_agreement:wla}
16 # part of IE update - requires Windows license to use
17 License:        Windows EULA
18 Group:          Fonts
19 %if %{with license_agreement}
20 Source0:        http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB
21 # NoSource0-md5: 358584cddb75ac90472c25f01b308ebe
22 NoSource:       0
23 BuildRequires:  cabextract
24 Requires(post,postun):  fontpostinst
25 Requires:       %{_fontsdir}/TTF
26 %else
27 Source1:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
28 # Source1-md5:  329c25f457fea66ec502b7ef70cb9ede
29 Requires:       cabextract
30 Requires:       rpm-build-tools >= 4.4.37
31 Requires:       rpmbuild(macros) >= 1.544
32 %endif
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         ttffontsdir     %{_fontsdir}/TTF
37
38 %description
39 Microsoft Tahoma TrueType font.
40
41 %description -l pl.UTF-8
42 Font TrueType Tahoma firmy Microsoft.
43
44 %prep
45 %if %{with license_agreement}
46 %setup -q -c -T
47 %{_bindir}/cabextract -L %{SOURCE0}
48 %endif
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %if !%{with license_agreement}
53 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
54
55 sed -e '
56         s/@BASE_NAME@/%{base_name}/g
57         s/@TARGET_CPU@/%{_target_cpu}/g
58         s-@VERSION@-%{version}-g
59         s-@RELEASE@-%{release}-g
60         s,@USE_DISTFILES@,no,g
61         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
62         s,@DATADIR@,%{_datadir}/%{base_name},g
63 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
64
65 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
66
67 %else
68 install -d $RPM_BUILD_ROOT%{ttffontsdir}
69 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with license_agreement}
76 %post
77 fontpostinst TTF
78
79 %postun
80 fontpostinst TTF
81
82 %else
83 %post
84 echo "
85 License issues made us not to include inherent files into this package
86 by default (You need Windows license). If you want to create full
87 working package please build it with the following command:
88
89 %{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
90 "
91 %endif
92
93 %files
94 %defattr(644,root,root,755)
95 %if %{with license_agreement}
96 %{ttffontsdir}/*
97 %else
98 %attr(755,root,root) %{_bindir}/%{base_name}.install
99 %{_datadir}/%{base_name}
100 %endif
This page took 0.071059 seconds and 3 git commands to generate.