]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-arialunicode.git/blobdiff - fonts-TTF-microsoft-arialunicode.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/fonts-TTF-microsoft-arialunicode.git] / fonts-TTF-microsoft-arialunicode.spec
index a71f5760a24c2119d5ca8777d4642b630c8bca33..1f00b31d1495c3fe0a5ddb5debe517e426389705 100644 (file)
@@ -2,16 +2,17 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package (may require MS Office license?)
 #
-Summary:       Microsoft Arial Unicode True Type font
-Summary(pl):   Font True Type Arial Unicode firmy Microsoft
 %define                base_name               fonts-TTF-Microsoft-ArialUnicode
+%define                rel                     3
+Summary:       Microsoft Arial Unicode TrueType font
+Summary(pl.UTF-8):     Font TrueType Arial Unicode firmy Microsoft
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
 Version:       1.0
-Release:       1%{?with_license_agreement:wla}
+Release:       %{rel}%{?with_license_agreement:wla}
 # part of MS Office - may require Office license to use
 License:       ?
 Group:         Fonts
@@ -20,12 +21,14 @@ Group:              Fonts
 Source0:       http://orwell.ru/download/aruniupd.exe
 # NoSource0-md5: 1bef548eb449a0b24ad1c0b8e9d5f2ba
 BuildRequires: cabextract
-Requires:      %{_fontsdir}/TTF
 Requires(post,postun): fontpostinst
+Requires:      %{_fontsdir}/TTF
 %else
+Source0:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source0-md5: 329c25f457fea66ec502b7ef70cb9ede
 Requires:      cabextract
-Requires:      rpm-build-tools
-Requires:      wget
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -33,26 +36,24 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ttffontsdir     %{_fontsdir}/TTF
 
 %description
-Microsoft Arial Unicode True Type font.
-%if ! %{with license_agreement}
+Microsoft Arial Unicode TrueType font.
+%if !%{with license_agreement}
 License issues made us not to include inherent files into this package
 by default (it probably requires MS Office license). If you want to
 create full working package please build it with one of the following
 command:
 
 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
 %endif
 
-%description -l pl
-Font True Type Arial Unicode firmy Microsoft.
-%if ! %{with license_agreement}
-Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
-plików (prawdopodobnie wymaga licencji na MS Office). Je¶li chcesz stworzyæ
-w pe³ni funkcjonalny pakiet, zbuduj go za pomoc± polecenia:
+%description -l pl.UTF-8
+Font TrueType Arial Unicode firmy Microsoft.
+%if !%{with license_agreement}
+Kwestie licencji zmusiły nas do niedołączania do tego pakietu istotnych
+plików (prawdopodobnie wymaga licencji na MS Office). Jeśli chcesz stworzyć
+w pełni funkcjonalny pakiet, zbuduj go za pomocą polecenia:
 
 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
 %endif
 
 %prep
@@ -63,63 +64,17 @@ w pe
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if ! %{with license_agreement}
+%if !%{with license_agreement}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
 
-cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]
-then
-       TMPDIR=`rpm --eval "%%{tmpdir}"`; export TMPDIR
-       SPECDIR=`rpm --eval "%%{_specdir}"`; export SPECDIR
-       SRPMDIR=`rpm --eval "%%{_srcrpmdir}"`; export SRPMDIR
-       SOURCEDIR=`rpm --eval "%%{_sourcedir}"`; export SOURCEDIR
-       BUILDDIR=`rpm --eval "%%{_builddir}"`; export BUILDDIR
-       RPMDIR=`rpm --eval "%%{_rpmdir}"`; export RPMDIR
-       BACKUP_SPEC=0
-       mkdir -p $TMPDIR $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-       if [ -f $SPECDIR/%{base_name}.spec ]; then
-               BACKUP_SPEC=1
-               mv -f $SPECDIR/%{base_name}.spec $SPECDIR/%{base_name}.spec.prev
-       fi
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd $SRPMDIR
-               if echo "$3" | grep '://' >/dev/null; then
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" .
-               fi
-               rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i %{base_name}.spec ) )
-               if ! cp -i $TMPDIR/%{base_name}.spec $SPECDIR/%{base_name}.spec; then
-                       exit 1
-               fi
-       else
-               if ! cp -i "$3" $SPECDIR; then
-                       exit 1
-               fi
-       fi
-       ( cd $SPECDIR
-       %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAME=%{base_name}-%{version}-%{release}wla.noarch.rpm
-       rpm -U $RPMDIR/$RPMNAME || \
-               echo -e "Install manually the file:\n   $RPMDIR/$RPMNAME" )
-       if [ "$BACKUP_SPEC" -eq 1 ]; then
-               mv -f $SPECDIR/%{base_name}.spec.prev $SPECDIR/%{base_name}.spec
-       fi
-else
-       cat %{_datadir}/%{base_name}/Microsot-EULA.txt
-       echo "
-License issues made us not to include inherent files into this package
-by default (it probably requires Windows license). If you want to
-create full working package please build it with the following command:
-
-$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-"
-fi
-EOF
+sed -e '
+       s/@BASE_NAME@/%{base_name}/g
+       s/@TARGET_CPU@/%{_target_cpu}/g
+       s-@VERSION@-%{version}-g
+       s-@RELEASE@-%{release}-g
+       s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
@@ -139,7 +94,7 @@ fontpostinst TTF
 fontpostinst TTF
 
 %else
-%pre
+%post
 echo "
 License issues made us not to include inherent files into this package
 by default (it probably requires Windows license). If you want to
This page took 0.093887 seconds and 4 git commands to generate.