]> git.pld-linux.org Git - packages/fonts-TTF-OpenSans.git/commitdiff
new, verison 1.10 auto/th/fonts-TTF-OpenSans-1.10-1
authorElan Ruusamäe <glen@delfi.ee>
Mon, 29 Dec 2014 13:29:03 +0000 (15:29 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 29 Dec 2014 13:29:05 +0000 (15:29 +0200)
based on fedora package (80d1c4f)
review-request: https://bugzilla.redhat.com/1035897

fontconfig.conf [new file with mode: 0644]
fonts-TTF-OpenSans.spec [new file with mode: 0644]
get-source.sh [new file with mode: 0755]

diff --git a/fontconfig.conf b/fontconfig.conf
new file mode 100644 (file)
index 0000000..048b45e
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
+<fontconfig>
+ <alias>
+    <family>Open Sans</family>
+    <prefer>
+      <family>sans-serif</family>
+    </prefer>
+  </alias>
+  <alias>
+    <family>sans-serif</family>
+    <default>
+      <family>Open Sans</family>
+    </default>
+  </alias>
+</fontconfig>
diff --git a/fonts-TTF-OpenSans.spec b/fonts-TTF-OpenSans.spec
new file mode 100644 (file)
index 0000000..8a10712
--- /dev/null
@@ -0,0 +1,65 @@
+%define        fontname open-sans
+%define        fontconf 60-%{fontname}.conf
+Summary:       Open Sans is a humanist sans-serif typeface designed by Steve Matteson
+Name:          fonts-TTF-OpenSans
+Version:       1.10
+Release:       1
+License:       Apache v2.0
+Group:         Fonts
+URL:           http://www.google.com/fonts/specimen/Open+Sans
+# Since the font doesn't have clear upstream, the source zip package is
+# downloaded from Google Fonts. It is then converted to tar.gz. All by get-source.sh.
+Source0:       http://pkgs.fedoraproject.org/repo/pkgs/open-sans-fonts/open-sans-fonts-%{version}.tar.xz/5fa43b45f45c7ef4b589b3bdf4052d77/open-sans-fonts-%{version}.tar.xz
+# Source0-md5: 5fa43b45f45c7ef4b589b3bdf4052d77
+Source1:       fontconfig.conf
+Source2:       get-source.sh
+BuildRequires: tar >= 1:1.22
+BuildRequires: ttembed
+BuildRequires: xz
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _ttffontsdir    %{_fontsdir}/TTF
+
+%description
+Open Sans is a humanist sans serif typeface designed by Steve
+Matteson, Type Director of Ascender Corp. This version contains the
+complete 897 character set, which includes the standard ISO Latin 1,
+Latin CE, Greek and Cyrillic character sets. Open Sans was designed
+with an upright stress, open forms and a neutral, yet friendly
+appearance. It was optimized for print, web, and mobile interfaces,
+and has excellent legibility characteristics in its letter forms.
+
+%prep
+%setup -q -n open-sans-fonts-%{version}
+
+%build
+# set Embedding permission to 'Installable'
+ls *.ttf | xargs ttembed
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_ttffontsdir},%{_sysconfdir}/fonts/conf.d,%{_datadir}/fontconfig/conf.avail}
+
+cp -p *.ttf $RPM_BUILD_ROOT%{_ttffontsdir}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/fontconfig/conf.avail/%{fontconf}
+ln -s %{_datadir}/fontconfig/conf.avail/%{fontconf} $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d/%{fontconf}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc LICENSE.txt
+%{_sysconfdir}/fonts/conf.d/60-open-sans.conf
+%{_datadir}/fontconfig/conf.avail/60-open-sans.conf
+%{_datadir}/fonts/TTF/OpenSans-Bold.ttf
+%{_datadir}/fonts/TTF/OpenSans-BoldItalic.ttf
+%{_datadir}/fonts/TTF/OpenSans-ExtraBold.ttf
+%{_datadir}/fonts/TTF/OpenSans-ExtraBoldItalic.ttf
+%{_datadir}/fonts/TTF/OpenSans-Italic.ttf
+%{_datadir}/fonts/TTF/OpenSans-Light.ttf
+%{_datadir}/fonts/TTF/OpenSans-LightItalic.ttf
+%{_datadir}/fonts/TTF/OpenSans-Regular.ttf
+%{_datadir}/fonts/TTF/OpenSans-Semibold.ttf
+%{_datadir}/fonts/TTF/OpenSans-SemiboldItalic.ttf
diff --git a/get-source.sh b/get-source.sh
new file mode 100755 (executable)
index 0000000..3bf1a69
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/bash
+# Get upstream zip and make source tar.gz
+
+ARCHIVE="open-sans-fonts-1.10"
+TMPDIR=$(mktemp -d --tmpdir=/var/tmp getopensans-XXXXXXXXXX)
+[ $? != 0 ] && exit 1
+umask 022
+pushd "$TMPDIR"
+
+wget -N -O $ARCHIVE.zip http://www.google.com/fonts/download?kit=3hvsV99qyKCBS55e5pvb3ltkqrIMaAZWyLYEoB48lSQ
+unzip $ARCHIVE.zip -d $ARCHIVE
+tar -cvJf "$ARCHIVE.tar.xz" $ARCHIVE
+
+popd
+mv "$TMPDIR/$ARCHIVE.tar.xz" .
+rm -fr "$TMPDIR"
\ No newline at end of file
This page took 0.124476 seconds and 4 git commands to generate.