]> git.pld-linux.org Git - packages/fontconfig.git/commitdiff
up to 2.13.1 auto/th/fontconfig-2.13.1-1
authorJan Palus <atler@pld-linux.org>
Sat, 1 Sep 2018 16:58:42 +0000 (18:58 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 1 Sep 2018 16:58:42 +0000 (18:58 +0200)
- constant-weight patch no longer needed
- pass OSTYPE explicitly to tests, otherwise they fail with:
  ./run-test-conf.sh[29]: OSTYPE: parameter not set

fontconfig-constant-weight.patch [deleted file]
fontconfig.spec

diff --git a/fontconfig-constant-weight.patch b/fontconfig-constant-weight.patch
deleted file mode 100644 (file)
index ac764cb..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-From 198358dd8ff858c9e36531a7406ccb2246ae77b7 Mon Sep 17 00:00:00 2001
-From: Akira TAGOH <akira@tagoh.org>
-Date: Mon, 12 Mar 2018 11:49:58 +0900
-Subject: Allow the constant names in the range
-
-https://bugs.freedesktop.org/show_bug.cgi?id=105415
----
- src/fcname.c | 34 +++++++++++++++++++++++++++++-----
- 1 file changed, 29 insertions(+), 5 deletions(-)
-
-diff --git a/src/fcname.c b/src/fcname.c
-index 79e413e..15fb659 100644
---- a/src/fcname.c
-+++ b/src/fcname.c
-@@ -330,13 +330,37 @@ FcNameConvert (FcType type, FcChar8 *string)
-     case FcTypeRange:
-       if (sscanf ((char *) string, "[%lg %lg]", &b, &e) != 2)
-       {
--          v.u.d = strtod ((char *) string, &p);
--          if (p != NULL && p[0] != 0)
-+          char *sc, *ec;
-+          size_t len = strlen ((const char *) string);
-+          int si, ei;
-+
-+          sc = malloc (len);
-+          ec = malloc (len);
-+          if (sc && ec && sscanf ((char *) string, "[%s %[^]]]", sc, ec) == 2)
-           {
--              v.type = FcTypeVoid;
--              break;
-+              if (FcNameConstant ((const FcChar8 *) sc, &si) &&
-+                  FcNameConstant ((const FcChar8 *) ec, &ei))
-+                  v.u.r =  FcRangeCreateDouble (si, ei);
-+              else
-+                  goto bail1;
-+          }
-+          else
-+          {
-+          bail1:
-+              v.type = FcTypeDouble;
-+              if (FcNameConstant (string, &si))
-+              {
-+                  v.u.d = (double) si;
-+              } else {
-+                  v.u.d = strtod ((char *) string, &p);
-+                  if (p != NULL && p[0] != 0)
-+                      v.type = FcTypeVoid;
-+              }
-           }
--          v.type = FcTypeDouble;
-+          if (sc)
-+              free (sc);
-+          if (ec)
-+              free (ec);
-       }
-       else
-           v.u.r = FcRangeCreateDouble (b, e);
--- 
-cgit v1.1
-
-From 4699406a68321179b14fae7412f828e2f37a7033 Mon Sep 17 00:00:00 2001
-From: Akira TAGOH <akira@tagoh.org>
-Date: Wed, 14 Mar 2018 18:31:30 +0900
-Subject: Add the value of the constant name to the implicit object in the
- pattern
-
-For objects which has been changed the object type to FcTypeRange.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=105415
----
- src/fcname.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/fcname.c b/src/fcname.c
-index 15fb659..c9320ae 100644
---- a/src/fcname.c
-+++ b/src/fcname.c
-@@ -490,6 +490,10 @@ FcNameParse (const FcChar8 *name)
-                       if (!FcPatternAddBool (pat, c->object, c->value))
-                           goto bail2;
-                       break;
-+                  case FcTypeRange:
-+                      if (!FcPatternAddInteger (pat, c->object, c->value))
-+                          goto bail2;
-+                      break;
-                   default:
-                       break;
-                   }
--- 
-cgit v1.1
-
index 38092229d2726fb7759ee7a9eed46590c4c3f65e..50262d39d0d6d2d44836cb954f1709879deb550e 100644 (file)
@@ -8,16 +8,15 @@ Summary:      Font configuration and customization tools
 Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów
 Summary(pt_BR.UTF-8):  Ferramentas para configuração e customização do acesso a fontes
 Name:          fontconfig
-Version:       2.13.0
-Release:       3
+Version:       2.13.1
+Release:       1
 Epoch:         1
 License:       MIT
 Group:         Libraries
 Source0:       https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
-# Source0-md5: 60d2394a79d3b2e5db2daea55193fa47
+# Source0-md5: 36cdea1058ef13cbbfdabe6cb019dc1c
 Source1:       %{name}-lcd-filter.conf
 Patch0:                %{name}-bitstream-cyberbit.patch
-Patch1:                %{name}-constant-weight.patch
 URL:           http://fontconfig.org/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.11
@@ -130,7 +129,6 @@ Este pacote contém a biblioteca estática do fontconfig
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{__gettextize}
@@ -149,7 +147,7 @@ export HASDOCBOOK=no
        --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
 %{__make}
 
-%{?with_tests:%{__make} check || (cat test/test-suite.log && /bin/false)}
+%{?with_tests:%{__make} OSTYPE=linux check || (cat test/test-suite.log && /bin/false)}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.13795 seconds and 4 git commands to generate.