]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
47b92a6ff6261a12900e85fe1e8b14621b47ab57
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.12.3
12 Release:        1
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  872f757ec180e8c51918ff39705c40de
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11
23 %if %{with doc}
24 BuildRequires:  docbook-dtd31-sgml
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  docbook-utils >= 0.6.13-3
27 %endif
28 BuildRequires:  ed
29 BuildRequires:  expat-devel
30 BuildRequires:  freetype-devel >= 2.1.5
31 BuildRequires:  libtool >= 2:2.2
32 BuildRequires:  pkgconfig
33 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
34 Requires:       freetype >= 2.1.5
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Fontconfig is designed to locate fonts within the system and select
39 them according to requirements specified by applications.
40
41 This package contains tools and documentation.
42
43 %description -l pl.UTF-8
44 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
45 systemie i wybierania ich w zależności od potrzeb aplikacji.
46
47 Paket ten zawiera programy narzędziowe i dokumentację.
48
49 %description -l pt_BR.UTF-8
50 Fontconfig é uma biblioteca para configuração e customização do acesso
51 a fontes.
52
53 Este pacote contém as ferramentas e documentação.
54
55 %package libs
56 Summary:        Font configuration and customization library
57 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
58 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
59 Group:          Libraries
60 Requires:       freetype >= 2.1.5
61 Provides:       XFree86-fontconfig
62 Obsoletes:      XFree86-fontconfig
63 Conflicts:      fontconfig <= 1:2.2.98-1
64
65 %description libs
66 Fontconfig is designed to locate fonts within the system and select
67 them according to requirements specified by applications.
68
69 %description libs -l pl.UTF-8
70 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
71 systemie i wybierania ich w zależności od potrzeb aplikacji.
72
73 %description libs -l pt_BR.UTF-8
74 Fontconfig é uma biblioteca para configuração e customização do acesso
75 a fontes.
76
77 %package devel
78 Summary:        Font configuration and customization library - development files
79 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
80 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
81 Group:          Development/Libraries
82 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
83 Requires:       expat-devel
84 Requires:       freetype-devel >= 2.1.5
85 Provides:       XFree86-fontconfig-devel
86 Obsoletes:      XFree86-fontconfig-devel
87
88 %description devel
89 Fontconfig is designed to locate fonts within the system and select
90 them according to requirements specified by applications.
91
92 This package contains the header files needed to develop programs that
93 use these fontconfig.
94
95 %description devel -l pl.UTF-8
96 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
97 systemie i wybierania ich w zależności od potrzeb aplikacji.
98
99 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
100 programów korzystających z biblioteki fontconfig.
101
102 %description devel -l pt_BR.UTF-8
103 Fontconfig é uma biblioteca para configuração e customização do acesso
104 a fontes.
105
106 Este pacote contém arquivos de desenvolvimento necessários à criação
107 de extensões baseadas na biblioteca fontconfig.
108
109 %package static
110 Summary:        Static font configuration and customization library
111 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
112 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
115 Provides:       XFree86-fontconfig-static
116 Obsoletes:      XFree86-fontconfig-static
117
118 %description static
119 This package contains static version of fontconfig library.
120
121 %description static -l pl.UTF-8
122 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
123
124 %description static -l pt_BR.UTF-8
125 Este pacote contém a biblioteca estática do fontconfig
126
127 %prep
128 %setup -q
129 %patch0 -p1
130
131 %build
132 %{__libtoolize}
133 %{__aclocal} -I m4
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137
138 # don't rebuild docs by default, use prebuild ones
139 export HASDOCBOOK=no
140
141 %configure \
142         --enable-docs%{!?with_doc:=no} \
143         --disable-silent-rules \
144         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
145 %{__make}
146
147 %{?with_tests:%{__make} check}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT \
155         htmldoc_DATA= \
156         doc_DATA=
157
158 install %{SOURCE1} \
159         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
160
161 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
162
163 cp -pf conf.d/README README.confd
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %pretrans
169 # this needs to be a symlink
170 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
171         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
172         install -d %{_datadir}/%{name}/conf.avail
173         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
174         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
175         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
176 fi
177
178 %post
179 umask 022
180 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
181
182 %post   libs -p /sbin/ldconfig
183 %postun libs -p /sbin/ldconfig
184
185 %files
186 %defattr(644,root,root,755)
187 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
189 %{_sysconfdir}/fonts/conf.avail
190 %{_sysconfdir}/fonts/conf.d/README
191 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
192 %attr(755,root,root) %{_bindir}/fc-cache
193 %attr(755,root,root) %{_bindir}/fc-cat
194 %attr(755,root,root) %{_bindir}/fc-list
195 %attr(755,root,root) %{_bindir}/fc-match
196 %attr(755,root,root) %{_bindir}/fc-query
197 %attr(755,root,root) %{_bindir}/fc-pattern
198 %attr(755,root,root) %{_bindir}/fc-scan
199 %attr(755,root,root) %{_bindir}/fc-validate
200 %dir %{_datadir}/xml/%{name}
201 %{_datadir}/xml/%{name}/fonts.dtd
202 %{_datadir}/%{name}/conf.avail/*.conf
203 %if %{with doc}
204 %{_mandir}/man1/fc-*.1*
205 %{_mandir}/man5/fonts-conf.5*
206 %endif
207 %dir /var/cache/fontconfig
208
209 %files libs
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
213
214 %files devel
215 %defattr(644,root,root,755)
216 %doc doc/fontconfig-devel/*.html
217 %attr(755,root,root) %{_libdir}/libfontconfig.so
218 %{_libdir}/libfontconfig.la
219 %{_includedir}/fontconfig
220 %{_pkgconfigdir}/fontconfig.pc
221 %if %{with doc}
222 %{_mandir}/man3/Fc*.3*
223 %endif
224
225 %if %{with static_libs}
226 %files static
227 %defattr(644,root,root,755)
228 %{_libdir}/libfontconfig.a
229 %endif
This page took 0.102376 seconds and 2 git commands to generate.