]> git.pld-linux.org Git - packages/fontconfig.git/blame_incremental - fontconfig.spec
- don't rebuild docs that since these are already there
[packages/fontconfig.git] / fontconfig.spec
... / ...
CommitLineData
1# TODO:
2# - upgrade puts new files into /usr/share/fontconfig/conf.avail/*.conf
3# and also removes /etc/fonts/conf.avail/*.conf BUT there is a symlink
4# /etc/fonts/conf.avail/ -> /usr/share/fontconfig/conf.avail/ and in the end
5# rpm deletes freshly installed /usr/share/fontconfig/conf.avail/*.conf files
6
7# Conditional build
8%bcond_without static_libs # don't build static library
9%bcond_without doc
10#
11Summary: Font configuration and customization tools
12Summary(pl.UTF-8): Narzędzia do konfigurowania fontów
13Summary(pt_BR.UTF-8): Ferramentas para configuração e customização do acesso a fontes
14Name: fontconfig
15Version: 2.10.1
16Release: 0.1
17Epoch: 1
18License: MIT
19Group: Libraries
20Source0: http://fontconfig.org/release/%{name}-%{version}.tar.gz
21# Source0-md5: c94e380eea42f2f23ca9537035ef1899
22Source1: %{name}-lcd-filter.conf
23Patch0: %{name}-blacklist.patch
24Patch1: %{name}-bitstream-cyberbit.patch
25URL: http://fontconfig.org/
26BuildRequires: autoconf
27BuildRequires: automake
28%if %{with doc}
29BuildRequires: docbook-dtd31-sgml
30BuildRequires: docbook-dtd41-sgml
31BuildRequires: docbook-utils >= 0.6.13-3
32%endif
33BuildRequires: ed
34BuildRequires: expat-devel
35BuildRequires: freetype-devel >= 2.1.5
36BuildRequires: libtool
37BuildRequires: pkgconfig
38Requires: %{name}-libs = %{epoch}:%{version}-%{release}
39Requires: freetype >= 2.1.5
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43Fontconfig is designed to locate fonts within the system and select
44them according to requirements specified by applications.
45
46This package contains tools and documentation.
47
48%description -l pl.UTF-8
49Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
50systemie i wybierania ich w zależności od potrzeb aplikacji.
51
52Paket ten zawiera programy narzędziowe i dokumentację.
53
54%description -l pt_BR.UTF-8
55Fontconfig é uma biblioteca para configuração e customização do acesso
56a fontes.
57
58Este pacote contém as ferramentas e documentação.
59
60%package libs
61Summary: Font configuration and customization library
62Summary(pl.UTF-8): Biblioteka do konfigurowania fontów
63Summary(pt_BR.UTF-8): Biblioteca para configuração e customização do acesso a fontes
64Group: Libraries
65Requires: freetype >= 2.1.5
66Provides: XFree86-fontconfig
67Obsoletes: XFree86-fontconfig
68Conflicts: fontconfig <= 1:2.2.98-1
69
70%description libs
71Fontconfig is designed to locate fonts within the system and select
72them according to requirements specified by applications.
73
74%description libs -l pl.UTF-8
75Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
76systemie i wybierania ich w zależności od potrzeb aplikacji.
77
78%description libs -l pt_BR.UTF-8
79Fontconfig é uma biblioteca para configuração e customização do acesso
80a fontes.
81
82%package devel
83Summary: Font configuration and customization library - development files
84Summary(pl.UTF-8): Biblioteka do konfigurowania fontów - pliki dla programistów
85Summary(pt_BR.UTF-8): Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
86Group: Development/Libraries
87Requires: %{name}-libs = %{epoch}:%{version}-%{release}
88Requires: expat-devel
89Requires: freetype-devel >= 2.1.5
90Provides: XFree86-fontconfig-devel
91Obsoletes: XFree86-fontconfig-devel
92
93%description devel
94Fontconfig is designed to locate fonts within the system and select
95them according to requirements specified by applications.
96
97This package contains the header files needed to develop programs that
98use these fontconfig.
99
100%description devel -l pl.UTF-8
101Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
102systemie i wybierania ich w zależności od potrzeb aplikacji.
103
104Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
105programów korzystających z biblioteki fontconfig.
106
107%description devel -l pt_BR.UTF-8
108Fontconfig é uma biblioteca para configuração e customização do acesso
109a fontes.
110
111Este pacote contém arquivos de desenvolvimento necessários à criação
112de extensões baseadas na biblioteca fontconfig.
113
114%package static
115Summary: Static font configuration and customization library
116Summary(pl.UTF-8): Statyczna biblioteka do konfigurowania fontów
117Summary(pt_BR.UTF-8): Biblioteca estática para configuração e customização do acesso a fontes
118Group: Development/Libraries
119Requires: %{name}-devel = %{epoch}:%{version}-%{release}
120Provides: XFree86-fontconfig-static
121Obsoletes: XFree86-fontconfig-static
122
123%description static
124This package contains static version of fontconfig library.
125
126%description static -l pl.UTF-8
127Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
128
129%description static -l pt_BR.UTF-8
130Este pacote contém a biblioteca estática do fontconfig
131
132%prep
133%setup -q
134%patch0 -p1
135%patch1 -p1
136
137%build
138%{__libtoolize}
139%{__aclocal}
140%{__autoconf}
141%{__autoheader}
142%{__automake}
143
144# don't rebuild docs by default, use prebuild ones
145export HASDOCBOOK=no
146
147%configure \
148 --%{?with_doc:en}%{!?with_doc:dis}able-docs \
149 --disable-silent-rules \
150 %{!?with_static_libs:--disable-static}
151%{__make}
152
153%install
154rm -rf $RPM_BUILD_ROOT
155install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
156
157%{__make} install \
158 DESTDIR=$RPM_BUILD_ROOT \
159 htmldoc_DATA= \
160 doc_DATA=
161
162install %{SOURCE1} \
163 $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
164
165ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
166
167cp -f conf.d/README README.confd
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172%post
173umask 022
174HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
175
176%post libs -p /sbin/ldconfig
177%postun libs -p /sbin/ldconfig
178
179%files
180%defattr(644,root,root,755)
181%doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
182%dir %{_sysconfdir}/fonts
183%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
184%dir %{_datadir}/xml/%{name}
185%{_datadir}/xml/%{name}/fonts.dtd
186%{_sysconfdir}/fonts/conf.avail
187%dir %{_datadir}/%{name}/conf.avail
188%{_datadir}/%{name}/conf.avail/*.conf
189%dir %{_sysconfdir}/fonts/conf.d
190%{_sysconfdir}/fonts/conf.d/README
191%config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
192%attr(755,root,root) %{_bindir}/fc-cache
193%attr(755,root,root) %{_bindir}/fc-cat
194%attr(755,root,root) %{_bindir}/fc-list
195%attr(755,root,root) %{_bindir}/fc-match
196%attr(755,root,root) %{_bindir}/fc-query
197%attr(755,root,root) %{_bindir}/fc-pattern
198%attr(755,root,root) %{_bindir}/fc-scan
199%if %{with doc}
200%{_mandir}/man1/fc-*.1*
201%{_mandir}/man5/fonts-conf.5*
202%endif
203/var/cache/fontconfig
204
205%files libs
206%defattr(644,root,root,755)
207%attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
208%attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
209
210%files devel
211%defattr(644,root,root,755)
212%doc doc/fontconfig-devel/*.html
213%attr(755,root,root) %{_libdir}/libfontconfig.so
214%{_libdir}/libfontconfig.la
215%{_includedir}/fontconfig
216%{_pkgconfigdir}/fontconfig.pc
217%if %{with doc}
218%{_mandir}/man3/Fc*.3*
219%endif
220
221%if %{with static_libs}
222%files static
223%defattr(644,root,root,755)
224%{_libdir}/libfontconfig.a
225%endif
This page took 0.056554 seconds and 4 git commands to generate.