]> git.pld-linux.org Git - packages/folly.git/blame - folly.spec
up to 0.31.0
[packages/folly.git] / folly.spec
CommitLineData
d4b12164
ER
1# TODO
2# - add testing
987f958e
ER
3#
4# Conditional build:
5%bcond_without static_libs # don't build static libraries
6
94baf25c 7Summary: Library of C++11 components designed with practicality and efficiency in mind
987f958e 8Name: folly
d4b12164
ER
9Version: 0.31.0
10Release: 1
987f958e
ER
11License: Apache v2.0
12Group: Libraries
d4b12164
ER
13Source0: https://github.com/facebook/folly/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 40c654db9055e9dd735907b0a430c16b
4c898fa9 15URL: https://github.com/facebook/folly/blob/master/folly/docs/Overview.md
987f958e
ER
16BuildRequires: boost-devel >= 1.20.0
17BuildRequires: double-conversion-devel
75aeafe8 18BuildRequires: double-conversion-static
987f958e 19BuildRequires: gflags-devel
3a553404 20BuildRequires: glog-devel
987f958e
ER
21BuildRequires: gtest-devel >= 1.6.0
22BuildRequires: libstdc++-devel
d4b12164 23BuildRequires: rpmbuild(macros) >= 1.583
423f0b7b 24ExclusiveArch: %{x8664}
987f958e
ER
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
d4b12164
ER
27# missing openssl linking
28%define skip_post_check_so libfolly.so.31.0.0
29
987f958e 30%description
4c898fa9
ER
31Folly (acronymed loosely after Facebook Open Source Library) is a
32library of C++11 components designed with practicality and efficiency
33in mind. It complements (as opposed to competing against) offerings
34such as Boost and of course std. In fact, we embark on defining our
35own component only when something we need is either not available, or
36does not meet the needed performance profile.
37
38Performance concerns permeate much of Folly, sometimes leading to
39designs that are more idiosyncratic than they would otherwise be (see
40e.g. PackedSyncPtr.h, SmallLocks.h). Good performance at large scale
41is a unifying theme in all of Folly.
987f958e
ER
42
43%package devel
44Summary: Header files for %{name} library
45Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50Header files for %{name} library.
51
52%description devel -l pl.UTF-8
53Pliki nagłówkowe biblioteki %{name}.
54
55%package static
56Summary: Static %{name} library
57Summary(pl.UTF-8): Statyczna biblioteka %{name}
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60
61%description static
62Static %{name} library.
63
64%description static -l pl.UTF-8
65Statyczna biblioteka %{name}.
66
67%prep
d4b12164 68%setup -q
987f958e 69
d4b12164 70#ln -s %{_usrsrc}/gtest folly/test/gtest-1.7.0
987f958e
ER
71
72%build
73cd folly
74%{__libtoolize}
75%{__aclocal}
76%{__autoconf}
77%{__autoheader}
78%{__automake}
987f958e
ER
79%configure \
80 %{!?with_static_libs:--disable-static}
81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%{__make} -C folly install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88# these aren't supposed to be installed!
d4b12164 89#rm $RPM_BUILD_ROOT%{_libdir}/libgtest*
987f958e
ER
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
99%doc README LICENSE
100%attr(755,root,root) %{_libdir}/libfolly.so.*.*.*
d4b12164 101%ghost %{_libdir}/libfolly.so.31
987f958e 102%attr(755,root,root) %{_libdir}/libfollybenchmark.so.*.*.*
d4b12164 103%ghost %{_libdir}/libfollybenchmark.so.31
987f958e
ER
104
105%files devel
106%defattr(644,root,root,755)
107%{_libdir}/libfolly.so
108%{_libdir}/libfollybenchmark.so
987f958e
ER
109%{_libdir}/libfolly.la
110%{_libdir}/libfollybenchmark.la
987f958e
ER
111%{_includedir}/folly
112
113%if %{with static_libs}
114%files static
115%defattr(644,root,root,755)
116%{_libdir}/libfolly.a
117%{_libdir}/libfollybenchmark.a
987f958e 118%endif
This page took 0.072722 seconds and 4 git commands to generate.