]> git.pld-linux.org Git - packages/fnfx.git/blob - fnfx.spec
*** empty log message ***
[packages/fnfx.git] / fnfx.spec
1 Name:           fnfx
2 Version:        0.2
3 Release:        0.1
4 Summary:        Toshiba laptop function key utility
5 License:        GPL
6 URL:            http://fnfx.sf.net
7 Group:          System/Configuration/Hardware
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  fb0b2a9d6c5446a4615d907a572fd541
10 Source1:        %{name}.init
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12 Requires(post,preun):   /sbin/chkconfig
13
14 %description
15 FnFX enables owners of Toshiba laptops to change the LCD brightness,
16 control, the internal fan and use the special keys on their keyboard
17 (Fn-x combinations, hot-keys). The internal functions will give the
18 possibility to map the Fn-Keys to functions like volume up/down, mute,
19 suspend to disk, suspend to ram and switch LCD/CRT/TV-out. These
20 functions heavily depend on the system and/or kernel configuration.
21 You will need at least a kernel (v2.4.x, v2.5.x, v2.6.x) with ACPI and
22 Toshiba support (CONFIG_ACPI and CONFIG_ACPI_TOSHIBA).
23
24 %prep
25 %setup -q
26
27 %build
28 %configure
29 %{__make}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_initrddir}}
34 install -d $RPM_BUILD_ROOT/etc/fnfx
35 install src/{fnfx,fnfxd} $RPM_BUILD_ROOT%{_sbindir}
36 install etc/{fnfxd.conf,keymap} $RPM_BUILD_ROOT/etc/fnfx
37 install %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/fnfx
38
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post
44 /sbin/chkconfig --add %{name}
45 if [ -f /var/lock/subsys/%{name} ]; then
46         /etc/rc.d/init.d/%{name} restart >&2
47 else
48         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon." >&2
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         if [ -f /var/lock/subsys/%{name} ]; then
54                 /etc/rc.d/init.d/%{name} stop >&2
55         fi
56         /sbin/chkconfig --del %{name}
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_sbindir}/%{name}
62 %attr(755,root,root) %{_sbindir}/*
63 %dir %{_sysconfdir}/%{name}
64 %config(noreplace) %{_sysconfdir}/%{name}/*
65 %attr(754,root,root)  %{_initrddir}/%{name}
66
67 #%doc ChangeLog INSTALL AUTHORS README
This page took 0.141168 seconds and 3 git commands to generate.