]> git.pld-linux.org Git - packages/flyer.git/commitdiff
- initial master
authorZsolt Udvari <uzsolt@pld-linux.org>
Wed, 1 Oct 2008 19:37:27 +0000 (19:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    flyer-box2d-include-string.patch -> 1.1
    flyer-limits.patch -> 1.1
    flyer.spec -> 1.1

flyer-box2d-include-string.patch [new file with mode: 0644]
flyer-limits.patch [new file with mode: 0644]
flyer.spec [new file with mode: 0644]

diff --git a/flyer-box2d-include-string.patch b/flyer-box2d-include-string.patch
new file mode 100644 (file)
index 0000000..aa6a109
--- /dev/null
@@ -0,0 +1,50 @@
+--- flyer-0.1/Box2D/Collision/b2BroadPhase.cpp~        2008-10-01 09:25:40.000000000 +0200
++++ flyer-0.1/Box2D/Collision/b2BroadPhase.cpp 2008-10-01 20:40:48.000000000 +0200
+@@ -18,6 +18,7 @@
+ #include "b2BroadPhase.h"
+ #include <algorithm>
++#include <string.h>
+ // Notes:
+ // - we use bound arrays instead of linked lists for cache coherence.
+--- flyer-0.1/Box2D/Common/b2BlockAllocator.cpp~       2008-10-01 09:25:37.000000000 +0200
++++ flyer-0.1/Box2D/Common/b2BlockAllocator.cpp        2008-10-01 20:44:42.000000000 +0200
+@@ -20,6 +20,7 @@
+ #include <cstdlib>
+ #include <memory>
+ #include <climits>
++#include <string.h>
+ int32 b2BlockAllocator::s_blockSizes[b2_blockSizes] = 
+ {
+--- flyer-0.1/Box2D/Dynamics/Contacts/b2CircleContact.cpp~     2008-10-01 09:25:34.000000000 +0200
++++ flyer-0.1/Box2D/Dynamics/Contacts/b2CircleContact.cpp      2008-10-01 20:48:31.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "../../Common/b2BlockAllocator.h"
+ #include <new>
++#include <string.h>
+ b2Contact* b2CircleContact::Create(b2Shape* shape1, b2Shape* shape2, b2BlockAllocator* allocator)
+ {
+--- flyer-0.1/Box2D/Dynamics/Contacts/b2PolyAndCircleContact.cpp~      2008-10-01 09:25:34.000000000 +0200
++++ flyer-0.1/Box2D/Dynamics/Contacts/b2PolyAndCircleContact.cpp       2008-10-01 20:50:15.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "../../Common/b2BlockAllocator.h"
+ #include <new>
++#include <string.h>
+ b2Contact* b2PolyAndCircleContact::Create(b2Shape* shape1, b2Shape* shape2, b2BlockAllocator* allocator)
+ {
+--- flyer-0.1/Box2D/Dynamics/Contacts/b2PolyContact.cpp~       2008-10-01 09:25:34.000000000 +0200
++++ flyer-0.1/Box2D/Dynamics/Contacts/b2PolyContact.cpp        2008-10-01 20:51:46.000000000 +0200
+@@ -23,6 +23,7 @@
+ #include <memory>
+ #include <new>
++#include <string.h>
+ b2Contact* b2PolygonContact::Create(b2Shape* shape1, b2Shape* shape2, b2BlockAllocator* allocator)
+ {
diff --git a/flyer-limits.patch b/flyer-limits.patch
new file mode 100644 (file)
index 0000000..1de3439
--- /dev/null
@@ -0,0 +1,10 @@
+--- flyer-0.1/QPropertyEditor/Property.cpp~    2008-10-01 09:25:24.000000000 +0200
++++ flyer-0.1/QPropertyEditor/Property.cpp     2008-10-01 20:56:51.000000000 +0200
+@@ -25,6 +25,7 @@
+ #include <QtCore/QMetaProperty>
+ #include <QtGui/QSpinBox>
++#include <limits.h>
+ Property::Property(const QString& name /*= QString()*/, QObject* propertyObject /*= 0*/, QObject* parent /*= 0*/) : QObject(parent), 
+ m_propertyObject(propertyObject)
diff --git a/flyer.spec b/flyer.spec
new file mode 100644 (file)
index 0000000..98767bb
--- /dev/null
@@ -0,0 +1,43 @@
+Summary:       Flyer is a cool and fun 2D flight simulation
+Summary(hu.UTF-8):     Flyer egy nagyszerű és szórakoztató 2D repülő szimulátor
+Name:          flyer
+Version:       0.1
+Release:       0.1
+License:       GPL v2
+Group:         X11/Applications/Games
+Source0:       http://flyer2d.googlecode.com/files/%{name}-%{version}-src.tar.gz
+# Source0-md5: fc923a6272512f7e207661e57a908b79
+Patch0:                %{name}-box2d-include-string.patch
+Patch1:                %{name}-limits.patch
+URL:           http://code.google.com/p/flyer2d/
+BuildRequires: QtOpenGL-devel
+BuildRequires: qt4-qmake
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Flyer is a cool and fun 2D flight simulation.
+
+%description -l hu.UTF-8
+Flyer egy nagyszerű és szórakoztató 2D repülő szimulátor
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+qmake-qt4
+%{__make} CPPFLAGS="-include string.h"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
+install bin/* $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(755,root,root) %{_bindir}/*
This page took 0.09654 seconds and 4 git commands to generate.