]> git.pld-linux.org Git - packages/fluxbox.git/blob - fluxbox.spec
- Rs: WindowMaker, gxmessage to fix background setting
[packages/fluxbox.git] / fluxbox.spec
1 #
2 # Conditional build:
3 %bcond_without  imlib2          # disable imlib2 (pixmap themes) support
4 #
5 Summary:        Fluxbox - a windowmanager that is based on Blackbox
6 Summary(de.UTF-8):      Fluxbox - ein weiterer Window Manager für X
7 Summary(pl.UTF-8):      Mały i szybki zarządca okien dla X Window oparty o Blackbox
8 Summary(pt_BR.UTF-8):   Fluxbox é um gerenciador de janelas baseado no Blackbox
9 Name:           fluxbox
10 Version:        1.3.1
11 Release:        0.1
12 Epoch:          1
13 License:        MIT-like
14 Group:          X11/Window Managers
15 Source0:        http://downloads.sourceforge.net/fluxbox/%{name}-%{version}.tar.bz2
16 # Source0-md5:  0eaa940a69c0a876a520bb85d67b8bec
17 Source1:        %{name}.desktop
18 Source2:        %{name}-xsession.desktop
19 Source3:        %{name}-pld.style
20 Source4:        %{name}-pld.jpg
21 Source5:        %{name}.menu
22 URL:            http://fluxbox.org/
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.0.0}
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  xorg-lib-libXft-devel
29 BuildRequires:  xorg-lib-libXinerama-devel
30 %{?with_imlib2:BuildRequires:   xorg-lib-libXpm-devel}
31 BuildRequires:  xorg-lib-libXrandr-devel
32 Requires(post): vfmg >= 0.9.95
33 Requires:       WindowMaker
34 Requires:       gxmessage
35 Requires:       vfmg >= 0.9.16-3
36 Provides:       blackbox
37 Obsoletes:      blackbox
38 Conflicts:      filesystem < 3.0-20
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir     /etc/X11/%{name}
42 %define         _wmpropsdir     /usr/share/gnome/wm-properties
43
44 %description
45 Fluxbox is yet another windowmanager for X. It's based on the Blackbox
46 0.61.1 code. Fluxbox looks like blackbox and handles styles, colors,
47 window placement and similar thing exactly like blackbox (100%
48 theme/style compatibility). So what's the difference between fluxbox
49 and blackbox then? The answer is: LOTS! Have a look at the homepage
50 for more info ;)
51
52 %description -l pl.UTF-8
53 Fluxbox jest zarządcą okien dla X Window opartym na Blackboksie
54 0.61.1. Jego zaletą jest estetyczny i szybki interfejs z wieloma
55 pulpitami i prostym menu. Wbudowano weń także algorytm rysowania
56 dekoracji okien, które mogą być jednokolorowe, gradientowe lub
57 trójwymiarowe.
58
59 %description -l pt_BR.UTF-8
60 Fluxbox é um gerenciador de janelas para X. Ele é baseado no código do
61 Blackbox 0.61.1. Fluxbox tem a aparência do blackbox e pode utilizar
62 seus estilos, cores e temas. Então qual a diferença entre o fluxbox e
63 o blackbox?
64
65 %description -l de.UTF-8
66 Fluxbox ist ein weiterer Window Manager für X basierend auf dem
67 Quellcode von Blackbox 0.61.1. Fluxbox ähnelt Blackbox und behandelt
68 Styles, Farben, Fensterplatzierungen und ähnliche Dinge genauso wie
69 Blackbox. Es ist somit 100% kompatibel zu den Blackbox Themes und
70 Styles.
71
72 %prep
73 %setup -q
74
75 echo "session.screen0.antialias: true" >> data/init.in
76
77 %build
78 %{__libtoolize}
79 %{__aclocal} -I .
80 %{__autoheader}
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --enable-slit \
85         --enable-gnome \
86         --enable-xinerama \
87         --enable-nls \
88         --enable-xft \
89         --enable-randr \
90         %{?with_imlib2:--enable-imlib2}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_datadir}/{xsessions,wallpapers,%{name}/styles},%{_wmpropsdir}} \
97         $RPM_BUILD_ROOT%{_sysconfdir}
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
103 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
104 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{name}/styles/PLD
105 install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/wallpapers
106 install %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/fluxbox/menu
107 touch $RPM_BUILD_ROOT%{_sysconfdir}/menu2
108
109 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/fluxbox/nls/no*
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 # generate initial menu
116 [ -f /etc/sysconfig/vfmg ] && . /etc/sysconfig/vfmg
117 [ "$FLUXBOX" = yes -o "$FLUXBOX" = 1 -o ! -f %{_sysconfdir}/menu2 ] && \
118         vfmg fluxbox > %{_sysconfdir}/menu2 2>/dev/null ||:
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
123 %attr(755,root,root) %{_bindir}/fbrun
124 %attr(755,root,root) %{_bindir}/fbsetbg
125 %attr(755,root,root) %{_bindir}/fbsetroot
126 %attr(755,root,root) %{_bindir}/fluxbox
127 %attr(755,root,root) %{_bindir}/fluxbox-generate_menu
128 %attr(755,root,root) %{_bindir}/fluxbox-remote
129 %attr(755,root,root) %{_bindir}/fluxbox-update_configs
130 %attr(755,root,root) %{_bindir}/startfluxbox
131 %dir %{_sysconfdir}
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/menu2
133 %dir %{_datadir}/fluxbox
134 %{_datadir}/fluxbox/[!n]*
135 %dir %{_datadir}/fluxbox/nls
136 %{_datadir}/fluxbox/nls/C
137 %lang(be) %{_datadir}/fluxbox/nls/be*
138 %lang(bg) %{_datadir}/fluxbox/nls/bg*
139 %lang(cs) %{_datadir}/fluxbox/nls/cs*
140 %lang(da) %{_datadir}/fluxbox/nls/da*
141 %lang(de) %{_datadir}/fluxbox/nls/de*
142 %lang(el) %{_datadir}/fluxbox/nls/el*
143 %lang(en) %{_datadir}/fluxbox/nls/en*
144 %lang(es) %{_datadir}/fluxbox/nls/es*
145 %lang(et) %{_datadir}/fluxbox/nls/et*
146 %lang(fi) %{_datadir}/fluxbox/nls/fi*
147 %lang(fr) %{_datadir}/fluxbox/nls/fr*
148 %lang(it) %{_datadir}/fluxbox/nls/it*
149 %lang(ja) %{_datadir}/fluxbox/nls/ja*
150 %lang(ko) %{_datadir}/fluxbox/nls/ko*
151 %lang(lv) %{_datadir}/fluxbox/nls/lv*
152 %lang(mk) %{_datadir}/fluxbox/nls/mk_MK*
153 %lang(nb) %{_datadir}/fluxbox/nls/nb*
154 %lang(nl) %{_datadir}/fluxbox/nls/nl*
155 %lang(pl) %{_datadir}/fluxbox/nls/pl*
156 %lang(pt_BR) %{_datadir}/fluxbox/nls/pt_BR*
157 %lang(pt) %{_datadir}/fluxbox/nls/pt_PT*
158 %lang(ru) %{_datadir}/fluxbox/nls/ru*
159 %lang(sk) %{_datadir}/fluxbox/nls/sk*
160 %lang(sl) %{_datadir}/fluxbox/nls/sl*
161 %lang(sv) %{_datadir}/fluxbox/nls/sv*
162 %lang(tr) %{_datadir}/fluxbox/nls/tr*
163 %lang(uk) %{_datadir}/fluxbox/nls/uk*
164 %lang(vi) %{_datadir}/fluxbox/nls/vi*
165 %lang(zh_CN) %{_datadir}/fluxbox/nls/zh_CN*
166 %lang(zh_TW) %{_datadir}/fluxbox/nls/zh_TW*
167 %{_datadir}/xsessions/%{name}.desktop
168 %{_wmpropsdir}/fluxbox.desktop
169 %{_datadir}/wallpapers/*.jpg
170 %{_mandir}/man1/*.1*
171 %{_mandir}/man5/*.5*
This page took 0.064172 seconds and 3 git commands to generate.