]> git.pld-linux.org Git - packages/fluxbox.git/blob - fluxbox.spec
b0deead30b891afbd503c356772df72b3efd305c
[packages/fluxbox.git] / fluxbox.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome           # build with support for GNOME2 wm-properties
4 %bcond_without  imlib2          # disable imlib2 (pixmap themes) support
5 #
6 Summary:        Fluxbox - a windowmanager that is based on Blackbox
7 Summary(de.UTF-8):      Fluxbox - ein weiterer Window Manager für X
8 Summary(pl.UTF-8):      Mały i szybki zarządca okien dla X Window oparty o Blackbox
9 Summary(pt_BR.UTF-8):   Fluxbox é um gerenciador de janelas baseado no Blackbox
10 Name:           fluxbox
11 Version:        1.3.1
12 Release:        2
13 Epoch:          1
14 License:        MIT-like
15 Group:          X11/Window Managers
16 Source0:        http://downloads.sourceforge.net/fluxbox/%{name}-%{version}.tar.bz2
17 # Source0-md5:  0eaa940a69c0a876a520bb85d67b8bec
18 Source1:        %{name}.desktop
19 Source2:        %{name}-xsession.desktop
20 Source3:        %{name}-pld.style
21 Source4:        %{name}-pld.jpg
22 Source5:        %{name}.menu
23 URL:            http://fluxbox.org/
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_imlib2:BuildRequires:   imlib2-devel >= 1.0.0}
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 BuildRequires:  xorg-lib-libXft-devel
30 BuildRequires:  xorg-lib-libXinerama-devel
31 %{?with_imlib2:BuildRequires:   xorg-lib-libXpm-devel}
32 BuildRequires:  xorg-lib-libXrandr-devel
33 Requires(post): vfmg >= 0.9.95
34 Requires:       WindowMaker >= 0.92.0-13
35 Requires:       gxmessage
36 Requires:       vfmg >= 0.9.16-3
37 Provides:       blackbox
38 Obsoletes:      blackbox
39 Conflicts:      filesystem < 3.0-20
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sysconfdir     /etc/X11/%{name}
43 %define         _wmpropsdir     /usr/share/gnome/wm-properties
44
45 %description
46 Fluxbox is yet another windowmanager for X. It's based on the Blackbox
47 0.61.1 code. Fluxbox looks like blackbox and handles styles, colors,
48 window placement and similar thing exactly like blackbox (100%
49 theme/style compatibility). So what's the difference between fluxbox
50 and blackbox then? The answer is: LOTS! Have a look at the homepage
51 for more info ;)
52
53 %description -l pl.UTF-8
54 Fluxbox jest zarządcą okien dla X Window opartym na Blackboksie
55 0.61.1. Jego zaletą jest estetyczny i szybki interfejs z wieloma
56 pulpitami i prostym menu. Wbudowano weń także algorytm rysowania
57 dekoracji okien, które mogą być jednokolorowe, gradientowe lub
58 trójwymiarowe.
59
60 %description -l pt_BR.UTF-8
61 Fluxbox é um gerenciador de janelas para X. Ele é baseado no código do
62 Blackbox 0.61.1. Fluxbox tem a aparência do blackbox e pode utilizar
63 seus estilos, cores e temas. Então qual a diferença entre o fluxbox e
64 o blackbox?
65
66 %description -l de.UTF-8
67 Fluxbox ist ein weiterer Window Manager für X basierend auf dem
68 Quellcode von Blackbox 0.61.1. Fluxbox ähnelt Blackbox und behandelt
69 Styles, Farben, Fensterplatzierungen und ähnliche Dinge genauso wie
70 Blackbox. Es ist somit 100% kompatibel zu den Blackbox Themes und
71 Styles.
72
73 %prep
74 %setup -q
75
76 echo "session.screen0.antialias: true" >> data/init.in
77
78 %build
79 %{__libtoolize}
80 %{__aclocal} -I .
81 %{__autoheader}
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         --enable-slit \
86         --enable-gnome \
87         --enable-xinerama \
88         --enable-nls \
89         --enable-xft \
90         --enable-randr \
91         %{?with_imlib2:--enable-imlib2}
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_datadir}/{xsessions,wallpapers,%{name}/styles},%{_wmpropsdir}} \
98         $RPM_BUILD_ROOT%{_sysconfdir}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{?with_gnome:install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}}
104 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
105 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{name}/styles/PLD
106 install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/wallpapers
107 install %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/fluxbox/menu
108 touch $RPM_BUILD_ROOT%{_sysconfdir}/menu2
109
110 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/fluxbox/nls/no*
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 # generate initial menu
117 [ -f /etc/sysconfig/vfmg ] && . /etc/sysconfig/vfmg
118 [ "$FLUXBOX" = yes -o "$FLUXBOX" = 1 -o ! -f %{_sysconfdir}/menu2 ] && \
119         vfmg fluxbox > %{_sysconfdir}/menu2 2>/dev/null ||:
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
124 %attr(755,root,root) %{_bindir}/fbrun
125 %attr(755,root,root) %{_bindir}/fbsetbg
126 %attr(755,root,root) %{_bindir}/fbsetroot
127 %attr(755,root,root) %{_bindir}/fluxbox
128 %attr(755,root,root) %{_bindir}/fluxbox-generate_menu
129 %attr(755,root,root) %{_bindir}/fluxbox-remote
130 %attr(755,root,root) %{_bindir}/fluxbox-update_configs
131 %attr(755,root,root) %{_bindir}/startfluxbox
132 %dir %{_sysconfdir}
133 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/menu2
134 %dir %{_datadir}/fluxbox
135 %{_datadir}/fluxbox/[!n]*
136 %dir %{_datadir}/fluxbox/nls
137 %{_datadir}/fluxbox/nls/C
138 %lang(be) %{_datadir}/fluxbox/nls/be*
139 %lang(bg) %{_datadir}/fluxbox/nls/bg*
140 %lang(cs) %{_datadir}/fluxbox/nls/cs*
141 %lang(da) %{_datadir}/fluxbox/nls/da*
142 %lang(de) %{_datadir}/fluxbox/nls/de*
143 %lang(el) %{_datadir}/fluxbox/nls/el*
144 %lang(en) %{_datadir}/fluxbox/nls/en*
145 %lang(es) %{_datadir}/fluxbox/nls/es*
146 %lang(et) %{_datadir}/fluxbox/nls/et*
147 %lang(fi) %{_datadir}/fluxbox/nls/fi*
148 %lang(fr) %{_datadir}/fluxbox/nls/fr*
149 %lang(it) %{_datadir}/fluxbox/nls/it*
150 %lang(ja) %{_datadir}/fluxbox/nls/ja*
151 %lang(ko) %{_datadir}/fluxbox/nls/ko*
152 %lang(lv) %{_datadir}/fluxbox/nls/lv*
153 %lang(mk) %{_datadir}/fluxbox/nls/mk_MK*
154 %lang(nb) %{_datadir}/fluxbox/nls/nb*
155 %lang(nl) %{_datadir}/fluxbox/nls/nl*
156 %lang(pl) %{_datadir}/fluxbox/nls/pl*
157 %lang(pt_BR) %{_datadir}/fluxbox/nls/pt_BR*
158 %lang(pt) %{_datadir}/fluxbox/nls/pt_PT*
159 %lang(ru) %{_datadir}/fluxbox/nls/ru*
160 %lang(sk) %{_datadir}/fluxbox/nls/sk*
161 %lang(sl) %{_datadir}/fluxbox/nls/sl*
162 %lang(sv) %{_datadir}/fluxbox/nls/sv*
163 %lang(tr) %{_datadir}/fluxbox/nls/tr*
164 %lang(uk) %{_datadir}/fluxbox/nls/uk*
165 %lang(vi) %{_datadir}/fluxbox/nls/vi*
166 %lang(zh_CN) %{_datadir}/fluxbox/nls/zh_CN*
167 %lang(zh_TW) %{_datadir}/fluxbox/nls/zh_TW*
168 %{_datadir}/xsessions/%{name}.desktop
169 %{?with_gnome:%{_wmpropsdir}/fluxbox.desktop}
170 %{_datadir}/wallpapers/*.jpg
171 %{_mandir}/man1/*.1*
172 %{_mandir}/man5/*.5*
This page took 0.092705 seconds and 2 git commands to generate.