]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
0.4.1
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Name:           flux
3 Version:        0.4.1
4 Release:        1
5 Group:          Libraries
6 Group(pl):      Biblioteki
7 Copyright:      GPL
8 Source:         ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
9 URL:            http://projects.simplemente.net/flux/
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %description
13 Flux is a survival-through-structure library, whose goal is to reduce the
14 complexity of C programming. To this end, it supplies high-level functions
15 for manipulating data and communication with specialized handles, masking
16 typically tedious programming tasks. Common instruction blocks are wrapped
17 in higher-level calls with intuitive names. In short: Do it once, do it
18 right, then forget about it.
19
20 Abstracting things this way involves speed compromises. In Flux, these
21 should be minimal, and sometimes, when superiour algorithms are easily
22 accessible, efficiency is actually gained.
23
24 Another important goal is bridging gaps between typical tasks - like
25 parsing, storage, retrieval, buffering and transfer, data structures - like
26 generic tree structures, generic network structures, XML and presentation
27 formats, and protocols - like FluxComm, Unix protocols and IRC. (Note: IRC
28 protocols are hairy and ill-defined. Unification and masking is particularly
29 useful here).
30
31 %package devel
32 Summary:        Header files and development documentation for flux
33 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
34 Group:          Development/Libraries
35 Group(pl):      Programowanie/Biblioteki
36 Requires:       %{name} = %{version}
37
38 %description devel
39 Header files and development documentation for flux.
40
41 %description -l pl devel
42 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
43
44 %package static
45 Summary:        Static flux libraries
46 Summary(pl):    Biblioteki statyczne flux
47 Group:          Development/Libraries
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 Static flux libraries.
53
54 %description -l pl static
55 Biblioteki statyczne flux.
56
57 %prep
58 %setup -q
59
60 %build
61 LDFLAGS="-s"; export LDFLAGS
62 %configure
63 echo n | make
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 make install DESTDIR=$RPM_BUILD_ROOT
69
70 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
71
72 gzip -9nf AUTHORS README NEWS TODO 
73
74 %find_lang %{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/lib*.so.*.*
85
86 %files devel
87 %defattr(644,root,root,755)
88 %doc *.gz doc/*
89 %attr(755,root,root) %{_libdir}/lib*.so
90 %attr(755,root,root) %{_libdir}/lib*.la
91 %{_includedir}/*
92
93 %files static
94 %attr(644,root,root) %{_libdir}/lib*.a
95
96 %changelog
This page took 0.06484 seconds and 4 git commands to generate.