]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- added patch AC_C_BIGENDIAN for use system avalaible AC_C_BIGENDIAN aclocal macro.
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        3
6 License:        GPL
7 Group:          Libraries
8 Group(de):      Libraries
9 Group(es):      Bibliotecas
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Group(pt_BR):   Bibliotecas
13 Group(ru):      âÉÂÌÉÏÔÅËÉ
14 Group(uk):      â¦Â̦ÏÔÅËÉ
15 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
17 Patch1:         %{name}-acinclude_fix.patch
18 Patch2:         %{name}-am15.patch
19 Patch3:         %{name}-AC_C_BIGENDIAN.patch
20 URL:            http://projects.simplemente.net/flux/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Flux is a survival-through-structure library, whose goal is to reduce
28 the complexity of C programming. To this end, it supplies high-level
29 functions for manipulating data and communication with specialized
30 handles, masking typically tedious programming tasks. Common
31 instruction blocks are wrapped in higher-level calls with intuitive
32 names. In short: Do it once, do it right, then forget about it.
33
34 Abstracting things this way involves speed compromises. In Flux, these
35 should be minimal, and sometimes, when superiour algorithms are easily
36 accessible, efficiency is actually gained.
37
38 Another important goal is bridging gaps between typical tasks - like
39 parsing, storage, retrieval, buffering and transfer, data structures -
40 like generic tree structures, generic network structures, XML and
41 presentation formats, and protocols - like FluxComm, Unix protocols
42 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
43 and masking is particularly useful here).
44
45 %description -l pl
46 Flux jest bibliotek± typu "survival-through-structure", której celem
47 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
48 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
49 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
50 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
51 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
52 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
53 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
54 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
55 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
56 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
57 transfer), strukturami danych (generyczne struktury drzew, generyczne
58 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
59 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
60 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
61 ukazuj± swoja warto¶æ).
62
63 %package devel
64 Summary:        Header files and development documentation for flux
65 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
66 Group:          Development/Libraries
67 Group(de):      Entwicklung/Libraries
68 Group(es):      Desarrollo/Bibliotecas
69 Group(fr):      Development/Librairies
70 Group(pl):      Programowanie/Biblioteki
71 Group(pt_BR):   Desenvolvimento/Bibliotecas
72 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
73 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
74 Requires:       %{name} = %{version}
75
76 %description devel
77 Header files and development documentation for flux.
78
79 %description -l pl devel
80 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
81
82 %package static
83 Summary:        Static flux libraries
84 Summary(pl):    Biblioteki statyczne flux
85 Group:          Development/Libraries
86 Group(de):      Entwicklung/Libraries
87 Group(es):      Desarrollo/Bibliotecas
88 Group(fr):      Development/Librairies
89 Group(pl):      Programowanie/Biblioteki
90 Group(pt_BR):   Desenvolvimento/Bibliotecas
91 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
92 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
93 Requires:       %{name}-devel = %{version}
94
95 %description static
96 Static flux libraries.
97
98 %description -l pl static
99 Biblioteki statyczne flux.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107
108 %build
109 rm -f missing
110 libtoolize --copy --force
111 aclocal
112 autoconf
113 automake -a -c
114 %configure
115 echo n | %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install DESTDIR=$RPM_BUILD_ROOT
121
122 gzip -9nf AUTHORS README NEWS TODO 
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.so.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %doc *.gz doc/*
137 %attr(755,root,root) %{_libdir}/lib*.so
138 %attr(755,root,root) %{_libdir}/lib*.la
139 %{_includedir}/*
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/lib*.a
This page took 0.078726 seconds and 4 git commands to generate.